Tidal playback stalling on Airplay devices

Roon Core Machine

Rock 1.8 Build 884, NUC 7i5, 16GB Ram, M.2 250GB, 2TB ext SSD

Networking Gear & Setup Details

NUC → Draytek Vigor 2920n via Ethernet, Ethernet → Ubiquity UAP-AC-Pro Access Point,

Connected Audio Devices

5 * Libratone Zipp wireless airplay devices
2 * RoPieee endpoints + 2 RoPieee screens
Various iPads, iPhones & Macs functioning as endpoints or remotes.

Number of Tracks in Library

45000 tracks

Description of Issue

When playing to airplay devices a mix of library and tidal/qobuz tracks, for example in a playlist (or radio play) transport pauses when the new track loads.

This equipment has previously functioned successfully for 3+ years, the problem behaviour began before Christmas.

RoPieee endpoints still function properly. Checked logs and discovered the airplay devices are suspending playback.

message from logs - received transport control from endpoint integration: suspend

I have tried starting a blank system, problem still persists ( I do have logs from that effort too)

To reiterate, this system has been working fine until December.

I am using cloudflare DNS and every item on the network that has an ethernet port is hardwired. I use static IP addresses set by the Draytek router.

The problem is entirely repeatable although roughly once in 25 times it might work properly.

I understand that these problems are often attributed to network issues but I’m not sure why Tidal works fine to RoPieee endpoints using the same router/fibre connection but Airplay devices are suspending playback while waiting for the stream.

I have tried playlists where the tracks are both 44/16 to see if it’s an aspect of data conversion, I’ve tried Qobuz instead of Tidal in case it’s MQA that’s a problem. I’m getting 99% wifi experience on the endpoints in the Ubiquity software suggesting there’s no problem with the wifi connection. I moved the RoPieee endpoints to WiFi and they are able to stream at 96/24 without problem.

I’ve tried breaking up the group of endpoints and streaming to just one, the problem persists. I’ve tried swapping the Ubiquity access point. Factory reset the Libratone endpoints. Logged out of Tidal on any other devices.

The problem also occurs when going from Tidal to Library files. I have tried changing the streaming quality in Tidal settings, problem persists.

When the problem occurs the loading bar appears for a few seconds and the pause symbol changes to a play symbol. Play stops. Play can be started by pressing the play button.

All other endpoints work fine, the Libratone endpoints have been working without problems for years.

Everything has been rebooted, firmware is all up to date. I have been testing to find a solution over the last 3 weeks. The Libratone have no ethernet connectability.

Hey @Andy_Jones thanks so much for bringing this to our attention, we’re sorry for the trouble you’re having with AirPlay!

We’d like to take a look at the logs so that we can have a better look at what may be happening. Can you please reproduce the issue, note the exact local time + date + track and use the directions found here and send over a set of logs to our File Uploader?

Let me know and we’ll be sure to take a look! Thanks! :pray:t3:

Hi Ashley, I have some logs already prepared according to your faq which I will send you. These logs were prepared yesterday and contain results from 2 different Rock states.

One is my normal Roon setup following restoration of the backup (having tried the clean setup which is also logged below) and all the logs contain is failures to play tracks corresponding to my description of the problem.

The second set are described in the filename but they contain the logs from a clean setup of the Roon database and subsequent testing which failed.

Either of these logs only contain activity from 11th January in the evening GMT. I’ve tested with multiple tracks but the 2 predominant ones are J. Dilla - Stop! followed by Celeste - Strange. (See what I did there?)

I just got a page saying ‘Link no longer valid’ when I clicked on your File Uploader link. Not a very good start is it?

My apologies that the link wasn’t working, I have sent you a reply to the private message you sent me and made sure to attach a working link for you to upload the logs.

Thanks Ashley, I’ve sent the files.

I have another problem with Tidal, if I adjust the streaming rate to the lowest quality I just get 2 seconds of digital screeching per track instead of music from Tidal.

Maybe I’ll start a new thread for that?

Hey @Andy_Jones thanks so much for your patience while we reviewed the logs you sent over (I’m happy to hear the link worked!)

When reviewing the logs, we saw traces of airplay packets being lost. We’re wondering if you can try to play to an iOS device (such as an iPhone/iPad) and then use the iOS system to Airplay to the Libratone speaker. You can do this by selecting your iOS Roon Remote as the zone, then going to your phone’s dropdown menu and selecting the Airplay option for the Libratone speaker.

Does the same issue occur when trying this (bypassing the Core and going straight to Airplay)?

If you’re willing, could you also temporarily host the Roon Core on the Mac device you have?

As far as the screeching issue, would you be able to provide us with a video with sound, so that we can see/hear exactly what you’re experiencing?

Thanks so much, Andy; I look forward to your reply!

Hi Ashley,

I’ve tested the iOS->Libraton connection as described. It works as it should, no halting.

I’ve also recorded the bleeping. It sounds like some ‘failure to change format’ digital noise from my experience. To clarify, this happens when I switch to Normal in Tidal settings.

I did start to run the Mac Pro as a core the other day. I started that way with Roon years ago. I switch off the Rock but it still detects I am signed in elsewhere and asks me to sign in on the Mac Pro. If I do this my Rock setup is kept safely and I only need to sign back in once the test is done?

Do you want to send me a link for the audio file?

Thanks so much for testing that for us! The next step would be to switch your Core and try to stream via Airplay normally using the new Core device. Before switching to the Mac Pro, you’ll want to create a Backup of your Roon data so that when you switch back to the ROCK core, all of your edits and settings will be presevered. If you have a backup, you can “unauthorize” the ROCK Core and use the Mac as your Core. These instructions might be helpful to you when switching between Core devices.

My apologies for not providing a link to upload the audio file right away, I wanted to see if that was something you were comfortable with, first.

You can upload that audio file here: Media Upload Once you’ve uploaded the file, let me know and we can give it a listen!

Thanks, Andy!

Hi Ashley, I’ll try and get round to testing the core on a different machine. Got a lot on this week though.

Not a problem, I’m interested to see how this goes. I’ll wait for your follow up!

I’m also wondering if, when you switch to using the Mac Core, can you please try lowering the streaming quality of TIDAL and try to reproduce the “screeching” noise? I was able to review the media file you uploaded and we’d like to see if it happens when using the Mac, as well.

Managed to switch my core to the Mac Pro. So far playing without any problem. I am leaving the core on the MAc Pro for as short a time as possible but please let me know if you need logs.

I have also tried adjusting the Tidal playback quality to normal and don’t get any ‘digital screech’ from any endpoints.

@Andy_Jones thanks so much for giving that a try, it’s helpful to hear that it’s not occurring on the Mac Core.

We wanted to ask, how is the Mac Core connected, is it the same way that your Linux Core was connected?

It might be helpful to lay out the connection in the same way you did in your initial post:

If you’re able to connect the Mac like you did with the Linux, are you able to reproduce the issue while using the Mac Core?

It’s already connected by ethernet to a different port on the same router as the linux core.

I have changed the ethernet cable for the linux core (I assume this means ROCK in different terms) but I’m waiting to hear from you before I go back to that setup.

Perfect, thank you for confirming how it’s connected. Since it’s connected in the same way as the Linux Core (ROCK, you’re right), we’d like to take a look at the logs.

Can you please stream via Airplay to the Libratone using the Mac Core, note the exact local time + date + track and use the directions found here and send over a set of logs to our File Uploader?

Please let me know once they’re uploaded and I’ll be sure to have our technical support team review them! Thanks, Andy!

1 Like

I’ve just run a mixed playlist for 1/2 an hour and sent the logs. Log time of interest will be 15:00-15:30 28/01/22.

I noticed in the logs there are a few packets lost but nothing hanging up playback.

I had failed to check that I had WiFi off on the mac pro so it’s effectively connected by ethernet and wifi. I have run it with wifi off and no change in performance. I’m reasonably sure it’s actually using the ethernet connection in any case but thought I should let you know.

I’m happy to prepare more logs at a later date but I’m preparing for a gig this weekend so I can’t do anything more right now.

Just tried the new release on the ROCK. No dice. Stalled after the second switch from library 96/24 to Tidal.

Hi @Andy_Jones ,

Are you saying that the playback hung during this time? It looks like there were some airplay dropouts then the play/pause button was clicked: 01/28 15:26:40 Info: [ui] [popups] Pause button clicked: play_pause()

Also, it looks like you are playing to these zones as a group, can you please confirm if the issue also happens if you play to them individually?

This is made pretty hard to answer by the 8 day delay!

As far as I can remember there was no pause button pressed. I would have pressed play to restart the playlist.

It has never made a difference whether they are grouped or individual.

In the last few days I have been using Roon radio and it chooses very few tidal tracks which is unusual but does help to avoid stalling. It does still stall occasionally.

Hi @Andy_Jones ,

Can you let me know the time + date + track it stalls on? Having the track as well can help us focus on one specific area of the log.