Tidal streaming extremely slow or not even start

Hi @support;
I am currently on free trial. I’m having issues with Tidal streaming. Its so slow to start playing so I gave up playing Tidal using Roon. Sometimes it started to play but then stutter or stopped after a few seconds.

Roon core installed on Qnap 453B Mini with 4GB Ram. End point is the new Naim ND555. I am trying to pin point the culprit. No issue with local streaming though.

I tried installed Roon in my iMac and there is no problem with Tidal at all!

Can someone please tell me what is the cause of the Tidal streaming issues when running Roon in my Qnap NAS?
CPU not powerful enoght for Roon?
Need SSD Cache?
NAS network settings?
Not enough RAM?

I really like Roon but I need to know if I can run Roon Core in my Qnap NAS or need to purchase a dedicated hardware like Nucleaus or Intel NUC.

Please point me at the right direction soon

Thanks for reaching out, @Eddie_Hsu!

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Is there any difference in how your NAS and iMac are connected to the network?

In the past we have seen Google DNS help with similar reports. Can you try using Google DNS and let us know if you notice a change?

I also notice that the QNAP 453B you’re using for your Roon Core falls short of our recommended specs.

Because this device uses a Celeron processor you may experience performance issues, particularly with larger libraries or DSP, or if you don’t use an SSD for your Roon database.

It’s hard to say whether the issues you’re experiencing are related to performance, but we do like to give people a “heads up” when their system is under spec, since it can impact the product in a number of ways, and you may encounter some limitations going forward.


Hi Dylan;

The QNAP NAS is connected by ethernet 1+2 but iMAC is connected wirelessly. The end point and NAS are all connected to the same Netgear Switch. My wifi router is also Netgear R8000 AC3200. Our internet is still copper, awaiting for fibre connection in my area within a couple of months. However, I do not think its an issue because there is no problem with Tidal streaming using my Mac as Core. Core on my iMAC works flawless with Roon Tidal.
One thing to note here is that I also having trouble with Tidal streaming using Squeezebox server installed on my old back up Netgear NAS. Slightly different issue as it will stream 1 track then server will crash then took a long time to restart. Again, it runs smoothly if I change LMS server onto my iMAC. The common issue is Tidal but reacted differently.
I did have Google as my secondary DNS in my NAS. Used or Same problem.
I can not see any overloading of CPU or RAM in the QNAP Resource Monitor. I could see that network is an issue as it shows almost no downloading traffic when I ask Roon to stream Tidal. I meant it started ok then abruptly stopped after a few seconds. Or it is not starting at all!
It puzzles me as I did not see stressed CPU or RAM and Roon works fine in iMAC. I just dont want to spend money on an SSD if that is not the cause.



Thanks for the update here, @Eddie_Hsu!

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here. The diagnostics report may be able to give the team a little more information about what is occurring here (i.e. if this is a hardware issue, or something else)

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


1 Like

Hi @dylan;

That is easy to reproduce the issue. I just hit PLAY any tidal album :slight_smile: Its 2:14am on 25 Sept New Zealand time.
And I just hit play 1 Tidal track again and it refused to start playing at 2:18am. So basically I waited 4 min from 2:14am for Tidal album to play without any luck. So I gave up and tried to hit a single track at 2:18am and now it started to play that track at 2:20am. So 2 minutes buffer to play 1 track! I had no such problem when Roon was in my iMac. It was immediate.
And now I just tried and hit PLAY an album at 2:28am and its 2:31am now and still waiting…
Hope these info helps.

Thanks, @Eddie_Hsu!

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


Update — The report has been received

Hi @dylan:

Well, it is active now. What do I have to do? Keep trying to play Tidal?

Will you see a report including the timestamps I gave you if you only just enabled diagnostics?



Thank you for your patience while we’ve looked into this, @Eddie_Hsu!

I spoke with the team regarding their findings in the diagnostics report and wanted to follow up with you.

The team is seeing some networking errors in the logs which seems to be the cause for what you’re seeing.

Could you elaborate on the above? How exactly is the QNAP connected to the network?


Hi @dylan;
My NAS is capable of Link Aggregation but my switch is not so it sets 1+2 balanced-alb with both ethernet connected. I have purchased a ASUS VivoMini with i7, 8GB RAM and 256BG SSD yesterday to run my various servers now. So this Tidal issue is solved now. Roon is no longer in my NAS.
Another question, is there an easy way to disable the Roon Core in my iMAC so my Remote won’t see various Cores? I tried Configure Roon OS under Setting but it just kept searching then stop :frowning:


Hey @Eddie_Hsu,

Glad things are working for you now!

First, I’d make sure you have a backup of your database if you don’t have one already.

Are you wanting to still use the iMac as a remote, or not at all?

Hi @dylan;
I will use my ASUS Mini as a dedicated server in the house now so do not really need another Core on the MAC.



Thanks for the info!

Once you have a backup, you can do the following on the old Mac Core:

  • Shut down your Roon Core
  • Locate your Roon database according to these instructions
  • Rename the entire Roon folder to roon_old

From there you should be able to use your Mac just as a remote unless you configure it to be a Core again.

Let me know if you have any questions!

A post was split to a new topic: TIDAL playback trouble with NAS Core