Tidal tracks available to browse, but will not play

Hi using a new NUK,Rock from, CAT 6E, to BT smart hub 2… NUK runs all my library music off hard disk storage…But as above lists all Tidal tracks available to browse, but will not play… says Too many failures Tidal stopped playing,
The Smart Hub 2 cannot be changed to try the Google DNS…
We have tried everything, ports are set to 9000 to 9300
My Laptop works perfectly, in the same position on the end of the same cable… Never misses a beat…
We are at a loss!

Hi @mark_Manwaring-White,

Welcome to the forum! Can you please share a screenshot of your ROCK’s Web UI?

Hi, I assume that is this…



You might try setting your DNS server to (cloudflare/apnic) or (google) and see if that helps.

sadly using the BT Smart Hub 2, one can not change the DNS address…
However my laptop works perfectly in the same situation running W10, wlth no playing probems at all…

By that, I assume you mean running RoonServer on the Win10 machine works fine. Or, do you mean running the Tidal app?

Yikes! I have my ROCK set to Static IP which allows me to set a DNS address in ROCK. But, if you try it be careful, any mistakes in the IP addresses can make it difficult to recover as you would lose web access and there is no command line access for ROCK.

Bit of a worry really…what I do not understand is why is does not work with the BT server’s DNS…Is this a fault with Tidal or Roon’s handling of Tidal?
Either way there should be a proper fix, to sort the problems., not just get round it and use a crack for the symptoms!? :wink:

I use the W10 laptop as a temporary server, whilst Rock is not working… Runs Roon and Tidal perfectly, with the same DNS settings that maybe stopping the Rock…
Also Rock seems to play if the firewall is turned off in the router…
I have set ports 9000 - 9300 on the router, are ther any other ports to add?


When it comes to ports see:

However you have those covered already. Hmm, so if you turn off the firewall, Rock works?

Well, there was this post that found more ports were needed:

If you have a few quid, you can fleabay and replace the 2 with the BT Business Smarthub 6 version 088315. As well as being a better hub it allows you to change the DNS server settings.

Thank you every one for the help and suggestions…I will add the extra ports first incase that works!
Then go for a new BT business Hub, hopefully it woorks with the WiFi extenders!.. BTW, I use hard wire for the Rock

Sadly the Black WiFi extender disc will not work with Smart Hub2, and it is needed for Roon/Tidal control…
I have tried the ports listed above, no go either…
I think Roon have to solve this one…!!

@ support
Ok,I have read as much as possible, and the following is still happening…


I have set all the ports on the earlier reply, no difference, especially as I do not use McCaffey etc. The firewall still stops it…
I cannot change the DNS servers in Smart Hub 2, …and surely this should work with BT servers anyway(laptop does), as they are the major broadband supplier in UK??
Is there anyone out there that knows why the filewall would block Tidal through the Rock, but not from the laptop on the exact same Lan socket in the system? Local playback of music thru Rock on my external hard disk is fine! Help…
Are there port numbers that Roon/Tidal have not told us?

Ps it is a NUC813 BEH3

So it is a suppported version! :wink:

I had the same setup and it did work so i’d say it is something in your set up.

ah, that is curious!
So you have Rock, NUC and Smart hub 2, and it all works?
Ho hum…Did you add any special ports etc to the home hub?

I’ve moved on in that I have a Plusnet modem now but I just plugged the rock in and it worked when I was on BT.

Ah ok, thanks, was it a Smart Hub 2? or the earlier Hub 4 or 5?
If you can rememer :slightly_smiling_face:

Good point it was a hub 6.

:slightly_frowning_face: :cold_sweat: