Tidal tracks available to browse, but will not play

You have I am sure seen the correspondence below…Please can you help me now?
Kind regards

Yes ,Rock is fine when Firewall is off… Ho hum…

I have just set all those ports again, and the effect is identical, ho hum…
Please can I have any suggestions from Roon/Tidal rather than just the community as well, being as they write the software, that is causing the problems!? I need to have a request from Roon to provide the logs to them!! HELP

Temporarily install windows a roon windows on the nuc and see if it works.

Yes may well do that and forget the the Rock nonsense! As no one from Roon can be bothered to help…seems to be waste of money me thinks!

Rock works for 999 out of a thousand. You seem to be the .1 percent.
Mary see if windows works on it to make sure the network hardware on the nuc is ok.

AS an update, The Roon radio player is perfect, does straight through and works perfectly…
So nailed down to the Roon implementation of Tidal…
Any help out there please?

At this point, I would look at both the logs of the Router and Roon. to see if they give any indications as to the cause of the issue. I would note the time and attempt to play some Tidal tracks. After they fail. Shut down Roon and look at the logs. You can find them by pointing a Windows file browser at \\rock\Data\RoonServer\Logs

I have no idea how to get to your Router’s logs, if they exist. It might be in the manual.

Giving a ping to @support


My core runs Windows so while I have a spare NUC that runs ROCK, I mainly use the Windows PC. If you do decide to go to Windows instead, remember to reset the BIOS back to the default settings since Windows will be expecting the newer options that you turned off for ROCK.

Summarising the discourse above:

  • Local files from USB storage play just fine.
  • Live Radio streams from the ROCK play fine.
  • Roon Core / Tidal work fine on his Windows laptop with Roon on the same router.
  • Problem with Roon ROCK OS/Tidal plugin and how it interacts with the very commonly-used BT SmartHub 2 in the UK with it’s necessary firewall enabled is thus likely. Again, Roon on other PCs works fine, with firewall enabled. This is seemingly a ROCK issue with Tidal and certain firewalls.

Is nobody from Roon able to help Mark with this issue?. Ged, I do note you have been helpful but I think this needs a little more engagement from Roon as a company.

Nobody at Roon has even asked for MMW’s server log files. This is $$$ premium software, not free open source fix-it-yourself. C’mon guys, please look into this properly :wink:!

The suggested fix of changing to Google DNS could maybe work if ROCK SSH remote login was available as DNS could be changed in the ROCK OS. But it isn’t, and he cannot change his routers DNS, nor should he have to. so he is blocked.

Could this issue be escalated to a dev/other tech team please?

As you may have seen, I have already pinged the support team directly, that is what @… support does. Hopefully, someone will be by soon. And yes, looking at logs is the next thing to do, which is what I suggested to him.

I’d say post the logs in a dropbox and I can look at them, but, Roon’s support has already engaged and I do not want to interfere.

Actually, as I mentioned in a post days ago up thread, to set your own DNS you just have to switch the NUC to a static IP. That lets you put in your own gateway and DNS info. No SSH needed. I have no Idea if mark ever tried that or not.

Hi Daniel

My response was being typed as you were prepping yours, and you got there first so we are slightly out of sequence!

Regarding the static IP option: This only worked with early gen BT hubs as other have found. There is no way to do this in the ROCK unless you have further info?

I do think that changing DNS server should not be necessary to fix this. Really, no other software that uses the internet has required this in my personal experience. This is perhaps a web service call that is failing due to some internal software timeout issue or redirect issue in the Tidal plugin ROCK code. Hopefully the support team can find out something! Thanks for your input though.

Thank you for your offer to look at his server logs too.

Perhaps I wasn’t clear, on the ROCK’s Web UI page, there is the tab option to either have the ROCK NUC be DHCP OR Static IP.


However, given the unusual-ness of the issue, the logs are really the place to start.

1 Like

Oh, that DNS option looks interesting. First time I have seen that, thanks!

Mark: I think that DNS entry is worth a go, but these entries are risky as you can lock yourself out if not careful, which may require a restore from a backup ROCK image.

Ok, thanks, but I may observe that it is a temp fix rather than a Roon based cure!
We need to cure the problem not the symptoms!
Over to you Roon!

Hi @mark_Manwaring-White,

Thanks for your patience here while your case reached my queue again. I’ve activated diagnostics mode for your ROCK and what this action does is automatically upload a log set to our servers.

Looking over the log, this appears that the issue might be tied to your TIDAL account. Can you please let me know, is there any special regarding your TIDAL account, is it part of a family subscription or did you use an extended trial license when you set it up?

If you have another TIDAL account to try, it would be a good test to see if the other account is impacted in the same setup.


As I remember we are in a family group of 4 or 5, but how would this stop it working in Rock, but perfecty my laptop? Especially as the Roon radio works ok…

ps, no I do not have another tidal account! :slightly_smiling_face:

@Noris As above, although the Tidal is a family deal, How on earth could that change the situation with the Rock please? Especially as it works correctly on both my Laptop and my Phone, all through the same router!
And as also mentioned Roon Radio is fine, as well as browsing all the tracks on Tidal…