Tidal very slow, Qobuz very fast

Core Machine (Operating system/System info/Roon build number)

Intel NUC10i5 / 8gb RAM / 128gb system drive

Operating System: Rock Version 1.0 (build 227) stable

Roon Server Software: Version 1.7 (build 710) stable

(Side note/FR: you should put a “copy system info” screen on the Roon “About” page and/or the Rock status page)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ISP (Fios 125mbps up/down) > Netgear R6700 > Ultrarendu

All ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonore Ultrarendu -> USB DAC (Rega DAC-R)

Description Of Issue

Clicking “Play Now” on a Tidal version of an album takes 10-15+ seconds before it starts playing. Click over to the Qobuz version of the same album, and it loads and plays in a 1-2 seconds or less (basically immediate).

This Tidal slowness is also apparent when viewing the “Overview” screen. If I disable Tidal, it speeds it up considerably, since it isn’t waiting for Tidal.

Likewise, if I click “Tidal” in the main nav menu of Roon, it might take ~10 seconds for the main Tidal screen to load. Doing the same with Qobuz the albums load nearly instantaneously.

I’ve tried the above in reverse order, dozens of different albums, pressing stop before playing a different version, etc.

I’ve stopped the server, deleted the RoonServer/Tidal cache, logged out and re-logged into Tidal, etc.

Roon, Rock, and the NUC itself have been restarted multiple times.

I use Cloudflare DNS settings (1.1.1.1, 1.0.0.1) at the router level.

Using the Tidal app directly (not through Roon), clicking play on a track starts immediately.

I have fully paid, premium accounts on both Tidal and Qobuz.

Has been like this for at least a few days. (Maybe more. The NUC is new as of last week, so now I’m much more sensitive to loading speed issues now that I know it’s not the computer/internal network slowing things down.)

LMK if anything else would be useful. Thanks in advance!

Hi @jtnt,

Can you please let me know the exact local time + date + track you experience this issue with TIDAL next? I would like to enable some logging for your account to see if I can get some more information.

Is there any change in behavior if you try to logout and back into TIDAL via Roon or clear out the TIDAL cache?

  • Stop Roon Server from running in the Web UI
  • Find and open your RoonServer database
  • Navigate to RoonServer/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon Server via the WebUI and verify if the issue still occurs

@noris, thanks for your reply.

I can make it happen at will, so sure. :slight_smile: It just happened, January 8th, at 9:12pm. The track was “The Past Ain’t Passed” by Chris Forsyth.

I have done all the things in your bullet points, including logging out/into Tidal via Roon, and more (reboot NUC, restart ROCK, etc.) multiple times, as I pointed out.

This happens consistently, like every time, a Tidal track is played and has continued to do so in the days since my original post.

Thanks for your help!

Hi @jtnt,

Thanks for the timestamp! I’ve activated diagnostics mode and what this action does is automatically upload a log-set to our servers, I can confirm that the log report has been recieved.

I’m looking over your logs and I am noticing the issues with TIDAL, it looks as if Roon buffers the tracks for 10-15 seconds before playback starts, and that the buffers are not being filled up in time.

Have you by any chance tried a fresh database on this Core?

  • Create a Backup
  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • Verify if the fresh database also exhibits this issue

If the issue still occurs on a fresh database, I would also try another Core on the same network as a test to see if the issue is limited to ROCK or any Core on this network. To switch Cores:

  • Create a Backup of your current database
  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC

Thanks! I’ll try this other steps when I have time later this week/weekend.

One note: this delay also happens when loading (or refreshing) the Tidal front page (clicking Tidal in the main nav in Roon), which doesn’t involve buffering a track. Just FWIW.

I just loaded and refreshed this Tidal front page at 12:52pm EDT on January 12 (today), if the logs will be helpful to look at on this as well.

1 Like

@noris Hey there. I finally got around to doing the other two troubleshooting steps you suggested. In both cases - fresh database and entirely different core - Tidal took a long time to load.

What’s next?

1 Like

FWIW, I also just tested Tidal via Audirvana, and it’s lightning quick. This seems to clearly be a Roon integration issue.

That sounds like an accurate conclusion. I’ve tried several DACS and the results are the same. Thank you.

1 Like

Hi @jtnt,

Thank you for running those tests I mentioned. Can I please ask that you send me a log set from the other Core you tried the test on, you can use these instructions to access, I want to try to identify if there are any other similarities between the logs. On the other machine you tried, was this with a fresh database or a restored database of ROCK?

1 Like

A post was split to a new topic: TIDAL errors on NAS + ROCK

@noris Here are the log files from the other temporary Core, which was a Macbook Pro. A completely separate machine from my standard Core machine (the NUC running ROCK), running a fresh database. I did not restore from a backup when I tested this.

https://drive.google.com/file/d/1t_hYA5grmvl28D_YmtFyctaXtsNZiGxJ/view?usp=sharing

Well, I don’t want to pile on - it wouldn’t be useful for me to complain. But I have similar symptoms from time to time, and I’m hoping there’s a general / generalizable solution here.

1 Like

@Johnny_Ooooops Yep. Seems like there are more and more threads popping up of others having similar issues.

Yes its frustrating, I am in the process of looking at making network changes as I thought it may help…but it appears that there are a lot of others with this issue.

1 Like

Hi @jtnt,

Thank you for sending those logs and for your patience here while I had a chance to review.

Looking over the logs, I am noticing quite a bit of networking error, even when attempting to download images from our Roon metadata servers, which is typically not a good sign.

Can we please try to eliminate the current network setup from the equation? Do you by any chance have hotspot capabilities on one of your mobile devices?

Would it be possible to temporarily test to see if only the current network setup is impacted with that test? It won’t help us solve the issue long term, but if we can confirm that same gear works on a different network then we can be more confident that the issue is networking-related.

Do you have the latest firmware on the router? If you try plugging into FIOS router directly, does the same issue occur?

Thanks, @noris.

Not sure what/how you’re suggesting I test with the mobile hotspot…

I do have the latest firmware on the router.

I will try plugging directly into the FIOS router and report back.

That said, I’m not sure why my local network setup would be causing things to be slow to Tidal (but only through Roon) but quick to Qobuz (and everything else), especially since it seems at least several other people are having identical issues as I am with Tidal.

2 Likes

I fixed problem with Tidal in Roon this way:
On Rock I connected to it via http and saw that IP address and DNS were given by DHCP. I wrote that data (addresses) to a piece of paper and turned of DHCP there and put information as IP address, Mask, Gateway manualy as they were when DHCP was used but instead of previous DNS address I put 8.8.8.8 Apllied settings and rebooted ROCk. And Tidal started work nice.
With the ROON installed on QNAP I went to network settings in QNAP and added 8.8.8.8 as a secondary DNS address. And again it started work nice.
A lot of people here complain on how ROON works with Tidal and strange that they cannot fix it… As it is obviopus problem of how ROON sends requests to DNS server…

Thanks, @Pavel_Ezubov

My ROCK uses my router for DNS, and I use the Cloudflare DNS https://1.1.1.1/ in my router settings, so it’s used universally for everything on my network.

I may try Google’s 8.8.8.8 one this weekend as a test, but I have confidence in the speed Cloudflare’s service. Here’s more info: https://1.1.1.1/dns/

As you suggest, the problem continues to be Roon + Tidal, and not just Tidal, since using Tidal directly works fine, so I’m fairly certain it’s not a local network config issue.

Hi pavel-

Are you saying you had to go into the ROCK network config and hard code IP/subnet mask/DNS to get the improvement? If so, that’s wild. That somehow the wrong DNS is being used by the ROCK, even though the network is configured correctly?

yes, that works for me. You can do it via config of your router to put DNS server address as 8.8.8.8 but I did it in ROCK - just put static IP address with DNS 8.8.8.8. It might have problems in future as your router may assign same IP address to other device, but it solves problem for the time being. Hoping that ROON does something about it