Tidals masters list missing in Roon

I would say about 95% of the time when I log in under new albums there is no Masters tabs in the tidal part of Roon. If I then log out of tidal via roon and back in again the Masters tab is back.
However the masters playlist is ALWAYS there.
My setup is as follows
The Roon core is on a synology 916+
Outputting to a sotm 200 ultra and sPS-500 Power Supply and the tX-USB Ultra USBHub, which then outputs to a Oppo ha-1 headphone amp/dac via usb.

Here is one after I logged out of tidal and back in and master list is back

Hi @Ryan_Sayce ---- Thank you for the feedback and more importantly, thank you for your patience here.

I saw your report come in earlier but wanted to see if I could replicate this behavior on my setup here (Core = NUC w/ROCK / Remote = Macbook Air). So for the last 2.5 hours I have been periodically logging in and out of TIDAL via ROON to see if the “masters” would disappear and then eventually re-appear, as laid out in your report. No issues to report so far on my end.

Being as you have your Roon core on a NAS you must be controlling it via a remote device. Have you tried reinstalling Roon on the remote since noticing this behavior?


Hi no I haven’t as I was worried about it having to rescan my huge library again, I am guessing I will just have to bite that bullet.

Hi @Ryan_Sayce ----- BEFORE YOU PROCEED

Please note that I am not asking you to start with a fresh DB on the Synology NAS. You should leave all elements in place on that device, however what I am proposing is that you reinstall the application on the remote device where you are controlling the core from.

Note that reinstalling on the remote device will have no adverse affects on the Roon database that is residing on the Synology NAS.

If there is any confusion on the above please let me know before doing anything so I can clarify :microscope:


Oh I see what you mean.
I also have the same result if I access it from the remote device on my samsung galaxy s8 phone or my apple mac air laptop.

So do you still want me to reinstall it on my windows 10 device, as I get the same result on android and apple ios ?

If I have to reinstall it on my synology is there any way I can back up everything so it won’t have to scan my entire library again ?

Hi @Ryan_Sayce ---- Thank you for touching base with me, very appreciated!

Before continuing forward, I want to take a step back for a moment and make sure that I have all the details of your setup correct so I can properly advise :microscope:

Setup details:

  • Core = Synology 916+
  • Remote devices = Galaxy S8, Macbook Air, Win10 (device unknown), Apple iOS (device unknown)

Continuing forward…

Based on your feedback it sounds like you may not be making backups of your Roon DB:

“…is there any way I can back up everything so it won’t have to scan my entire library again?”

First, I would strongly recommend making use of our backup feature as this is going to be the most reliable way to ensure that the information in your Roon database is preserved.

Second, I would like you to please reinstall the application only on your remote devices and verify if the behavior is the same after the reinstall. If this does not fix the issue we can then look into the behavior of the core machine.


Ok I have reinstalled the software on my remote devices and the behaviour is the same still no masters list under new albums, also sometimes when I try to load tidal it says failed to load check your network connection and it is much slower to initially play a tidal song than when core was installed on my windows 10. However once the song starts playing everything is fine.
The network connection on my synology where the core is installed is fine and always on so shouldn’t be a problem in that regard.

First of all this is important!

Don’t follow my advice as I’m not sure how roon behaves.

Sometimes when I’m in my office far outside WIFI range I install roon and create a new core and as I don’t want to pay for two cores I basically disables my primary core.

When I get back home I terminate the office core and if everything works like I want the original core has not changed.

If this is true you would be able to try connecting to a new core for a short while and see if the problem occurs with a fresh core and there should be no risk concerning your old core.

As I said I don’t recommend this as I don’t know how roon works.and is currently not in a good position to test.

Hi @Ryan_Sayce ---- Thank you for giving the proposed test a shot and sharing your observations with me, both are appreciated!

Moving forward, I would like you to try reinstalling the application on the Synology NAS. Remember, the goal is to leave the current ROON DB in place and just reinstall the application. Please see below for instructions.

  1. Before anything please create a backup of your current Roon database.

    One the backup has been created…

  2. Close all instances of Roon on your various devices and then stop RoonServer from running on the NAS.

  3. Once RoonServer has been stopped on the NAS, please uninstall the application from the device. Note that the “Roon Server” folder (i.e your database) should be left in place and not touched.

  4. Next, please then reinstall the application on the NAS.

  5. Finally, Launch RoonServer and connect to it from one of your various remote devices. Are you still noticing the same behavior?


Ok reinstalled the core on the synology just like you said, however some of the old settings must have been left as it didn’t ask me for any of my passwords etc and when I go to tidal, once again the masters tab is missing.

Hi @Ryan_Sayce ----- Thank you for touching base with me and sharing the observations you have made after performing the proposed troubleshooting test. Very appreciated!

Continuing forward, I would like to enable diagnostics on your account so our techs can have a closer look into this behavior. However, before I enable this feature may I kindly ask you to please perform the following:

  • Please reproduce the issue and note the following:

    • The time when the error occurrs.

      " I would say about 95% of the time when I log in under new albums there is no Masters tabs in the tidal part of Roon. If I then log out of tidal via roon and back in again the Masters tab is back."

    • Which remote device was used during the above test.

Additionally, I want to just reconfirm that I have the above behavior conceptualized correctly in my head. You are mentioning that when you “log in under new albums” that the “Masters Tab” is not present. Are you actually “logging in” to TIDAL every time the application is launched OR are you just navigating to the TIDAL section of the application?


Ok I am just navigating to the tidals section when I launch Roon, If I log out of the tidal via the options and back in again and then go back to the tidal new album section it then shows masters albums. The vast majority of the time the masters tab doesn’t show up on any of my devices including the windows 10 pc.

Log in with Samsung galaxy s8 plus into the roon app which is already logged into tidal no masters tab - 4:39pm Monday 16th

Log into Roon app with windows 10 pc, again already logged into tidal with Roon - this time masters tab showed up - 4:42 pm

Log into Roon on imac air then navigate to tidal section- no masters tab - 4:44pm

Hi @Ryan_Sayce — Now that I have the requested time frames (thank you again) I have enabled the mentioned diagnostics on your account.

What this action will do is the next time that Roon is active on your core machine and the mentioned remote devices from above, a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded to our servers. I will keep an eye out for the upload and will touch base again once it has come in so you know we have it.


Just so you know at 2:15am
On my windows 10 desktop tidal masters did not show
at 2:16 am on my samsung galaxy s8 plus it did show up
at 2:18am on my imac air it did not show up

So it seems on my end to be entirely random.

Hi @Ryan_Sayce ---- Thank you for the additional feedback!

I wanted to touch base with you because we have received the mentioned diagnostics report which has now been attached to your ticket for our tech to review. Once the team has completed their evaluation I will be sure to touch base again to share their thoughts/findings with you asap.

Your patience is appreciated!

1 Like

Hi @Ryan_Sayce ---- Thank you for your patience here while our tech team has been evaluating the logs attached to the received diagnostic report. Very appreciated!

I checked in on the status of your ticket this morning and can see that our team is still investigating but wanted to suggest trying to host your core temporarily on another device, just to verify if a different core machine displays the same issue. When you are setting up this test I would recommend…

  • First making a backup of your current Roon database before anything.
  • Next I would stop Roon from running, not only on your NAS but any active Roon remotes as well.
  • Finally, load Roon on to another device that can act as Roon core (i.e meets our minimum requirements)
  • Verify if you notice the same behavior with TIDAL “Masters”


Ok I can install the roon core on my windows 10 pc, I will try and get this done over the weekend.

Ok a status update, I installed roon core on my windows 10 computer this weekend and disabled it on my synology 916+

So far not only has every device showed the masters tab but when browsing and actually playing a tidal track it is SIGNIFICANTLY faster, on the synology after clicking playing there was normally at least a 8-10 second delay but on the windows 10 core and all clients connected to it when playing a track off tidal it is instant.

The synology is on the same network so has access to the same speed internet and should be more than fast enough spec wise to run Roon core.

Also the Roon when running on synology when accessing Tidal routinely says error check your network connection, something that never happens on my windows 10 core.