Total Distortion on Upsample above 384 kHz, DSD 256 Works Perfectly

Core Machine (Operating system/System info/Roon build number)

OS X 10.14.5/3.1GHz i5/1.6 (build 416)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Pro-ject Pre Box S2 Digital via USB

Description Of Issue

Any time I try to upsample a file to a rate above 384 kHz there is total distortion. 705 and 768 are just massive noises. DSD256 works perfectly fine, however. I feel like I have tried just about every setting change and whatnot and have still been unable to figure it out. This distortion occurs regardless of the source: local ALAC, FLAC, and Tidal. I am beginning to wonder if the unit is defective (I’ve had it about a week,) or theres something in the settings that I could be missing. Again, 16 bit, 24 bit, 44.1 through 192 and in between sample rates all produce these effects if attempting to upsample to any rate over 384. Any help would be much appreciated, thanks.

What is the USB connected to? Mac?

Maybe Mac support is not there for above 256? Typically most dacs need windows and specific drivers for such rates.

It is connected to a MacBook Pro via Audioquest Carbon USB C to A adapter > ifi iSilencer 3.0 > Audioquest Cinnamon USB B to A > Pre Box S2 Digital. I’ve also troubleshooted by using OEM USB C to A dongle as well as a Belkin 3.0, I have also tried these combinations without the iSilencer and with an Audioquest Jitterbug as well, and none of those combinations made a difference.

1 Like

Right, I know DSD512 is not supported on Mac through Core Audio, but I am looking to upsample to 705 and 768 PCM rate. The options for these sample rates are available to select from in the Audio MIDI Setup menu in the OS.

What happens when you go direct from Macbook to S2 DAC, without the iFi gadget?

It does the exact same thing, it doesn’t appear to matter whether there is a jitter reducer or not. Interestingly, if I reset the DAC and restart Roon and lets say I select a 44.1 track and upsample to 705 it is okay, but if I switch to any other sample rate or format, like any MQA or a 48 kHz the distortion then starts. But, if it is an MQA track played it is okay, but if I switch back to a regular file it distorts. If i go from, for example, 44.1 to 96 it will distort and if I go back to select a 44.1 after that it will also distort.

In Roon audio settings for your S2 DAC, have you enabled ‘Exclusive Mode’ ?

Can you share a screenshot of your Roon Signal path when you are getting the static sound.

And is your Macbook powering the S2 DAC or are you using the included external PSU? Should work properly both ways but just asking.

Yes, exclusive mode is enabled. I am not using the external PSU. The S2 is plugged directly to the Mac, no hub, dock, or anything like that.

But you’re going through the Audioquest adapter? I’m guessing your Mac doesn’t have any Type A port?

The reason I asked about the iFi gadget wasn’t to do with jitter, it’s sometimes these gadgets do more harm than good. I know you mentioned it’s the same with and without the iFi. Wondering if it’s the Audioquest adapter.

I’ve never had issues with my S2 DAC at PCM705 and PCM768kHz rates, with Macbook.

Yes, that is correct, it only has C ports, I have also tried the OEM Apple dongle as well as a Belkin 3.0 adapter, results are the same. I have not tried a B to C cable, however, as I do not have one, I did see that they make them.

Yeah, I knew you asked about the iFi item as a troubleshoot, I know that effects are not always “better.”

Hmmm just to properly rule out any issues that it’s the DAC unit itself, do you have any other computer/laptop in the house with type A USB port? Either Windows or Mac.

Or even an iOS device with Apple USB3.0 (type A) Camera Kit to test?

Just to check the DAC with another USB source.

One other thing. Can you change your Roon MQA settings to have the S2 DAC as MQA ‘Renderer only’. In this mode you’ll see MQB on the DAC’s display when playing MQA.

There is a known bug with MQA with the S2 DAC (not an issue only with Roon) but it only appears when you have the S2 DAC as MQA decoder. Everything is fine when the DAC is in MQA rendering (only) mode. Just to rule this out.

My setting are renderer only and it properly displays MQB on the S2, the MQA functionalities work fine. And as far as another device goes, I think in the house there are several windows laptops and a desktop, none of which are mine, I’m sure I could use them but wouldn’t that involve installing drivers and Roon to replicate the environment? I do have the Apple camera kit lightning to usb; I have an iPhone XS. Would I be able to connect the S2 to the iPhone and through Roon instruct it to upsample? I’ve really only ever used it for the Dragonfly Red.

Nice. Yes you can run the Roon iOS app and turn it into a Roon endpoint. Point Roon Core on your Mac to your iPhone endpoint.

For the Windows computers in the house, you’d just need to install the Pro-Ject USB driver and Roon and get Roon to act as an endpoint also. Just use your Mac as your Roon Core.

See if you can use a bog standard (USB 2.0 certified) cable too, instead of the Audioquest. Just to rule that out to. And leave the iFi out too.

Either of these is just to make sure the S2 DAC itself is working properly with a simple and direct connection to an alternative USB source.

Up-sampling to PCM705/768 to WiFi endpoints will test your WiFi network though, so that’s introducing a potentially problematic variable.

Maybe testing with a Windows laptop/desktop hard wired to router is the better test. I’d try it all personally.

I will try these when I can later today. I think as far as the WiFi goes, it should be okay I have an ac router with good connection. I can also hardwire them. But, I’d know pretty quickly if the distortion were occurring. The only other troubleshooting I can think of would be would be picking up a cheap USB B to C cable and hook it directly to the computer. Would that be worth trying? I appreciate all of the feedback thus far.

Not sure, never tested as I don’t have any USB C ports. If it’s cheap and easy for you to get one, give it a try.

Hi @Grant_Munday,

It looks like there are some great next steps here that Sean suggested, I would try to verify what the behavior is like via iOS first just to confirm that it works via another endpoint with the Lightning Kit and that the DAC itself is properly functioning.

Once we establish that, we can give other computers running Roon a try (see Running Roon as a Remote Guide) and verify if this behavior is DAC specific or Core/Endpoint specific.

I would try to change one variable at a time if this starts working properly:

  1. Use USB + iOS adapter
  2. Use same USB on a PC Roon Remote
  3. Use the intended adapter for the original setup
  4. See where the issues start

Also, I would double check to make sure you have the newest firmware and I have recently seen a thread where the Pre Box S2 was a counterfeit (Pro-ject Pre Box S2 Set-Up Digital Question), might be worth looking into where you bought it from just in case this might be related.

– Noris

Yes, great suggestions, so far I have tried:

-Switching to a different cable with my Core. I was able to get a USB C to B cord that would plug straight from my computer into the DAC without any adapters; eliminating the C to A dongle. This test yielded the same as previous scenarios.

-Hooking up the DAC to my iOS device. I used the Apple Camera Kit from my iPhone to the DAC and set it to upsample. I was able to successfully play local and streamed MQA files, ALAC and FLAC local files at their native sample rate, as well as streamed FLACs. However, when I hit the switch to turn on DSP upsampling by max PCM rate power-of-two, the distortion was immediately present. I then tried DSD256 with my local files and streamed files; both worked as they have before, as did upsampling to 352 and 384. I will note that I did have to use the PSU with this method as the power from the phone, to no surprise, did not power the unit, even with the power plugged into the Camera Kit’s charging port; I know this works with some lower power units. So, plugging the PSU into the DAC and USB to my iPhone without power on the Lightning side worked perfectly, save the existing upsampling issue.

-On the firmware and intended adapter: SW version says 2.12. I believe this is the latest version if I am not mistaken. As for the intended adapter, I am not certain, as there was not a USB cable included with the device, and am unable to find where it states whether only a 2.0 will work, etc.

-Using the same USB on a PC Roon Remote: that I may not be able to make happen. None of the PCs belong to me, one of them has USB-C ports and one of them is a work computer that cannot install third party software. However, the one option is an aged desktop PC that does have traditional ports that I may get permission to use.

This is my status with this at the moment and I appreciate all of the suggestions and helpful feedback,