Track currently not available from TIDAL

@support, I faced the same problem couple weeks ago, it showed that “this track is currently not available from tidal”.

I’m using Innuos Zenith mkiii, it works fine for playing both music in HDD and tidal before, but it can’t play tidal now, please help!

Hi @Mac_Wong,

Welcome to the forum!

Is there any change in behavior if you try to log out and back into TIDAL via Roon Settings -> Services?

Are you able to play any TIDAL tracks, does this behavior only occur for items previously saved in your Roon database?

Hi @noris, I tried to log out Tidal and log in again, and this doesn’t work for me.

I can read the content from Tidal, but can’t play any content.

Thank you!

Hi @Mac_Wong,

Can you please confirm if the TIDAL web player ( has any issues with playing a song using the same TIDAL account you’re logged into Roon with on a PC on the same network?

Have you tried to reboot your Core + Networking Gear yet? If not, I would also perform this troubleshooting step.

What does the rest of your setup look like, can you provide more details please?

Hi I’m having this same issue just started happening today. I tried Rebooting everything and signing out of Tidal and back in.

Are there any actual working solutions for this? I’ve been getting the same errors for the past month or so on a ROCK NUC as core.

Hello @MRJ & @Taylor_Vancoillie ,

We recently resolved an issue in this area, please see:

If you are still having difficulties, please open a new thread with setup details:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.