Track is loading slowly

No, Roon is still saying either Tidal or song from hard drive are loading slowly. I checked at my core and download speed is currently 179mbps.

And the Roon page on my core is not displaying everything correctly, lots of black boxes where images should be and play control buttons not displaying

This is a graphics driver issue with certain types of graphics hardware. It’s been tracked down and should be squashed in the near future (I hope). See this thread:

Ok great. What about the constant issues I’m having with song loading too slowly directly off my core? Same with Tidal.

Hello @Donald_Adams,

I split your post into a new thread to help keep things organized.

Are you seeing this behavior on all of your zones? What about when playing to the “System Output” zone of a Mac or PC.

Please note the exact local time + date when this issue next occurs and the name of the track that was playing and upload your Roon Logs by using these instructions. The best way to get them over to me would be via Dropbox / Google Drive, but if you don’t have either service please let me know and I can provide alternate upload instructions.


Thanks John. It was playing fine this morning and then just started doing the same thing about 5min ago so 10:10AM central time. This is on my Hifiberry pi dac. I stopped playing and went downstairs and its playing fine on my Allo Piano/Pi dac. Its also playing fine on my core PC. I’ll follow your instructions for getting the logs now.

After getting the logs files zipped up, I tried playing on Hifiberry/Pi dac and now its working again. It seems to start happening after I’ve paused playback for a while.

John, seems like this exact same issue is happening with other people and it all started with latest Roon software update. I had 2 other people respond on my other thread that took 2 weeks for someone from Roon to reply to.

Hello @Donald_Adams ,

We have resolved this issue in a new build of Roon, can you please update your Roon to the latest version and verify if it helps with this issue?

Thanks for sending the logs and for the further tests. Since the issue only impacts that Hifiberry DAC, I suggest we troubleshoot further in this direction.

How is the DAC connected to the network, is it via a powerline adapter? WiFi? Can you try to connect it directly to the router via Ethernet and verify if the same issue occurs? Let us know if this helps!

I updated the firmware and the graphic issue seems to be fixed on my core pc. Thanks
So far I haven’t got the hifiberry DAC to act up again but have had limited time to play.
The hifiberry DAC has always been connected directly to the Google Mesh router that is connected directly to my fiberoptic connection point. My core pc is connected directly to another Google Mesh router.


Hifiberry DAC started doing same thing again this morning. Says Tidal is loading slowly. Working fine on Allo Piano DAC and pc core.
Like I’ve said before, this all started with your recent firmware update, I’ve never had a problem like this int then.

I tried resetting power on Hifiberry. The only thing that happens, again started with your latest update, is it takes forever to show up in my devices. I also unplugged ethernet cable so its running off WiFi and it started working. I’m going to monitor it to see if it stays that way.

Hi @Donald_Adams ,

Thanks for the additional information, it sounds like the HifiBerry is having some issues if it is the only affected playback device. Have you ensured that you are on the latest firmware version of the HiFiBerry?

Yes, do let us know if this solves the issue!

Its not the Hifiberry, I have been able to get Allo Piano to do it too. This definitely appears to be a Roon issue. Others users are seeing the exact same thing and it all started with your last update.

See this thread as an example.

Hello @Donald_Adams ,

Can you please confirm if you are seeing this issue on System Output as well, or only on your network-connected zones?

If you are able to reproduce the issue on your System Output zone, can you please note the exact local time + date + track you had an issue with and send us a new log set for review?


It did happen on my system output before but now its not doing it on any of end points recently. I am still monitoring it so if it does happen again, I’ll check system output and provide the information you asked for. Thanks


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.