Tracks Skipping When Using USB DAC

Roon Core Machine - Windows 10 on laptop

Windows 10
Intel(R) Core™ i5-7200U CPU @ 2.50GHz 2.71 GHz
4,00 GB (3,88 GB usable

Networking Gear & Setup Details

Connected Audio Devices

Trying to use Focusrite Scarlette 2i4

Number of Tracks in Library

Description of Issue

Hi, I have just started a Roon trial however my USB DAC/ Audio interfaces will not work. They connect but just skip through tracks. I have tried this with my Focusrite Scarlette 2i4 and my Traktor Audio 2 DJ. Tracks play perfectly through my laptop speakers.

How is the laptop connected to the internet

What is the source of your music files local or streaming

Make sure you are using drivers provided by the DAC manufacturer. If necessary uninstall them and start again.

Welcome Bernard,

Fellow user here.

EDIT: My brain missed that you’re using Pro Audio gear. It’s more likely to be drivers rather than a networking issue.

The issue you’re describing is often caused by less than ideal network connectivity.
I realize this can seem unlikely as your network may be be working perfectly for everything else but Roon does things a bit differently and there’s more to it than just connection speed.
Best practices are for your Roon core to be connected via Ethernet.
If you can provide a detailed description of your network equipment and setup this will help Support, or others in assisting you.

Yes, an Henry says, make sure you have drivers installed from the Manufacturer. See here: Scarlett 2i4 2nd Gen | Focusrite Downloads Windows doesn’t generally have an USB Audio Class ‘USB Audio 2’ driver built into the OS like the mac, so you need to install these drivers to get beyond 96kHz resolution.

1 Like

When Roon skips through tracks it can mean that it cannot gain exclusive control of the audio device.

Try using Roon in a non-exclusive mode as a test. And, try disabling any other audio software you might have running on the machine that might have kept control of the audio device.

1 Like

Check your firewall settings and anti virus programs. Turn them off if you have to and see if Roon works

Thanks for the feeback, I will try to reinstall the drivers aswell as connet direct via Ethernet.

Hi Blair, thanks for this as it solved my problem.

Hi Guys, thanks again for the help, I installed the Scarlette drivers and everything works perfectly, problem solved.


< bows > Glad you’re working fine now.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.