Tracks stop mid-way

I’m having a problem with the latest version of Roon, in that tracks will stop mid-way, pause for anything up to about a minute, and then skip to the next tracks.

I’m running the core on a Mac with a Core i7 processor running at 3.1GHz with 8GB RAM. The OS is High Sierra 10.13.5. There’s plenty of disk space available (800+GB).

The library is running from a Synology DS214play with DSM 6.2.

Any guidance would be appreciated - I can send logs if required.

Many thanks


Hey @Mark_Hartt-Palmer, thanks for sharing your report with us!

To start, my I kindly ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

May I also ask that you please verify the following:

  • Does this behavior happen with all endpoints? If you play to System output do you still experience this?
  • Does this happen with all media? TIDAL included?
  • Do you have any active firewall or antivirus on the Core machine?
  • Have you tried rebooting your Core machine, any affected endpoints, and networking hardware?


Hi there

I’ll come back with the full system specs as suggested, but it maybe useful to know that I am receiving the skipping when playing direct to the System Output on the Mac of an album that is stored on the NAS drive. I received a “Server Interrupted” error on the Core just now.

1 Like

Thanks, @Mark_Hartt-Palmer.

Yes, please detail your setup when you are able to. It sounds like there is something disrupting the connection between your Core and media, so having a better picture of how things are communicating will be a great help!

As mentioned above, I’d also give rebooting everything (including networking hardware) a try. Also disable any antivirus and firewall on the Core and see if there is any change.


Hi Dylan,

me is encountering more or less the same issue. Roon is being paused like every half an hour and coming back to Roon client I hit play and music starts from where it had stopped.

Roon Setup Description

Internet router: Unitymedia Connect Box (Ethernet / Wifi)
OS: Windows 10 Home
CPU: Lenovo G70 (connects thru Ethernet) (Roon client)
Intel ® Core ™ i3-4005 CPU / 1,7 GHz / 64 bit OS / RAM 4 GB

IPhone 8 (connects thru WiFi), Roon Client
Roon Core: Innuos Zenith MKii , Software Release: 1.3.4 (connects thru Ethernet on Devolo)
Network Distribution: Devolo Powerline 550+ (2 endpoints)
Audio Zone: Kii Three Active speakers connected to Innuos via USB

I have rebooted all the devices several times.

Hi Dylan

I’ve done as you have suggested, and I’m still getting the intermittent skipping of tracks, with the Roon core software also occasionally crashing on the Mac.

I have a Fritz!Box 3490 router running the latest firmware. Everything on the network has static IP addresses. The Naim Uniti Atom and the Synology DS214play are plugged into a Cisco 2960 switch (although I have tried plugging the Synology into the router which has the same results). The Mac is networked into a Netgear GS105E switch.

I didn’t get any interruptions when playing an album on Tidal.

Many thanks!


Hey @Mark_Hartt-Palmer,

If I’m not mistaken, the Netgear switch you mentioned is a managed switch. As mentioned in out networking guide, managed switches often require some advanced setup in order to function properly, and we’ve traced several issues in the past to the use of managed switches.

In order to confirm this suspicion and help narrow down where this issue may be stemming from, may I ask that you please try connecting your Core machine, Naim endpoint, and Synology directly to the router and see if the issue persists?


Thanks for sharing your report, @Torsten_Fink!

I noticed that the Innuos Zenith MKii you’re using for your Roon Core falls short of our recommended specs.

Because this device uses a CPU below our recommendations, you may experience performance issues, particularly with larger libraries or DSP.

While a little more troubleshooting may be required before we can pinpoint the cause of the behavior you’re seeing, I wanted to point this out since it can impact the product in a number of ways, and you may encounter some limitations going forward.

Moving forward with troubleshooting, can you please confirm the following for me:

  • When you experience the pauses in Roon, is there any particular pattern you’ve noticed? Does it happen during radio play? Only specific sample rates or file types? TIDAL vs local media?
  • As mentioned in our networking guide, we have found that powerline adapters can sometimes have unreliable stability, and so it would be a great test to connect your devices directly to the router via Ethernet and see if the behavior still occurs.


Thanks @dylan,

no patterns. Have only used the Zenith streaming local FLAC. I do suspect the Powerline adapters, but that for me to change requires drilling holes in the wall. Will probably not do :wink:
I will do some more observation to see if I can come up with more insights / findings.
BR Torsten

Thanks for the update, @Torsten_Fink!

If possible, moving your hardware to the router and connecting it directly would be a great way to give this theory a test. If you learn anything else or have any other questions just let me know!


Hi Dylan

I haven’t tried directly connecting the items directly to the router yet, but I’ll try that. In the meantime though, I swapped out the GS105 for the unmanaged FS105, and the problems still occur.

Hi Dylan

An update for you: before going directly into the router, I tried an experiment by plugging the a LAN cable directly into a separate port in the office, and the problem occurred.

Having done this, I have connected the Atom, NAS and MAC into LAN ports on the router as you have suggested, and the problem appears to have been solved. However, having the MAC wired directly into the router isn’t really an option, so would you mind suggesting some further steps that I could take whereby the MAC remains in its original location in the office please?

Many thanks!


Hey @Mark_Hartt-Palmer,

Glad to hear that your problem was resolved with this change. While I understand that the Mac cannot remain in that location, the good news is we have confirmed where the behavior is rooting from so we can focus in on that area.

Per our networking guide, we recommend the following for switches:

If your switch has a “flow control” setting, please make sure that it is enabled. Also, make sure that the switch is not performing any sort of throttling that might impact communication between cores, storage, remotes, and/or audio endpoints. Finally, ensure that the switch is configured to pass multicast and broadcast traffic.

Based on your report and the results of the last troubleshooting test, it would appear that there is something going on with the switch that is causing the behavior you’re seeing. I would start by looking into the settings of your switch, making note of the settings mentioned in our guide, and try to configure the switch’s settings to improve performance.


Actually, it’s cutting out now when connected directly to the Fritz!Box rounter - i.e. the Mac, Naim Atom and the Synology NAS are directly connected. Any further advice would be much appreciated.

Thanks for the update, @Mark_Hartt-Palmer!

Just to be clear, the issue had gone away but is now back even with this change? Is it still exactly the same behavior (even occurring when playing directly to System Output) and still only with local (non-TIDAL) files?

Is there any active antivirus or firewall on the Core? Does disabling them yield any changes to this behavior?