Transfer files from windows laptop to the nucleus internal ssd

I can’t transfer to my nucleus internal ssd and I need help

Hello Stephen and welcome to the community.

Can you expand on the issue your having? Can you see the nucleus data files from your windows explorer under the network tab?

no the only thing I can do is share the music folders with the nucleus my lap top does not see the nucleus on the network.

Assuming the laptop is Windows 10, does it have Network share enabled?

You must also install SMB client from Windows Add/Remove Advanced Futures.

Stephen if you have a newer Windows 10 device you also need to enable insecure guest mode (SMBV1) from memory as I had this trouble earlier this year when I added a new PC to my roster. The older pc worked fine but the new one would not connect.
I will see if I can dig out the Microsoft KB that referenced this



Stephen I think this is the article I followed

There is also this thread on the Roon Forums which might be better (but I never followed as I had fixed my issue before then)

I hope these help



Don’t want to add any confusion to the post and don’t have a clear understanding of the situation.

I got my wife a new laptop for Christmas and did the setup/configuration yesterday. Brought up the Window explorer and selected the Network tab. A highlighted message appeared stating Network Sharing was not enabled with an option to enable. I clicked on the message to enable and Rock appeared with Data - Storage - InternalStorage.

Didn’t attempt to copy/paste any files but it appeared to be ready to go.

Mike that is strange as the default now should be set to off and you have to install the addin and also set registry keys as well. I am glad for you that it worked.

one question what was the build of Windows when you got it? (run the command Winver) as this is a relatively new feature (maybe 1909)



Enabling smb 1.0/cifs client in windows 10 options appears to be working so far. The Roon external storage appeared on the network and I started copying the music files. They are being added to the internal Roon drive and showing up in my library. After all 305 albums are copied and they play with the laptop off, controlling Roon with my tablet, is what I need to see next. this will take hours to complete. Thanks for all your help.

Stephen good news and enjoy the experience.
Hopefully you will be happy with Roon



Hey Mike, The new Lenovo P17 is Win 10 Pro version 2004 (OS Build 19041.685).

Another MSI Laptop I got back in April with Win 10 Home showed the same highlighted message in Explorer but I used the SMB procedure on the MSI to get Rock to show up in the Network. The highlighted message did not reappear after following the SMB procedure.

Over my head but there it is.

Happy to read the OP has got it working either way.

Mike yes it is a strange world where the same OS has different impacts depending on how it is delivered.

Yes good news for Stephen as hopefully he is listening to music now :wink:


Again, thanks to every one. After I was informed to enable SMB I saw there was more than one way to do it I chose the on that did it in one step.
windows key + r > type optionalfeatures.exe >then find and select SMB1.0/cifs sharing support > check the SMB1.0cifsclient > then reboot and wala done.
Its taking 10 hours to copy 305 albums. I’m just waiting now. I know it’s working because the nucleus shows the imported files under internal storage and I disabled disabled file share.
Thanks again, Im out of here,

1 Like

Well done Stephen

Enjoy your music! :slightly_smiling_face:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.