Transport: playback has failed due to playback parameter negotiation with audio device

I am using an ifidsd nano dac. I just installed roon on a new computer, and used the ASIO driver. However, after playing back briefly I got this error message

Transport: playback has failed due to playback parameter negotiation with audio device

The music stopped playing.

I tried using the standard usb driver for playback and got the same error.

I did a little research and was told to disable exclusive mode and exclusive stream under windows. I did this for the defautl usb driver.

So far, so good. However, I am concerned that if I go back to the ASIO driver or go back to exclusive mode on the standard usb driver, I will have the same problem

Any suggestions on how to fix this?

Two questions:

What type of content caused this error? Format? Sample rate? DSD?

How do you have this audio device configured in Roon?

A screenshot of the output settings window is probably the most succinct way to convey this (like this):


I have attached a screenshot of the output settings for the ifi dsd nano using the ASIO driver.

As you can see, I don’t have a setting for use exclusive mode or integer mode.

When you go to the windows control panel and choose “sound” there is no choice for ASIO driver, but I think that happens in general with windows.

I was having problems playing back typical flac files (16 bit, 44KHZ).

Hope this helps.


Thanks. This looks to be configured about how I would expect.

@mike, I think some logs would help here. It should show us what the exact error code coming from the ASIO driver is.


How do I access the logs to send to you?

And, can you provide an email address I should send the logs to?


@mike will PM you with instructions (that’s why I mentioned him in my comment). Hang tight.

Hey @steveoat87 – I just PM’d you with instructions. Let us know if you have any problems submitting the logs.

I’m having the same issue. I’m using the iFi micro DAC.

Maybe it’s the iFi driver and the new version. I’ve been using Roon for a month and never had this issue until updating to build 29.

The change in Build 29 is now, instead of failing silently, we throw up better error messages during playback failures so you have an idea of why it’s not playing. Nothing changed as far as how we actually speak to the audio devices or decode audio files, we just made the user interface for error reporting a little bit more clear.

That error means: we tried to open the DAC up and start a stream, and one of the underlying system calls involved returned an error code.

One of the most common causes is if another app is using the device in exclusive mode, or another app has the device open via an ASIO driver. This commonly causes devices to appear “busy” or “unavailable” to Roon.

Occasionally it can result from a configuration issue, as well (for example, choosing “Native” DSD mode on a DAC that doesn’t support that mode, and then attempting to play back DSD content). With PCM playback, Roon will automatically down-sample high-rate material if your device refuses to play it at the original rate.

I am having this same problem with one particular album (so far). The album is 98k FLAC.

Edit: This seems to be happening for any album above redbook resolution. I don’t think that this was happening yesterday. Any idea what’s going on?

Try restarting Roon to see if it gets better.

If not, we can look at some logs and find out exactly why it’s failing.

I’ll take a look. I haven’t changed anything on my setup though. This only seems to happen after roon has been idle for some time. If I disable and en-enable the iFi ASIO driver, it works fine. I listened all day yesterday. But sometimes if I go off and do something else, I get this error when I return. The core computer is set not to sleep by the way.

Actually, today I had to reboot the entire computer. There are no other programs on this machine running besides Roon. It’s a dedicated box.

Extracampine, are you using an iFi product by chance?

Nope - not even sure what an iFi product is!

How did your guys finally solve the problem? My friend has just installed Roon. When he played any file to any audio device, it shown the exact same error message.

I have this error on a Geek Pulse.
I believe the GP configuration is unchanged since it worked earlier, but I can’t be sure, I rarely use this device.
Haven’t had time to investigate further.

That message happens when we try to start playing through your sound card and the sound card or OS says no for some reason.

There have been a bunch of little fixes to cover different cases over the past few months.

@mike, lets get some logs so we can see what the actual error code is.

As Brian mentioned that message can happen when the OS or Sound Device says “NO”. And that usually happens when you have been using sound from another application before playing Roon. Games especially can cause this. For example, you’ve started something with sound, minimized it and then opened Roon and attempted to play something. It is more prone to happen if Roon is set to use Exclusive mode.
I would reboot the system, verify no other programs are open as some are set to auto-open on boot, and then just start Roon and try the playback and see what happens.
It also can happen if you have Roon and RoonServer on the same physical machine.

I just had this message while streaming to 818v3 USB input using (I think) the ASIO driver. Build 75.

I had it only once and the same track played OK a few moments later.

@brian do you need anything on this?

I’m happy to look at logs, but be forewarned: 95% of the time, the conclusion is “the driver experienced a non-descript internal failure and Roon was just the messenger”.

Let’s not bother then unless I see it again. (And again.)