Trouble adding Cocktail Audio X50 to Roon

OH—No, I’ll try that now—Do you know a Short Cut for that? Sorry. I’ve never done it before. I know I didn’t when it was originally working with ROON. I have VIPER and it usually asks me to Allow or Disallow something. THANKS GED

I Completely Shut off Firewalls. Still Lo

ading Error.

The cocktail probably needs smb1 access. One of the updates to windows turned this access off. Take a look and see. If not, then turn SMB1 access back on.

Instructions here:

Ged, I think you may be Right—My ipad (Just Tried) to connect and cant find the CORE. But I Shut the entire Firewall down?.

When you cannot find the server you might select the option on the iPad to add the server IP and enter 255.255.255.255; and see if that makes a difference.

On a side note, try getting Fing, to check and see what the IP addresses of everything on the network. It is a great little app to help with network issues.

And, finally, a recent Windows update may have also unenabled guest access to remote storage. If this is the issue, then this will help:

If you want to enable insecure guest access, you can configure the following Group Policy settings:
Computer configuration\administrative templates\network\Lanman Workstation

“Enable insecure guest logons”

Hi Rugby—You were right—The SMB1 wasn’t on—I Do remember doing that 9 months ago when I first started. I shoulda made a note. I just did! So I turned it on and Restarted my PC. Went back to ROON and ADDED the IP and still nothing----I tried both smb:// IP /MusicDB (AND) \ IP \MusicDB….Still Error. And ipad still not connecting to Core.

Did you try the other suggestion about insecure guest logons?

I can’t find that. Is it in Programs? I stumble on computers for stuff like this. Sorry

Hi Tony,

No Problem. To get into the Group Policy Editor in Windows.

Open search, and type gpedit and hit return. It should open the group policy editor. Like so:

LOL. Sorry. I got that Screen up. UH, where do I go? What do I change?

I found it under admin. Lanman Workstation—But what do I do with it? FILTER ON?

Enable it, if it is not already. If you do not have the option. Hold on. At work atm and will need to get home to continue and review exactly what I entered. Be back in an hour…

OK. I believe I Did it. It was off.

OMG----It Just Worked in ROON. Loading Now from X50D… I’m like a little KID. Thank you So Much RUGBY. You’re a Genius. I’m so clueless. MY iPAD still not connecting to Core though. :frowning:

1 Like

Great News!!! ( Yes, it takes me about an hour each way for work :frowning: )

In case you missed my comment about your iPad, I’ll repeat it here:

I had No Issues with Both my Cell and the ipads before.

Yeah—My CELL doesn’t connect either. So Frustrating. What IP do I try to hook them (Cell and ipad) into? Thanks for all your Help Rugby. You’re a truly Great ROONer.

Hi @Tony_Colletti,

Glad to hear you were able to get the X50 share working again with @Rugby’s help (Thanks for jumping in here Rugby!).

As for the issue of not being able to connect your iPad/Phone to Roon, I would check the Windows Firewall.

Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and make sure that you’re using a Private network type, not a Public one, you can use these instructions to check this.

I USE VIPER. Not the Windows Firewall. I’ll make sure they’re off though. Thank you noris. I’m a massive Fan of ROON and it’s community. I’m just not good at computer Issues. wow–gpedit still makes me laugh. No Clue what that was. lol