Trouble Creating a Backup Connection from NUC to Windows 10 Laptop Shared Folder

Roon Core Machine

Intel NUC10i3FNH, i3, 16GB, Roon OS 1.8 Build 931

Networking Gear & Setup Details

NUC and Windwos 10 laptop both hardwired in. Router is a TP-Link AX6000

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Hi, I cannot get the Manual Backup setup to work between my Intel NUC10i3FNH and my Windows 10 laptop. I created a shared folder on my laptop and made sure it was set to have full read/write access in the sharing/security settings. Please see the images from my Google Drive link below so you can see all of the settings I have chosen and may be able to tell me what I am doing wrong. I know my PC login and password, pin, IP address, workgroup name, shared folder \ASUSPC\RoonBackup, all the things. I’ve put in every combo of settings into Roon I can muster and none of them allow a successful connection.

Please review the images here and help me to troubleshoot and get the backup feature working: Loading Google Docs

AFAIK you need a local or domain user account, online (Microsoft) accounts don’t work.

I’ve tried that now making a local user account and still no luck. Also SMB 1.0 was already turned on on my PC fwiw.

How I did it -


Add id/pw when you set up the network share. I don’t remember using a Workgroup, but it couldn’t hurt.

1 Like

I feel like I did the same exact thing. Did you create a local user account in windows and what did you input into the Roon settings menu (blank in screenshot)?

I used my WIN10 logon userid/password and I gave my userid permission to the actual directory where I would put the backups.

It’s been awhile, but come to think of it I might have also had to do this -

The only way I’ve found to make it work is to turn off the Windows private firewall. I tried everyone’s advice amongst other steps and nothing worked, even creating custom rules in the advanced private firewall settings to allow all inbound and outbound connections to Roon, setting the overall connection to allow all traffic, and Roon was already allowed in the connection settings anyways. Nothing works besides turning the private firewall off entirely, but I’m not going to leave my firewall off.

Does anyone have any ideas to get Roon around the private firewall, while leaving the private firewall turned on

Sounds like you have to allow Windows File Sharing in your firewall.

Will you please send a screenshot of your firewall settings - any of them that would relate to Roon being blocked or allowed through, so that I can make sure my settings look identical? I worked and troubleshooted privately with another user who has gotten the backup feature to work and made sure all of my user settings, file share, permissions, Windows Antivirus, and Windows Firewall settings were identical to his and still no luck for me.

@danny is there anyone on your end that can help me to troubleshoot? I summitted a ticket on 4/17 but have not heard back yet.

Double check smb in use on Windows. Updates sometimes turn it off.

SMB1.0 is enabled already. I can do everything Roon is supposed to be able to do with the exception of the Backup and Network Storage features. I can drop music files into my NUC’s ROCK storage folder from my PC, playback music with Roon on my PC from the Roon CORE, etc. Very strange. Would be great if someone from Roon could do a screenshare with me to troubleshoot at this point.

I made a Word file with screenshots of every roon related setting on my PC I can think of. Can you all please review and see if you can tell what I am missing or doing wrong?

Still the same as above, in the new document you still seem to use an online Microsoft account exclusively. Try and create a local account, give him the rights for the share an try again with that user.

As for as your firewall settings, you documented the Roon settings (which is working and not the issue) and not the Windows file sharing settings (where incoming connections to local shares seem to get blocked).

I did try that already and it did not work. I tried with roon installed on the local acoount as well from that login. The only thing that worked is turning the private firewall completely off.

This File Sharing setting is already on on both the Private and Public side for me.

No one asked about the account Roon is installed on your PC. As of your description, you don’t have an issue with Roon but with Windows file sharing. So please use a local user for the file share. You may also look for help in a Windows forum if using a local user for the file share doesn’t work.

What exactly? Looks like your documentation is lacking content, this makes it hard for others to help you as they can’t trace your steps.

This topic was automatically closed after 43 days. New replies are no longer allowed.