Trouble getting HQ Player to work [Solved]

If you guys would prefer me to open another thread, just let me know.

I’ve been unable to use Roon with HQP. I posted this on CA:

[Quote=Originally Posted by Miska View Post]
First make sure HQPlayer works alone, without Roon, so you can play content. Then leave HQPlayer running and start Roon, use “localhost” for HQPlayer and when you click Play to play something it should talk to HQPlayer just fine.

Windows security software firewalls usually leave “localhost” alone, but there may be exceptions. But at least it should ask for such cases whether you want to allow connections for applications.[/quote]

[Quote=Originally Posted by Miska View Post]
Please enable HQPlayer log file, restart HQPlayer, do one standalone playback (no issues) and then one playback with Roon (issues). And then please email me that log file. I could then try to figure out what is going wrong.

The main difference between the two is that when HQPlayer is playing alone it is handling the file reading on it’s own. When you play with Roon, Roon is handling the file reading and then streaming the data to HQPlayer.

Also make sure you use “localhost” in Roon settings as address to HQPlayer.

Other possible culprits:

  • If you are using CUDA offload (shouldn’t, I believe 2015 iMac doesn’t have nVidia GPU anymore), Roon adds it’s own GPU load on top
  • Some network issues, some process (like sofware firewall) interfering with Roon-HQPlayer comms
  • Roon having trouble keeping up with dataflow from a file to HQPlayer[/quote]

I’m having this problem again. I tried all above. CUDA odd, turned off W10 Firewall, Plays perfectly thru HQP.
I tried to generate log file, but Windows is not showing any HQP log anywhere. Even this: Users/username/AppData/local/HQPlayer

Any ideas guys for me to try to fix this? This is on a brand new 6700k PC, ROON Server from Synology 1515+NAS, and Microsoft Remote to access ROON.

Thanks for any help!!

I have not tried hqplayer, yet. I just signed up for the OS X trial to test it.

To update, no change. Despite HQP working flawlessly on its own, Roon/HQP refuses to play.

Using Roon server on Synology NAS, iPad to control Roon. All I get is “Transport: Couldn’t Connect To HQP”

It sounds like a potential Synology Firewall / Roon-HQP interface port issue.

Is anyone on here running this setup?

I tried disabling Synology’s Firewall with no change.

I tried to reproduce it. Installed the HQPlayer trial and it seems to work - after I clicked the “Globe”-Icon in the HQPlayer Desktop software to “allow control from network”. Did you enable this option as well?

Yes, it is enabled. So strange it’s not reproducible for you. You are using Roon Server on a Synology? And not a good sign if I’m to get this resolved.

Edit: I was thinking the problem is what I started the other thread about, having problems getting /volume1/MUSIC to load. I noticed that the bottom banner of Roon isn’t being changed at all. Like the album isn’t being loaded. It shows some artist from over an hr ago. It won’t change/update at all despite restarting both the iPad and Roon and HQP.

Oh the other hand, I’m getting the same error message on Tidal "Transport: blah blah
I’m just brainstorming :wink:

??? Listen, I’ve yet to have HQP and Roon working. It’s been quite awhile since Roon has functioned. This is getting on my nerves tbh.

@fore ----- Sorry for the delay and the inconvenience here. Let’s try and get this figured out.

In order for me to better understand what the issue could be here can you please describe, in detail, your current setup. The more information I have, the easier it will be to understand how you are setup and what you are using.

I would also like to see how you are configured in the application. Can you please provide screen shots of the Audio and Storage tab settings in Roon. Thanks!


what version of Roon you are running
RoonServer Roon Installer Script 1.0

Windows 10 Version 1511 OS Build 10586.420 64 bit

Basic information is Intel 6700k Skylake 32GB RAM

Describe where your music is stored Synology 1515+ is where I keep all the music. Router is an ASUS RT AC88U. (I still had the exact same problem when I use straight Ethernet from router to PC. PC has no wireless function.

Output is WAV files to iFi Micro DSD
No DIRAC or other sw.
Happens with all: pcm, dsd, Tidal

Here’s a couple screenshots. Note in the first one, the artist name at the bottom won’t change. It’s been Sarah Brightman for over a week now.

1 Like

Hi @fore,

Apologies if you’ve already tried this, but the playbar stuck on Sarah Brightman indicates Roon Server may have got itself into a bad state. Have you tried restarting Roon Server, rebooting the PC or uninstalling and reinstalling Roon Server ?

No apologies at all Andy. Yes. I’ve rebooted, restarting/uninstall/reinstall Roon Server. Same. Still stuck on Brightman.

Could it be due to that I can’t find my RoonServer database. Looked
here with nothing there.

Roon Server (headless)
C:\Users\ [your user name] \AppData\Local\RoonServer\

Hi fore,
I think I spotted something on your screenshots.

RoonServer is running on your Synology. Because of that, you won’t be able to find your database in

“C:\Users\ [your user name] \AppData\Local\RoonServer”

It is always located on the Roon Server device. Your Mac just connects to the server. You also need to keep that in mind, when entering storage paths and network audio devices.

In your screenshot I could read “localhost” under the hqplayer entry in the audio settings. It should be the IP address of your Mac that is running hqplayer.

1 Like

Thanks Chris, finally ‘some’ progress. Changing from localhost to IP worked. The bottom banner now is in sync with chosen music.

However, I’m still getting the same error message of Transport…

Sorry, HQPlayer is running on a windows computer, right?
Then I was wrong with the IP address of the Mac. Instead it should be the IP of the computer with the hqplayer running.

I ‘had’ the PC IPs address…but was off a digit. With the right IP address Chris…SUCCESS!! Omg, I can’t believe we actually got this to work! All formats working!

Thanks Chris and the gang!