Trouble logging in to TIDAL - with new method

I have exactly the same problem for over 2 months.
Did everything… no change

Have the same problem, support is useless unfortunately

Have same problem for weeks now. Support simply doesn’t know what to do… I tried every single advice, nothing work, tomorrow will rebuild my Macmini OS.

Hi @Pawel_Rybak

I am a user just like you, I run my Roon Core on both a classic MacPro with MacOS 10.14.6 and I also use ROCK core built on unsupported hardware. I am on Roon build 528.

I have logged out of TIDAL on both cores, rebooted both cores then logged back in to TIDAL, luckily for me I have not had any issues and I swap cores and TIDAL accounts regularly.

Have support asked you to clear your cache on Safari, or whatever web browser you are using and then reboot your computer before trying to log back in to TIDAL? There has to be something specific to your and other users setups that are encountering this issue.

Again this must be a hard one for Roon to fix if the majority of Roon’s 100,000 strong membership are not having issues. I am guessing that Roon are working hard to try and recreate this issue on their in house set ups before reporting back and releasing a fix.

Hi @Pawel_Rybak

Spamming all over the forum really does not help you or anyone else. I have collected all your recent posts into this topic … Looking at your posting history I can’t see where you have requested for any help on this. If you do require [further] help see below.

In order for Roon’s @support team to better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so they can have a clear understanding of how your devices are communicating.

Sorry, but today this problem just crossed me. Your team wrote to me and we are trying to solve this. I started with new database (as instructed by Your team) and now Tidal is working. Will see how long but hope my problem will be solved.

This is my previous post:
sorry for pasting this link that way - I dont use forums, no experience

Hi again,

I clicked the link but it’s not visible to me … I can only assume Roon’s @support team were communicating with you via Private Messages. That’s their call I am not Roon staff, just one of community mods on here.

May I ask, if your system is good now … what sparked off all those posts?

It’s good for last 10min… They just wrote to me a solution. Right now.
Anyway: Thank You, Sorry for all the mess


That’s good to hear, I hope there are no more problems for you, enjoy.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.