Trouble starting Radio with classical albums


Still getting exactly the same problem in that Roon Radio will not work on the Classical Catalogue/Library but is fine on Rock etc. At the end of a classical album after searching for 20 seconds or so I get Unexpected Error: Limiting Roon Radio to Library and if I play an album using Roon Radio I get Roon Radio; Nothing Similar to Play!. As I said before it is almost as if something is blocking the classical catalogue. I have tried rebooting the Core and signing in and out of Qobuz but the problem remains. Everything else is absolutely fine. I have never previously experienced this issue.

Core Machine (Operating system/System info/Roon build number)

Roon ROCK NUC 7i7
Operating System - Version 1.0 (build 174)
Roon Server Software - Version 1.6 (build 416)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Apple Airport Express Router to Netgear switch ethernet hard wired to endpoint

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Naim ND555 ethernet hard wired

Description Of Issue

See above. I can’t see how this can be a Network issue when it only appears to be classical genre related

I have noticed this a few times my self recently.

Hi @Trevor_Clarke,

Can you provide some examples (including screenshots) of albums that you’re experiencing this with? Is this occurring with every classical album or only certain ones?

I will try later but it is every single classical album I have tested including very mainstream stuff which you would not expect difficulty with. Every other genre is working fine.

Here are 5 to be going on with:

@dylan - I’ve just tried this using the Vivaldi: Teatro alla moda album as a seed. When the album finishes, I get a “Coming up in 0:00 seconds” pop-up (for a Violin Concerto), but the track never starts playing…

Yes Geoff that’s how I first identified it on the back of Roon Radio not kicking in. Even limited to library it doesn’t play.

If you kickstart the popup (click the thumbs-up, and then click the Play button), does it then start Roon Radio, and does this then continue as expected? It seems to do that here (I’m now into my second multi-part concerto).

Yes but only limited to Library in my experience.

Hmm, that’s different to me - I’m getting the full Roon Radio experience (it’s including works streamed form Qobuz).

I’m having the same difficulties with Roon Radio today. I started my day like most, selecting some classical music while I work (Keith Jarrett Handel: Suites For Keyboard - local files), expecting the music to flow as usual. I noticed the queue was limited to local files and wasn’t automatically playing the next tracks. I rebooted, signed out/into Qobuz, toggled the Roon Radio options to no avail. I manually added a Qobuz track to the queue and it played as expected. The queue still says it is limited to local library though and isn’t selecting any Qobuz tracks on its own. I haven’t tried other genres yet.

I’m running Roon 1.6 (build 416) on a Windows 7 64-bit OS to a PS Audio Directstream DAC via their Bridge II.

Thanks everyone, the technical team is continuing to look into this. I’ll be sure to keep everyone updated as soon as I have more information.

Has this been addressed by the roon staff? I can no longer use radio for classical due to constant “nothing similar to play” or “limited to radio” messages. This is true for both qobuz and tidal.

The post directly above yours, by Dylan, says they are working on it.

Thanks Ged. I had posted my comment to a related thread that Dylan had not responded too. They moved my comment so now I see they are aware and working on it…thanks again

It gets very random when that happens.

Same here the past few days. After playing Qobuz, I see “Roon Radio limited to library”. I logged in and out of all streaming services and restarted Roon. Still having issues. All “play Roon Radio” options are turned on.

@dylan, something odd - I went to the Qobuz/New Releases screen, and when I chose the Classical genre, then Roon flashed up the “limiting Roon Radio to Local” message. It’s done this a couple of times, but it’s not repeatable, just happens occasionally…

Trevor, I am having the same issue, and it’s not just at the end of a classical album. If I start Radio based on a classical artist (Academy of Ancient Music, e.g.) after about 20 seconds I get exactly the same behavior. And it’s happening with Tidal as well as Qobuz. Seems like the classical music selection algorithm might have gotten corrupted/broken somehow? It has alway worked just fine until a few days ago, and is only a problem with classical music (not rock or jazz).

Continuing to be an issue for me. Also only for classical.