Trouble with adding radio stations [SOLVED]

In the UK we pay a license fee for BBC services. The TV Licence. It cover TV Radio and all,other BBC offerings. I am surprised they haven’t thought to offer an international licence to raise funds as I expect the demand would be strong.

Hi Noris,

I am UK based, to the geo sensitive station should work for me (and does in a web browser) - I’ve also tried the global ones and have the same error setting up the stations.

With the TuneIn station, the target zone makes no difference and I still get the Transport: Failed to load media problem.

As per Martin’s earlier post, my setup is (shown here):

  • Core 1.5 (build 363) running on IBM Lenovo T61p with Ubuntu Server 18.04 LTS
  • Storage OpenMediaVault on a Raspberry Pi and 2x Western Digital Passport 1Tb drives
  • Both of the above hard wired into a Netgear GS105 switch which in turn is wired to the primary Google WiFi point
  • Meridian 218 and MS200 wired into a secondary Google WiFi point for main two systems
  • 2x B&W Zeppelin
  • Remote (that I’m trying to use to set up radio): macOS 10.14.1

All working flawlessly for music from OpenMediaVault

Hello @Mesmo,

Thanks for confirming the setup details. Do other Radio stations work as expected or is other online content such as TIDAL working fine? If other radio stations do not work as expected, I an wondering if there might be something amiss with your DNS settings and Roon not being able to resolve the station’s streaming URL. Can you please try updating your DNS servers to Goolge’s DNS or Cloudflare and let me know if that helps?

Thanks,
Noris

Thanks for the suggestion - I’ve tried configuring both Google and Cloudflare DNS on Google WiFi (which acts as a DCHP server for all devices so assuming it passes those DNS settings on to its clients) and no change. I’m unable to change the DNS settings on my router (Sky hub).

Further to this, I’ve not managed to get any other radio stations working, though historically I have had internet radio working.

Be sure to renew each devices DHCP lease or they won’t pick up the new DNS server info until 1/2 through the lease expiration. Restart is likely the easiest option.

Sadly no joy after a reboot either…

Hello @Mesmo,

Since other radio stations are not working as expected, I am wondering if there is something wrong with the Ethernet cable from your Core or with the network switch. Can you please try using a different Ethernet cable or connecting your Core directly to your router to verify if the same behavior occurs?

Thanks,
Noris

My experience is/was that adding a URL from the actual radio station itself does not take. Rather, the URL must be from an internet radio provider, like Internet-radio.com.

So, I’ve made a little modest progress in my trouble-shooting… when I move the core onto a different machine (running macOS Mojave), Internet Radio works as expected.

When I return to my core on Ubuntu on the Lenovo the issue returns.

So what immediately springs to mind is my installation of the linux dependencies (ffmpeg et al) - any advice on how to verify that they’re all present and correct?

Hello @Mesmo,

I want to try something different. Can you please try pasting the stream URL in Roon Radio on your Ubuntu Core? For example (http://icy1.abacast.com/kplu-newsjazzmp3-32)? Does this link work as expected?

If so you may be experiencing the same issue as this thread which QA is investigating now:

Please let me know if that link works and if it does you may be able to get the BBC stream working by posting the stream link instead of the tunein link (http://opml.radiotime.com/Tune.ashx?id=s24941&formats=mp3,aac)

Thanks,
Noris

Nope - that gives me the message “Roon could not find a radio station at this URL”.

Hello @Mesmo,

Thanks for trying those links and verifying that it is not the same issue. I think you may have been right regarding the dependencies for your radio station, can you please check to make sure you have the proper dependencies installed for your linux Roon build? You can use the commands listed here to make sure that they’re installed properly:

For  ffmpeg :

$ sudo apt-get install ffmpeg

For  avconv :

$ sudo apt-get install libav-tools

These commands are from our Linux Setup Guide

Thanks,
Noris

Thanks Noris,

I really struggled to install ffmpeg originally as I was unable to find it using apt-get, but did manage in the end using:

$ sudo snap install ffmpeg

I’m running version 4.0.2 of it currently.

If I try using apt-get I get an error:

Package ffmpeg is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package ‘ffmpeg’ has no installation candidate

I get a similar error when trying to install libav-tools:

E: Unable to locate package libav-tools

So I installed libsound2 via apt-get.

If I run /opt/RoonServer/check.sh I get this response:

Checking to see if RoonServer can run on this machine
Checking for Binary Compatibility [ OK ]
Checking for ALSA Libraries [ OK ]
Checking for ffmpeg or avconv [ OK ]
Checking for the mount.cifs command [ OK ]
Testing ulimit -n 8192 [ OK ]
STATUS: SUCCESS

Hello @Mesmo,

Thanks for letting me know. I have passed your feedback to the QA team who will take a look at the log snippet you posted and I will be sure to let you know once I hear back from them regarding next steps.

Thanks,
Noris

Hello @Mesmo,

I spoke to the technical team today and they have confirmed that the issue you’re seeing here is because you don’t have ffmpeg installed on your Ubuntu Core. I would take a look at these instructions to see if they help with the installation of ffmpeg:

Please let me know if this helps.

Thanks,
Noris

Thanks Noris,

I do have ffmpeg installed, just not via apt-get, using snap instead.

When I try with those instructions its similar to the issues I had in my original install:

$ sudo add-apt-repository ppa:jonathonf/ffmpeg-4

Backport of FFMPEG-4 and associated libraries. Now includes AOM/AV1 support!
More info: https://launchpad.net/~jonathonf/+archive/ubuntu/ffmpeg-4
Press [ENTER] to continue or Ctrl-c to cancel adding it.
Hit:1 http://archive.ubuntu.com/ubuntu bionic InRelease
Get:2 http://archive.ubuntu.com/ubuntu bionic-security InRelease [83.2 kB]
Hit:3 http://ppa.launchpad.net/djcj/hybrid/ubuntu bionic InRelease
Ign:4 http://ppa.launchpad.net/jonathonf/ffmpeg-3/ubuntu bionic InRelease
Get:5 http://ppa.launchpad.net/jonathonf/ffmpeg-4/ubuntu bionic InRelease [15.9 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
Ign:7 http://ppa.launchpad.net/mc3man/trusty-media/ubuntu bionic InRelease
Err:8 http://ppa.launchpad.net/jonathonf/ffmpeg-3/ubuntu bionic Release
404 Not Found [IP: 91.189.95.83 80]
Err:9 http://ppa.launchpad.net/mc3man/trusty-media/ubuntu bionic Release
404 Not Found [IP: 91.189.95.83 80]
Get:10 http://archive.ubuntu.com/ubuntu bionic-security/main amd64 Packages [209 kB]
Get:11 http://archive.ubuntu.com/ubuntu bionic-security/main Translation-en [82.1 kB]
Get:12 http://ppa.launchpad.net/jonathonf/ffmpeg-4/ubuntu bionic/main amd64 Packages [6,976 B]
Get:13 http://ppa.launchpad.net/jonathonf/ffmpeg-4/ubuntu bionic/main Translation-en [4,652 B]
Get:14 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [444 kB]
Get:15 http://archive.ubuntu.com/ubuntu bionic-updates/main Translation-en [167 kB]
Reading package lists… Done
E: The repository ‘http://ppa.launchpad.net/jonathonf/ffmpeg-3/ubuntu bionic Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository ‘http://ppa.launchpad.net/mc3man/trusty-media/ubuntu bionic Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

$ sudo apt-get update

Hit:1 http://ppa.launchpad.net/djcj/hybrid/ubuntu bionic InRelease
Hit:2 http://archive.ubuntu.com/ubuntu bionic InRelease
Hit:3 http://archive.ubuntu.com/ubuntu bionic-security InRelease
Ign:4 http://ppa.launchpad.net/jonathonf/ffmpeg-3/ubuntu bionic InRelease
Hit:5 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:6 http://ppa.launchpad.net/jonathonf/ffmpeg-4/ubuntu bionic InRelease
Ign:7 http://ppa.launchpad.net/mc3man/trusty-media/ubuntu bionic InRelease
Err:8 http://ppa.launchpad.net/jonathonf/ffmpeg-3/ubuntu bionic Release
404 Not Found [IP: 91.189.95.83 80]
Err:9 http://ppa.launchpad.net/mc3man/trusty-media/ubuntu bionic Release
404 Not Found [IP: 91.189.95.83 80]
Reading package lists… Done
E: The repository ‘http://ppa.launchpad.net/jonathonf/ffmpeg-3/ubuntu bionic Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository ‘http://ppa.launchpad.net/mc3man/trusty-media/ubuntu bionic Release’ does not have a Release file.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

sudo apt-get install ffmpeg

Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
ffmpeg : Depends: libavcodec58 (= 7:4.0.3-1~18.04.york0)
Depends: libavdevice58 (= 7:4.0.3-1~18.04.york0) but it is not going to be installed
Depends: libavfilter7 (= 7:4.0.3-1~18.04.york0)
Depends: libavformat58 (= 7:4.0.3-1~18.04.york0) but it is not going to be installed
Depends: libavresample4 (= 7:4.0.3-1~18.04.york0) but it is not going to be installed
Depends: libavutil56 (= 7:4.0.3-1~18.04.york0) but it is not going to be installed
Depends: libpostproc55 (= 7:4.0.3-1~18.04.york0) but it is not going to be installed
Depends: libsdl2-2.0-0 (>= 2.0.8) but it is not installable
Depends: libswresample3 (= 7:4.0.3-1~18.04.york0) but it is not going to be installed
Depends: libswscale5 (= 7:4.0.3-1~18.04.york0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Not being a linux expert I’m at a bit of a loss, but it looks to me like this packaging of ffmpeg is no longer complete.

Hello @Mesmo,

While we don’t typically troubleshoot non-Roon related issues (such as ffmpeg) I have found these following articles which may point you in the right direction:

(Take a look at this one in-depth):

Thanks,
Noris

Partial success - thanks for all your help so far…

I looked at those links and sadly got nowhere with apt-get, so I followed the steps here https://www.johnvansickle.com/ffmpeg/faq/ and managed a manual install.

I now have the high quality BBC stations working, but still no joy with the TuneIn stations (though right now I cannot get them working in the browser either).

Hello @Mesmo,

Glad to hear you’ve been able to use those instructions to resolve the ffmpeg issue. If the Tunein links don’t work in your browser then it is highly unlikely they will work in Roon. There’s quite a few radio stations listed in this thread if you’re looking for some new content:

Thanks,
Noris