Trouble with adding radio stations [SOLVED]

#1

I’m trying to set up some radio stations, but am having real trouble… if I try to set up using URL’s in the Internet Radio URL Swap Meet thread, such as BBC Radio 3 here: Internet Radio URL Swap Meet then I see this error:

Or if I cut and paste a URL from the TuneIn Radio site, while I can add it, when trying to play, I get this error:
image

Any advice gratefully received…

(Martin Webster) #2

I suspect there’s an error in the URL … make sure there’s no leading space and you paste the following link exactly.

http://a.files.bbci.co.uk/media/live/manifesto/audio/simulcast/hls/uk/sbr_high/ak/bbc_radio_three.m3u8

or …

https://tunein.com/radio/BBC-Radio-3-913-s24941/

#3

Thanks, but no improvement - the top URL plays in a web browser but roon (well my roon anyway) won’t accept it and the bottom one still gives that transport error…

(Ged) #4

I tried the top one and it worked fine.

(Chris ) #5

This is what I use

http://a.files.bbci.co.uk/media/live/manifesto/audio/simulcast/hls/uk/sbr_high/ak/bbc_radio_three.m3u8

(Martin Webster) #6

Looping in @support for some help. @Mesmo please provide some details of your setup as described in the following KB article. Thanks.

(Noris) #8

Hello @Mesmo,

I have tried the various radio links posted here, the only one that I was able to sucessfully use was the tunein one (https://tunein.com/radio/BBC-Radio-3-913-s24941/) but this may be because the other links are geo-blocked for my location (US).

Can you please let me know if the behavior is the same when trying to output to all of your zones or even “System Output” and provide more information regarding your setup using the link Martin posted?

Thanks,
Noris

(Martin Webster) #9

@noris Yes, the BBC use geo-blocking.

(Chris ) #10

In the UK we pay a license fee for BBC services. The TV Licence. It cover TV Radio and all,other BBC offerings. I am surprised they haven’t thought to offer an international licence to raise funds as I expect the demand would be strong.

#11

Hi Noris,

I am UK based, to the geo sensitive station should work for me (and does in a web browser) - I’ve also tried the global ones and have the same error setting up the stations.

With the TuneIn station, the target zone makes no difference and I still get the Transport: Failed to load media problem.

As per Martin’s earlier post, my setup is (shown here):

  • Core 1.5 (build 363) running on IBM Lenovo T61p with Ubuntu Server 18.04 LTS
  • Storage OpenMediaVault on a Raspberry Pi and 2x Western Digital Passport 1Tb drives
  • Both of the above hard wired into a Netgear GS105 switch which in turn is wired to the primary Google WiFi point
  • Meridian 218 and MS200 wired into a secondary Google WiFi point for main two systems
  • 2x B&W Zeppelin
  • Remote (that I’m trying to use to set up radio): macOS 10.14.1

All working flawlessly for music from OpenMediaVault

(Noris) #12

Hello @Mesmo,

Thanks for confirming the setup details. Do other Radio stations work as expected or is other online content such as TIDAL working fine? If other radio stations do not work as expected, I an wondering if there might be something amiss with your DNS settings and Roon not being able to resolve the station’s streaming URL. Can you please try updating your DNS servers to Goolge’s DNS or Cloudflare and let me know if that helps?

Thanks,
Noris

#13

Thanks for the suggestion - I’ve tried configuring both Google and Cloudflare DNS on Google WiFi (which acts as a DCHP server for all devices so assuming it passes those DNS settings on to its clients) and no change. I’m unable to change the DNS settings on my router (Sky hub).

#14

Further to this, I’ve not managed to get any other radio stations working, though historically I have had internet radio working.

(Larry Post) #15

Be sure to renew each devices DHCP lease or they won’t pick up the new DNS server info until 1/2 through the lease expiration. Restart is likely the easiest option.

#16

Sadly no joy after a reboot either…

(Noris) #17

Hello @Mesmo,

Since other radio stations are not working as expected, I am wondering if there is something wrong with the Ethernet cable from your Core or with the network switch. Can you please try using a different Ethernet cable or connecting your Core directly to your router to verify if the same behavior occurs?

Thanks,
Noris

(stan pennock) #18

My experience is/was that adding a URL from the actual radio station itself does not take. Rather, the URL must be from an internet radio provider, like Internet-radio.com.

#19

So, I’ve made a little modest progress in my trouble-shooting… when I move the core onto a different machine (running macOS Mojave), Internet Radio works as expected.

When I return to my core on Ubuntu on the Lenovo the issue returns.

So what immediately springs to mind is my installation of the linux dependencies (ffmpeg et al) - any advice on how to verify that they’re all present and correct?

(Noris) #20

Hello @Mesmo,

I want to try something different. Can you please try pasting the stream URL in Roon Radio on your Ubuntu Core? For example (http://icy1.abacast.com/kplu-newsjazzmp3-32)? Does this link work as expected?

If so you may be experiencing the same issue as this thread which QA is investigating now:

Please let me know if that link works and if it does you may be able to get the BBC stream working by posting the stream link instead of the tunein link (http://opml.radiotime.com/Tune.ashx?id=s24941&formats=mp3,aac)

Thanks,
Noris

#21

Nope - that gives me the message “Roon could not find a radio station at this URL”.