Trouble with Roon ARC when I want to play tracks marked with a TAG(Update after ARC 1.0.022 b.100049)

Roon Core Machine

ROCK on INTEL NUC7i7BNH

Networking Gear & Setup Details

ASUS router. Core is connected via Ethernet cable. No VPN

Connected Audio Devices

Devialet Phantom Gold, hardwired
Blousound, hardwired
Phones on WIFI, Ipad WIFI, Thinkpad WIFI

Number of Tracks in Library

20000 tracks

Description of Issue

Hi, I’m having trouble with Roon ARC when I want to play tracks marked with a TAG.

Description of issue:
When I select tracks in ARC and then select a TAG containing songs, Roon ARC responds poorly and after a while an error message appears with “Poor connection - Retry”.

This error message comes when I am connected to the home network and when I am on the go. In some cases, ARC hangs completely. Even when I select a TAG where the songs tagged are downloaded to the phone, this occurs.

This happen with my 2 Samsung phones (A52 and SM-G960).

Browsing and playing songs without selecting from TAG, works great.

I created a new TAG with a song or 2 seems to work fine. The more songs I add to the TAG, the more sluggish the scrolling becomes. Especially initially, and when I swipe down when I’m at the top of the content view.
The error message “Poor connection” comes when there are more than approx. 280 songs in the TAG.
Tested this with my phone connected to the home network.

Update after release and ARC 1.0.022:
The error message “Poor connection” seems to have disappeared.
There is still a 2-3 second hang when I swipe down on the phone when I am at the top of the track list (When tracks with one or more TAGs are selected).