Unable to access iTunes folder through smb

Roon Core Machine

ROON Rock Server
Nuc10, i5, 16GB RAM, 256GB SSD plus 2TB SSD for music library
Server: V1.8 (build 882), OS v1.0 (build 227)
„Watched folder“ on iMac

Networking Gear & Setup Details

Router: Speedport Smart 3 (Deutsche Telekom) via Ethernet

Connected Audio Devices

Bluesound NODE n130 connected to ethernet

Number of Tracks in Library

19,000 tracks

Description of Issue

@support Help, please!

I read lots of your guidance on how to connect my Rock server with my iTunes folder on an iMac. Including granting access rights etc. but not successful.

At least by now I don’t get error messages anymore. Now it seems to add the network share (and shows the wobbling Roon logo) - but nothing is happening. And if I click anywhere into the Roon window that signals it is adding the network share just disappears…

Pls advise.
Many thanks!


Hello @Christian_Kroos ,

Welcome to the forum and thank you for your patience here while we’ve had a chance to reach your case following the Holidays.

Can you please confirm that you have set up the iMac shared folder according to our guide here?

Can you share a screenshot of the network share info you are putting in as well as the Mac Sharing screen permissions?

Thank you!

Thanks, Noris!

ad 1: yes, I used the guidance behind your link.

ad 2: I have to correct my above message: now, today I do get an error message:

Before, I had just the roon logo moving but without anything happening. The roon logo disappeared when I clicked somewhere in the roon window.

Here’s the pic from the iMac file sharing settings:

And this is the path to the iTunes folder on my iMac:

Hope helps.

Thanks for any idea to make this work.

Best, christian

In Roon try writing smb://IMAC.local/iTunes instead of writing smb://192.168.xxx/iTunes

Also, on your iMac, hit the Optionen… button and make sure that the option for “Share files and folders using SMB” is selected.

Thanks much!
Yes, I also did try …//IMAC.local/… instead of …///…
And the “share files and folders using SMB”-box is ticked…
Best, Christian

Under the “Windows File Sharing” you should also have the box selected next to your account name. If it was not selected and you select it, it will ask your to enter your password. Go ahead and enter your password.

In Roon, you should should be using smb://IMAC.local/iTunes. It looks like the username and password are correct. I just went through and added the folder named “Test” as a shared folder in Roon by following the instruction that are provided in the link above.

1 Like

Thanks again!!

Yes, I double-checked, the Windows File Sharing is activated as well.

I then moved back to using smb://IMAC.local/iTunes (instead of the variation with the iMac IP address) and tried to add a network share. It again shows the sign that it‘s adding…… But it does not come to an end and nothing seems to be happening. Even if I give it some minutes, and then click into a roon window, the adding ends but nothing was added…

I am clueless on what to try next!?

Yeah, this is strange. I would maybe try connecting to the iTunes Music folder that is in the iTunes folder. I think all of the other file types in the iTunes folder may be causing issues since Roon does not support them.

If that does not work then I would try turning off your firewall and seeing if you can connect.

1 Like

Done. First selected the suggested folder.
Same result as before: it seems to be starting to add a network share but it does not happen.

Second, additionally deactivated my firewall for a try. Same result as above.

How can an easy step turn out to be so difficult? :roll_eyes:

I have no idea why this is is so difficult :thinking:

Were you able to connect to a test folder with nothing in it? If you were it means Roon can connect to your computer, which is obviously a good thing. It also tells us that there is probably something in your iTunes Music folder that it does not like.
Also, Is your computer using ethernet or wifi? Do you have any additional routers between your NUC and your computer?

I am sorry your are having these issues, but I am sure it will get figured out

1 Like

Thanks so much for your continued support @AnimalOnDrums!

Tried to connect to a “test” folder. Sharing activated, again everything as instructed.

I put it into my iTunes folder (the same where also my iTunes Music folder is).
=> same thing as before, it looked like it is adding, no error message but it didn’t work.

Then I put the test folder in the first folder level of my account. => same, didn’t work.
Deactivated my firewall. => same, didn’t work.

Any other ideas? :woozy_face:

adding a screen shot…

Hmmmmm…I don’t know what else there is to try. I’ll let you know if I think of anything though. Sorry

Hi @Christian_Kroos ,

Can you please try to connect to the iTunes or test/iTunes folder again, note the time + date of the error and then use these instructions to upload a set of logs here for review?


P.S. Thanks for the great suggestions while I got to the thread again @AnimalOnDrums !

1 Like

Hi @noris ,

I did as instructed.
Zipped Logs file uploaded.

Before I started at 21.51h another try to add a network share.
As before, the wobbling roon logo created the impression that it is adding a network share…
No error message.
After 5 minutes at 21.56h I clicked somewhere in the main roon window and the wobbling roon logo disappeared, but no network share was added.

Just to be clear: I took the logs file from my MacBook. The iTunes Music folder is located on my old iMac.

Hope the review of the log files uncovers the root cause of the problem.

@AnimalOnDrums thank you so much for all your help and suggestions, really great!

1 Like

no problem! I really hope you get this figured out!

Hi @Christian_Kroos ,

Thanks for sending those logs over! Looking over the log, it appears that:

//IMAC.local/Test1 is returning a mount error(112): Host is down

//IMAC.local/iTunes Music is returning a mount error: could not resolve address for IMAC.local: Unknown error

For some reason, your ROCK can’t find a path to your iMac… strange. I have a suggestion here, let’s try IP address connection instead of hostname. Can you please check the IP of your iMac and try to use that instead of iMac.local?

If the IP connection works, I suggest creating an Address Reservation for your iMac in your router settings to ensure the IP does not change. For some reason, lots of routers have trouble with Hostname connection, and IP connection is more reliable. Let me know if that helps!

Thanks, @noris ! Done.
Tried it with the IP address of my iMac. I also fixed the iMac IP address in my router.
=> same outcome: it seems to add the network share but it does not happen.
Do you have any other idea?
By the way: Initially I used the IP address instead of the hostname until AnimalOnDrums suggested to try it with the hostname…
Best, Christian

What OS is the iMac running?

Are you able to connect to your iTunes shared folder from your MacBook?

Can you go to Network in System Preferences and take a screenshot?

In your first set of screen shots, in the last one there is a Network folder above SSHD. Can you open that and see if it sees your Rock?
If not, can you go to the Go menu in finder and select “Connect to server.” Then enter smb://rock And see if you can connect to your Rock. If that does not work try smb://rock.local or use the IP address of your Rock, which can be found in Roon settings.


No, I indeed cannot access the iMac from the MBP. Not sure why, I think I’ve giving all access rights required. Even deactivated the firewall.

It just says that a error occurred, no details. It doesn’t even ask if I want to register or access as a Guest.

I could access the Rock from the iMac, though. I did that two or three weeks ago in order to transfer music to the Rock internal storage, to get going as long as the shared folder issue isn’t solved. Which I did.

The iMac is actually a 24 inch with 3,06 GHz Intel Core 2 Duo and 6GB RAM from 2008 running on El Capitan…

I hope this doesn’t exclude it from serving as the my music server!?