Unable to Access my Roon Library since version 2.0 installed

Roon Core Machine

I am based in the UK and I store my music files on an Innuos Statement server and I read the files on my Apple MacBook Pro 15" 16Mb RAM 512GB storage 2.3ghz Intel Core i9. The wifi is ethernet wired using EE router and I have an English Electric switch to split the cable runs in my music room. I use high quality ethernet cables throughout. I do not know how many tracks in my library but there are around 1000 ads and 550 LPs (the latter took me over a year to record). I do not know how to screenshot so sorry for not being able to help in this but I could take photos and email them if that would help.

I was able to access my music library up until I installed version 2.0 of Roon but as soon as version 2.0 was installed I got the following messages on my Apple laptop:
"The Innuos Statement has a 2.0 (build 1128) production and advises that I have the latest version installed.
The Mac computer has a 1.8 (build 880) stable and advises that there was an error checking for an update.
It asks me to retry but this never succeeds and keeps asking me to retry.
I have checked the MAC and Innuos software for updates and have installed all the updates available but it has no affect on the above messages which remain stubbornly there.
With my limited knowledge of computers I have tried everything I can including removing power cords and stitching everything off and on again but to no avail.
Indeed this fault happened back in September and it is only with the very patient help of Rebeka in your Customer Success Team that I have at last figured out how to contact you on what is a very confusing web site to a 72 year old.

Please can you help me get back my access to my music files on the Inmnuos as I have lost around 6 or 7 weeks of access to them.

Kind regards
Graham Cox (based in Kent, England)

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Is anyone at @support @connor @benjamin able to help @Graham_Cox out with this issue he’s experienced for many weeks?

@Graham_Cox, have you tried downloading a fresh copy of Roon for the Mac from this link:

You will want to download the MacOS Roon file, not the Roon Server file. Reinstalling on your Mac should update you to Roon 2.0 Build 1148 which is the current version.

I am not sure how to update the Innuos Statement to be on the same version, you may need to contact Innous directly. They should be able to help you update to Roon 2.0 Build 1148 also.

1 Like

Hi Robert,
Thank you for your response but I have some questions:

  • Are the instructions for installing Roon again straightforward?

  • Will my subscription continue to apply to the new version

  • Will I have to remove my existing version of Roon and if so is this easy?

  • When I first used Roon a couple of years ago, a small but significant number of my albums had either no data of wrong data/covers and I was given instructions on how to add or amend data as appropriate. This was a painstaking task and I am worried that installing a completely new version of Roon one my Mac laptop would mean I would have to go through all the incorrect albums again. Will this be the case?

  • You mention the Innuos but as far as I can tell, this installed version 2.0 of Roon correctly - it was the Mac laptop that is still on the 1.8 version.

  • Am I correct in thinking that the Innuos has Roon Core installed and the Mac laptop has Roon Remote installed as this has always confused me?

  • It seems that the Innuos correctly installed the update but the Mac was left high and dry on the 1.8 version which is why there is this incompatibility. How can this happen?

If you can advise on the above then hopefully I will then be able to give the install a go to see if I can get Roon back up and running again.


Sorry for the delayed reply Graham. For the questions I can answer:

  1. Yes
  2. Yes
  3. No to having to selete Roon first from your MacBook Pro
  4. If you first make a backup from within Roon using this link:
    and then restore from this backup if Roon cannot open normally, then your changes to your metadata are saved.
  5. I cannot answer this one as I don’t have an Innuos server or file storage so don’t know how it can be configured either as a Roon Core server or as a Roon storage location
  6. See 5 above
  7. See 5 above

Hey @Graham_Cox,

It’s great to see you on the Roon Community! You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

Following up on this thread, I wanted to check in to see if you were able to get things sorted out? @Robert_F is pointing you in the right direction with creating a fresh backup, and then downloading the MacOS Roon file from the link they’ve included.

I’ll be monitoring this thread for your reply :+1:

1 Like

Hello Benjamin,
I am afraid that I am really struggling. I went onto the page that Robert recommended for backup before I try to install version 2 again. However, it explains how to backup but when I click on the Backup icon at the side of the page nothing happens. I then tried going into Roon by signing in but I then could not see any mention of “Backup” so with my useless ability with your site, I have again got nowhere. This is so frustrating having been without Roon for nearly 2 months now. Clear step by step guidance would be much appreciated.

I think you’re getting confused - do you mean this backup link (outlined in red)?

That’s a navigation link for the Roon Knowledge Base - and it’s actually the link to the page that you are on: the article explaining what Backup is. So nothing will happen when you click the link - you’re already on the Backup page.

What @benjamin was meaning was to restore a backup that has been made in Roon by going to Settings > Backup in the Roon application.

A question for you: have you ever set up a scheduled backup in Roon?

1 Like

Hi Geoff,
Yes that was the button that did not work. No I have never backed up Roon (scheduled or otherwise) as I had no idea how to. Where do I find “Settings” to enable me to get to Backup? Apologies for being such a muppet but as stated, I find this site so confusing. When I had a problem last year everything was cleared up with a couple of emails but on this community site everyone seems to be experts and I am beginning to think Roon is not for me.

Settings is in the main Navigation menu on the left of the Roon screen. Once you click on that, then you see the menu options for Settings - clicking on the Backup option will open the Backup functions screen.

Take your time and explore Roon - the Help Portal on the Roon website has lots of information, and if you get stuck, just come back to the Community forum and ask your questions. Don’t be afraid - we all had to learn. I’m older than you and I still discover new things…

1 Like

Hi Geoff,
Thank you very much for trying to help but there is a fundamental problem as I cannot access Roon because when I click on the usual icon to bring up the Roon screen, it comes up with the sane screen which states “Roon is trying to connect but your Core and Remote are running different versions (more info):
Statement (This is my Innuos Statement) 2.0 (Build 1154) Production - You have the latest version installed.
This Mac (My Apple Mac laptop) 1.8 (Build 880) Stable Retry Now - There was an error checking for an update”
With this screen, I cannot find anything on Roon so finding “Setting” and hence Backup will be impossible.
Am I correct?

So, what that is telling us is that your Roon Core (on Innuos) is version 2.0, but that the Roon client on your Mac is at a very old build of the previous version of Roon (1.8).

It’s so old a build that the automatic updating has failed, and we need to get version 2.0 installed on your Mac. Then the Roon client will get talking to your Roon Core, and you will see the Roon application screen on your Mac.

However, first we need to check that your Mac will be able to run version 2.0

Do you know what version of MacOS you have? Roon version 2.0 requires macOS 10.15 (Catalina) or later.

If you can answer that, then we can move to the next step. Thanks.

I have updated the Mac twice from Catalina - I only updated it a week ago to the latest version which I think begins with V. Sorry not sure how to check which version exactly.

OK, sounds as though you are good to go with version 2.0.

Then go to this page on the Roon website (click the “Downloads - Roon Labs” link to do so) and download and install Roon for MacOS

Once installed and you start up Roon, you should see a screen asking you to choose your Roon Core. Make sure that the Roon Core on your Innuous is running, and you should see that on the screen. Connect to it and you should be back up and running Roon.

Tried that but when I tried to install Roon Remotes (as I assume I should not try Roon Core), it just says the app is only available from the Apple Store. I am clearly doing something wrong again.

Also will I lose all the saved Metadata that I had to change manually for numerous albums by doing this - assuming I eventually succeed?

No - you’re wanting to install Roon on your Mac - which uses MacOS (the operating system for Macs) - Roon Remote is for iPhones and iPads, which use iOS (the operating system for iPhones and iPads).

Your assumption is wrong - you need Roon for MacOS. This is the all-in-one version of Roon that has the Roon user interface, the Core, and the Audio output components. You install this on your Mac, and connect to the Core on your Innuos - so you don’t use the Core that’s in the Roon running on your Mac.

Click the button that says Download for MacOS using the web browser on your Mac laptop:

Hi Geoff,
OK I’ve clicked “Download for MacOS” and it moves too another page which gives options of Roon Remote and Roon ARC and then more downloads of “Roon Apps”, “Roon Core” and “Audio Device”. Then it has a table with tick boxes in columns against each type of app. There does not seem to be a place to actually download the Roon for MacOS app.
I should say that my hifi dealer originally installed Roon for me hence my lack of knowledge of how to deal with this issue.

Click on the blue type:

Are you using Safari as your browser @Graham_Cox ?

Your last comment really puzzled me, so I tried it myself on my Mac using Safari. When clicking the blue download button it offered me this pop-up:

I clicked “Allow”, and the download immediately started. It did not take me to another page. Please confirm you are using Safari on your Mac to get to that page?

/Yes using Safari and definitely no pop up screen like you show aooears. Don’t understand this.