Unable to access Tidal via Roon (suggested fixes from Knowledge Base not working)

Hi there @support. I am unable to access Tidal via Roon. Get network connection error message when try to log on via Roon services. Tidal subscription current and able to access Tidal via web browser. Alas, I am unsophisticated user and unsure what fix I am missing. Cannot seem to find a Tidal file in Roon registry folder other than a sync file that have deleted but problem remains. Have also disconnected from Core, rebooted, etc. to no avail. Thanks.

Hi @Greg_Harding,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

In the past we have seen Google DNS help with similar reports. Can you try using Google DNS and let us know if you notice a change?

Hi Dylan.

In terms of my set-up:

• I am running Roon 1.6 (Build 390)
• I am primarily running on two PC’s - a desktop and a laptop. Both are running windows 10. Both are with i7. With 16GB of installed memory on the desktop.
• My music is stored on a Nucleus+. It is connected to home network by an internet LAN cable.
• My collection size is about 12,000 tracks
• My router is an Actiotec xDSL with recently updated Firmware. My provider is Telus.
• My network has a wide range of wired and wireless devices.
• Also run Roon from a Pixel 2L and a Mac Ipad. Right now my Nucleus+ is not coming up as Roon Core choice when I launch Roon from my Pixel. And I tried logging into Tidal via my Roon App om the Ipad and had the same problem “Network error: Please check your connection”.

Tidal was linked to Roon and was working fine prior to the Roon 1.6 update.

I looked at but am reluctant to try using Google DNS – I don’t meet the caution on the website: : “Caution: We recommend that only users who are proficient with configuring operating system settings make these changes” and I am also concerned (perhaps mistakenly?) about having to then make changes across all my networked devices that are currently running fine under my current network set-up. Prepared, however, to give it a try if need be…


That warning is the same as Caution this hot drink is hot. Changing DNS won’t affect anything else other than possibly making browsing quicker.

Hi @Greg_Harding,

You can set just your Nucleus to use Google DNS. You can access the Nucleus Web Administration Interface and set a static IP and choose which DNS to use.

Can you confirm what kind of TIDAL subscription you currently have? If you go to your TIDAL account (on the TIDAL website) and then go to subscription settings, can you verify what subscription you have active? What region is your TIDAL account for?

Thanks Dylan.

I have a Tidal HiFi subscription. Region is Canada.

Regrets, but I am going to need more help with setting my Nucleus to use Google DNS. I can navigate to the Nucleus Web Administration Administration Interface, get to the Roon Configure network set-up, and get to selecting the static IP option, but am in the dark as to what to input. I can see from the Google DNS website page you linked me to the different DNS server addresses for IPv4 and IPv6 but assume and have tried putting those addresses into the DNS setting box, but get and error message asking for input in the other 3 boxes (IP, Subnet Mask, and Gateway) and am at sea as to what to input. What static IP should I be choosing/setting? One that was being assigned before? Sorry, but am just out of my depth on this stuff…

I did check my router and see that it has IPv6 enabled and assume I should go that Google DNS Server route.

Hi @Greg_Harding,

Let’s try something else here:

Just to verify, when you navigate to Database > Registry > Core you don’t see the tidal_account file? Can you share a screenshot of everything you do see here?

Can you also try clearing your TIDAL cache?

  1. Stop RoonServer on your Nucleus

  2. Find and open your Roon database

  3. Navigate to /Library/Roon/Cache

  4. Move the contents of the /Cache folder elsewhere, like your desktop

  5. Try restarting Roon and syncing Tidal

Hi Dylan.

First, yes, am not seeing a tidal_account file. Have attached screenshots 3,4, and 5 of what I do see.

Second, alas, am having trouble with the cleaning tidal cache steps. I was able to stop RoonServer. I think I was able to open my Roon database - see screenshot 2, but not able to figure out how to navigate from there to /Library/Roon/Cache - not seeing a library folder come up among the folders that come up…

Hi @Greg_Harding,

Go ahead and clear out Database > Cache here and let me know if that works for you.

Thanks Dylan. That worked. Appreciate your patience in directing me towards a fix.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.