Unable to configure router to connect Roon Arc (Verizon Fios w/ Google Mesh)

Roon Core Machine

Macbook Air (M1, 2020) 8 GB Monterey 12.6
Roon 2.0; Remote iPhone 13 iOS 16.0

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
UPnP is enabled, but it won’t connect. I logged in to my router and tried manual configuration, still no luck. Can anyone assist?

Networking Gear & Setup Details

Verizon WiFi Router Gateway # FIOS-G1100

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I’ll try. Basically, you want to enable and configure Port Forwarding. The port to be forwarded is the ip address of your server. Roon has some specific troubleshooting instructions that will help too.

Also, RESTART your router after you configure it. That made the difference for me.

1 Like

Thank you for the suggestions. Restarting the router was the one thing I hadn’t tried, but unfortunately it’s still not working. I feel like I followed the instructions to the letter. I’m just at a loss.

Additional to port forwarding you can try setting up a static address in your router for your Roon Core device; the current IP address of your Core that you can use is in the Settings → Roon ARC tab. Then restart your router and after that your core.
Hope that helps.

1 Like

Check if the port forwarding is working.

For what is worth, I solved the issue by activating UPnP on the router side. It immediately worked out. Then I had the issue again and discovered that it was because I was momentarily using VPN on my server. So long story short: UPnP activated on the router + NO VPN on the core machine works like a charm.

1 Like

Thank you. The test failed so apparently port forwarding is working, but it still won’t connect.

what are you running roon core on?

Macbook Air (M1, 2020) 8GB

check the firewall, if it’s on switch it off and try again.

It’s been off. Just for the hell of it, I turned it on and still no luck. Turned it back off again, no luck.

Hi @Steve_Ackerman,

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest that UPnP is not properly configured on your router, but it’s also possible troubleshooting has failed so far because you have additional network equipment (like a second router, for instance) in your setup.

Please first try the following steps:

  • Try to toggle UPnP/NATPMP on/off in the web administration interface for the router directly upstream from your Core before restarting. Forgive me if this step is redundant, but we’ll want to confirm that you’ve tried it before proceeding.
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode, if you have a second router.

If you continue to experience difficulties, please respond here and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?


My current router is Verizon Fios CR1900A Gateway 2022 model. The router I listed in my original post crashed and died when I put it in bridge mode. I also have a Google Mesh Wi-Fi System. I live in New Jersey. When I put my core (MacBook Air 2020, M1) on the Verizon network, I get the signal that it’s ready and ARC can securely access my core. Generally ARC would work in my car for 2 or 3 songs before I’d lose my connection to the core (never in the middle of a song, always after the song ended). After the updates on Thursday, there was significant improvement. ARC stayed connected through my 45-minute commute and a good chunk of the morning before I lost connection. Today it regressed, I lost connection after 3 or 4 songs. The messages I get are always the same: “Poor connection - retry,” “Can’t Connect to Core,” “Core Last seen 30 minutes ago,” etc.

Hi @Steve_Ackerman,

The dropouts you’re reporting in your car are the result of ARC having cached a certain number of tracks in advance while you’re still connected to WiFi. Once we’ve finished troubleshooting and configured port forwarding, ARC will be able to sync to the Core using your 4G or 5G connection on the phone, instead of relying on this cached data. This will give you true on-the-go access to your streaming content and library from your Core.

I’m sorry to hear about your original modem/router breaking down on you. In the current system, if I’m summarizing correctly, your setup is:

Core → Google Mesh → Verizon Fios CR1900A → Internet

In this setup, you’ll likely need to set a manual rule on the Verizon Fios router for port forwarding. You will need to know the following:

  1. The static IP address of your Core. This will be listed in Roon → Settings → ARC
  2. The “listening port” Roon wants to use. This will also be in Roon → Settings → ARC

You’ll need to go to the web administration page for the Fios router and navigate to something like Advanced → Security&Firewall → Port Forwarding. There will be an option to “create rules.” You’ll need to create one for TCP, and one for UDP. It should resemble this.

Add this rule to the list and repeat the process for UDP before rebooting your setup.

If port forwarding sends an additional error, I recommend toggling UPnP on and off in both the Google Mesh and the Fios router settings. If you see any new diagnostic errors in Roon → ARC - > Settings, let us know, as we should be able to pin down the issue with the port forwarding rule in place.

Thank you for your patience again, @Steve_Ackerman.

Thanks. I have Virgin Media Hub as modem - Google mesh - iMac. It was turning off the VPN that worked for me


MacBook Air 2020, M1, Monterey 12.6

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Roon Arc is connected to my core. I go for a drive and my iPhone 13 can play music from Roon Arc for about ten minutes before it stops. After that I can’t get it back. It says “poor connection” and gives an option to retry. This has happened multiple times. Today it said “Roon core last seen 1 hour ago,” and then I tried the app again a few minutes later and it said “Roon core last seen 4 days ago.” I don’t know what to do.

You don’t have arc setup properly and the ten minutes play come from the cache on the phone. On a roon remote, not ARC, go to roon, settings, roonARC see what it says.

It shows exactly the same image you posted. Ready: Roon ARC can securely access your Roon core.

I have the same problem with ARC. It will work for a few songs and then times out stating “Poor Connection”. I have no problem when using Amazon Music or Qobuz apps in the car. I was hoping to be able to do away with amazon ARC just dies not work well.

Any thoughts on what it could be? You seemed confident that it wasn’t set up correctly, is that still possible? I would love to get this thing up and running…