Unable to connect to roon core also here

Intel NUC running roon OS, see attached screenshot

no remote Android or Windows will connect anymore.

Rebooted all devices, re started roon server several times, rebooted router, re installed roon OS, no change

Just came back from a week long trip and can not connect remotes to core, but server is running, visible on the network and responsive on the web GUI.

just see, it updated to 931 while I was away. Must be caused by the update

Have you updated the remote devices to the lastest version. And, you can set updates to not be automatic,. Settings About, gear icon by core

Yes updated all devices.

The setting is a good idea! But first I need to connect again

Well, let’s start with Android devices. In the cannot connect screen there is a blue Help link. This brings up a page to enter server IP. Instead of the actual IP enter

Done, no change

It does find the roon OS

I had to remove Roon client from my pc, reboot, then reinstall.

Just doing an uninstall (even though I said nuke the database) didn’t work.

My android client just worked.

Just to go through the basic checklist.

Your phone and desktop are also on 192.168.1.XX subnet.


See if there are any VPN’s running as that can cause issues.
Temporarily turn off the PC firewall and see if can connect.
Turn off IPv6 on the PC and Router and see if that helps

disclaimer, a fellow user here trying to help, not official support.

1 Like

Hi, thanks for stepping in. Tried all that. Results don’t change

Let’s hope support steps in soon

Just figured out the issue. Roon server is restarting about every 20 seconds. @Rugby , do you have any idea? How to call Support in?

@dylan Hi Dylan, you helped me last year, when my server crashed completely on the 227 update. Any idea what’s now needed?

Once a year a total crash is not a good frequency…

Hi Martin Dylan left Roon last year and @support are currently off for the weekend.
I’m not sure that they will be back in work before Tuesday

Hi Everyone,

I have been having a very similar problem (out of the blue) for a week or two now. The web interface shows everything as OK; the apps (OS X, iOS or android) will occasionally show the nucleus/core as ready to connect (green dot), but when I try to connect everything hangs and eventually starts looking for the core again. I have powered off/on, rebooted, reinstalled the OS, and restarted the roon server, restarted the network etc, to no avail. I’ll follow this discussion for a while before putting in a separate support request if needed.


1 Like

I wonder if Roon database corruption could cause these symptoms. There’s a way to move the database folder on Roon OS out of the way and start fresh with an empty database. If that works, you may be able to get in and restore a backup. A failing NVMe boot drive is another possible root cause. Connecting an HDMI display may reveal error messages if so.

Also having a lot of instability & shutdowns on the PC-side, started a couple of days ago. Never used the Android control app before, but downloaded it a few hours ago and it’s working fine, connects with the Roon Nucleus, can find new music on Qobuz, queues and plays tunes. When the PC end crashes, I can’t re-start Roon, or kill the process, only a machine reboot works. Another problem I hadn’t previously experienced is that a day after adding some albums to my library, the new ones had “lost” their cover art. I was able to restore those by manually telling Roon to re-identify each of those albums. I have Roon set up to automatically apply s/w updates, so I assume I have the latest version.

Here is an example of my roon server logs. Per minute running I get 2 of these, as it is starting a new log each time it re-startes the roon server.

04/15 21:14:37 Info: Starting RoonServer v1.8 (build 931) stable on linuxx64
04/15 21:14:37 Trace: [roondns] loaded 29 last-known-good entries
04/15 21:14:37 Trace: Checking if we are already running
04/15 21:14:37 Warn: get lock file path: /tmp/.rnsems0-roon
04/15 21:14:37 Trace: Nope, we are the only one running
04/15 21:14:37 Info: Is 64 bit? True
04/15 21:14:38 Info: Command Line Argument: -watchdogport=43529
04/15 21:14:38 Trace: [realtime] fetching time from NTP server
04/15 21:14:38 Trace: [realtime] Got time from NTP: 04/15/2022 21:14:38 (3859046078043ms)
04/15 21:14:38 Trace: [realtime] Updated clock skew to 00:00:00.0006191 (0.6191ms)
04/15 21:14:38 Trace: [ipaddresses] enumerating addresses
04/15 21:14:38 Trace: [ipaddresses] FOUND lo
04/15 21:14:38 Trace: [ipaddresses] FOUND eth0
04/15 21:14:38 Trace: [ipaddresses] SKIPPED docker0: not up
04/15 21:14:39 Info: [stats] 22091mb Virtual, 710mb Physical, 460mb Managed, 90 Handles, 23 Threads

Hey @Martin_Kogel,

We’re very sorry to hear that connection to your Core from remote devices is not possible… :pensive: .

It sounds like you have a Windows PC and a remote Android devices. If I didn’t miss anything, it looks like you haven’t tried reinstalling Roon on the remote devices. Could you please give that a try? Make sure you restart the device before installing Roon Remote fresh.


It’s 3 different android and 2 windows. But I narrowed it down to the roon server on top of roon os is restarting every 15 seconds…I also included logs from roon server.

Roon os runs without issues.

Get @Martin_Kogel,

Thanks for the follow up and the additional insight. When you say you have included logs, where is that Do you have a link :relieved: ?