Unable to play some tracks that were recently imported [Resolved]

I have my server on a QNAP 471, but I don’t think this problems is related to QNAP at all. My server has been running flawlessly for a long time and this is the first time I’m unable to play something and I think it’s related to them being recorded off a microphone - i.e they are not purchased CD’s. This is happening across all my controllers and audio outputs. I have DSD’s, high def recordings, amongst CD’s that have been playing flawlessly. Bringing up the info on the file in Roon, the decibel level is a huge negative number (like -24601.00db). That seems odd. Looking at a CD it’s usually a positive number so I’m guessing that is a clue. I’m able to play the exact same file in quicktime - i.e I access the same folder and file on the QNAP from my Mac and am able to play it.


What file format are those microphone recording?

Do you have dBpoweramp or similar? If so try re-coding them e.g. FLAC to FLAC.

It is m4A. I do have some conversion software but what should I be looking for? Why isn’t Roon able to play it, or even provide any notification? I think an error message of some kind would be helpful.

Hi Vin,

Looking at in Knowledge Base I don’t think m4A files are supported … but I’m a little confuse as if that’s true I’m not sure why they would be imported, I’d have thought Roon would just skip them.

I’ll leave a tag for @support to confirm or otherwise.

M4A is regular ALAC or AAC, which should play fine. M4P is Apple’s old DRM-protected AAC.

Maybe it is a codec problem on the QNAP? Is this with all M4A files? Do you know if it is AAC or ALAC?

Perhaps you can put one track up for download somewhere so we can check?

Thanks for responding. Unless I’m mistaken, m4A is the same as AAC on that list which is supported through OS dependent codecs according to the link you sent me. Thus far it’s worked for me on my computer, on the PS Audio DAC I have and on the Raspberry pi. So that shouldn’t be an issue. It’s what my entire iTunes library uses which has been imported into Roon successfully.

Thanks - my QNAP has been working flawlessly and it’s only with these files, not all m4A files. My ripped CD’s that were in iTunes previously work fine. I’ll put the track up shortly.

I notice that all the ones that don’t work have the db as negative as in this pic I’m attaching. These are all recorded off a phone or iPad – so obviously not audiophile quality recordings. I do have a few that were recorded using good mics through garage band that work fine. So this has something to do with recording off a mobile iOS Device.

There’s a file here ( bad quality audio but it exhibits this problem ):

[quote=“RBM, post:5, topic:15212”]
M4A is regular ALAC or AAC, which should play fine. M4P is Apple’s old DRM-protected AAC.
[/quote]Many thanks for that info, noted.

1 Like

FWIW: it’s playing fine on my system (RoonServer Linux @ Ubuntu Server w/ avconv):

Nice guitar work BTW :wink:

No weird dB level either:

Let’s also flag our resident Roon on NAS guru @crieke to check whether this is related (or not) to a QNAP install. I’m still thinking codecs – but I can be wrong, of course.

Hmm weird. Thanks for looking into it, and for the compliment :slight_smile:

I worked fine on my Mac Mini OSX Sierra with Roon Server. External HD via USB.

Cheers, Greg

It was seen and played immediately on my system… However, looking at the other pics, on my system it says the orig file in mono.

I can check this not before monday with my qnap server.

Thanks to everyone for taking a look. Chris look forward to hearing your feedback when your are able.

Roon uses codecs found within the OS where roon core is loaded. So, my guess is that your qnap doesnt have a codec for this type of file. Maybe see if there is an audio player app that you can load on the qnap that will add the codec ?

Hi @vin_k
I just came back an tested it already. It works without any issues on the QNAP TVS-471.
But currently I have installed the QTS 4.3 TechPreview to make adjustments for the upcoming QNAP OS. So there is still the chance that this is related to QNAP + QTS 4.2.2.

Thanks for getting back to me Chris. Is the Tech preview available to try? It’s not urgent for me but it’s something I would like to have working. I’m still getting the same broken behavior.

@ncpl – WRT Codec, I wonder what would be since it normally plays the file type otherwise. It’s only these iOS recorded ones.

Currently it has only been sent to package maintainers (afaik), but I could imagine that there will be a open beta as qnap did with QTS 4.2.2.

I will see, if I can revert back to 4.2.2 to test it again as the adjustments to keep RoonServer compatible have already been identified.