Unable to update my RoonOS (Rock - roon core) to Roon 2.0

Roon Core Machine

Prime Mini 5 (NUC)
CPU Intel i7
RAM: 2 x 16 GB Kingston
SSD: Samsung EVO 970 Pro M.2

Networking Gear & Setup Details

Router: Fritz!Box 6660 Cable
Switch: Uptone Audio Etherregen

Connected Audio Devices

Streamer: Musica Pristina connected via LAN

Number of Tracks in Library

Description of Issue

First I followed the update request in the roon app (Mac). And after that both the Core and the app were running Roon 2.0.

On the next day I wanted you use my iPad as the remote, again there was an update request I followed. But after that the core runs on Roon 1.8 and the app on the iPad Roon 2.0.

I followed the link to the help center and followed the procedure for the update for RoonOS core 2.0 several times.

After several attempts of Reinstall of the operating system, I always ended up (a few minutes later) with RoonOS 1.8.

Anything that I should do different? Any hints? Any changes I have to do before I start the Reinstall?

I performed the reinstall of the operating system, following the instruction (copying the “roon_2-0” renamed as “roon” in the branches folder as indicated above), again today (stopped the Roon Server software before). Still have the same situation. The Roon servers software is still Version 1.8.

Any ideas are welcome.

I have encountered the same Roon screw up.

Yes that was more or less the same situation I encountered. I installed the Roon 1.8 legacy app on one of my mobile devices to be able to control my Roon core running the 1.8 legacy to play music… :frowning:

See this reply -


Fixes the problem, but misses some of the point.

After reading your post more thoroughly, I see you’ve tried the ‘branch’ option.

It didn’t work?

Yes I tried the option via the created branches folder, copying the Ron_2-0 file renamed to just roon, into it. It didn’t worked.

Yep, I just tried it after I posted last. Your reply beat my reply. :slightly_smiling_face:

No wonder people get p*issed. The supplied fix to fix a Roon screw up is itself screwed up.

I had hoped that once I installed the Legacy app on my iPad that I could then fix things up, but the app on the iPad says I have the latest version installed.

Pathetic. I take that back. Absolutely pathetic.

In this case, this is not true -


I have a similar issue going from 2.0 > 1.8 Legacy. And, 1.7 > 1.8 Legacy.

No matter how many times I add the roon file to branches and reinstall the system… I even took the drive out, reformatted it, installed 1.7 again, and I still can’t get to 1.8 Legacy.

Has the downgrade to 1.8 Legacy been blocked?


This is what I did several times already. I followed again today twice but still the same situation. The core sticks to Roon 1.8.

At your step 4 I get that displayed:

after connecting

1 Like

Do you happen to have by any chance the older 1.7 USB install?

Despite my issue being different to you. I was able to wipe my ROCK and, install the OS from a usb I made a couple of months ago and, install 1.7. Once it was installed, I opened up Roon Remote 2.0 and got prompted to update which upgraded the ROCK to version 2.0.

I got the same result as you.


It looks like one doesn’t need a pre-V2.0 download. I just checked and, according to the date, it looks like the ROCK download might be V2.0.

I’m very sorry, that didn’t work out. Honestly, I was equally a bit frustrated late last night. I tried to recall as much as I could, but some details were a bit blurry. Many times I’ve failed, and when I rebooted Remote one last time, and found my Core, suddenly it shows “Installing” under the version/build No.

1 Like


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.