Unexpected error loading album. Please try again later. (Unauthorized)

Core Machine (Operating system/System info/Roon build number)

Dedicated Roon Rock server, build 227. Cpu i5, 8gb ram, 128gb ssd.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Telstra smart modem gen2

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

  1. PC with Roon bridge installed(wifi)
  2. Bel Canto streamer(wired to modem)

Description Of Issue
Hello Roon support team,

I have been playing music with Roon from Tidal only(no local storage), everything has been working smoothly, however last night I realized when I tap on recommended albums/tracks(those not saved in my library) on ANY of my Roon remote, a error msg ‘Unexpected error loading album. Please try again later. (Unauthorized)’ show up. Also if I try to search music on my remotes, the results are only from my library.
In other word I can only play those album/music have been previously saved in my library, I’m not able to explore new content.
Not sure how long this problem has been because I have been playing album from my library last couple weeks, i just realized last night. Tried on either audio devices, same problem.
Reboot server didn’t help, reboot modem didn’t help too.
Please let me know if you need more info.


1 Like

Hi @Ben_H

Sorry for the trouble here!

Can you try signing out of TIDAL in Roon and then sign back in? Is there any change after doing so?

Thanks for the response Dylan.
Signing out and in doesn’t make a difference either.

Hi Dylan

I tried reinstalling operating system on the web interface, no luck.
On the same page I tried resetting roon database & settings, this msg came up - Settings and databses could not be reset. Please try again, or contact support. {“status”:“Failure”,“exitcode”:2}

Any suggestion?


3 posts were split to a new topic: Can’t access new TIDAL content

Latest update - clicked ‘restart’ roon server software on web interface page, no difference. Clicked ‘stop’ roon server software, and then reboot, now it’s working normally.
I don’t think this is the solution but it’s working now somehow.

Thanks you anyway Dylan.

Hi Dylan

The problem come back again after 1 night, any advice appreciated.


The “unexpected error” seems like an on and off issue to me.

Hi @Ben_H

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

In the past, we’ve seen that the use of Google DNS can help in situations like this. Can you try giving Google DNS a try and let us know if it helps? You’ll want to set your router to use Google DNS.

If this doesn’t help, please use the directions found here and send us over a set of logs using a shared Dropbox link.


Thanks for the advice Dylan, will figure out if the google dns helps.

Hi @Ben_H

I just wanted to check in and see if Google DNS did help here. Let us know!

Hi Dylan thanks for the following up. It has been working fine most of the time lately even without google dns, so I can’t really tell if it helps, I’ll keep monitoring on it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.