UnexpectedError - ROCK backup to Windows 10 Pro Share [Resolved - IRPStackSize parameter settings]

I have a mirrored USB drive connected to a PC running Windows 10 Pro. I created a share to the RoonBackups folder on the drive. I also clicked off the requires password setting under network sharing in control panel and rebooted the Windows machine.

I’ve also tried smb://… no luck
tried un/password … no luck
tried un/password/workgroup … no luck

I can connect from my Windows 7 workstation using the path. I can’t get the ROCK to connect to the share and needs some suggestions. I did get it to work with DropBox but I don’t want to upgrade and add another monthly fee. I’ve attached the screen.

I think this is the same error as I reported here:

Yes, but it looks like your able to at least establish a connection. I clicked on the “Turn on sharing so anyone with network access can read and write files in the Public folders” which I noticed was off and still no connectivity.

I’ll keep an eye on your post and see if anyone can suggest a fix.

You’re sure ROCK and the Windows machine are on the same subnet right? Are you able to ping ROCK from the Windows machine? If you install Roon or Roon Bridge on the Windows machine, is it able to connect to ROCK?

I just tried the exact same settings as you have in your screenshot, and ROCK was able to mount a folder on my Windows 10 machine without issue.

Since the Windows 7 machine is working ok, I would focus on the connection between the NUC and the Windows box – something seems off there.

Installed the roon control on Win10. Can ping ROCK and can hit the share from Win10. Can’t hit the share from the Add Network Share dialog. They are on the same network connected directly to the same switch. Rock is and Win10 is

Hi @Gary_Thomas ----- Thank you for the follow up and the feedback, both are very appreciated!

Moving forward, we believe that this behavior is occurring due to the samba protocol which handles connections between Windows and Linux. We had another user correct this behavior by adjusting the IRPStackSize parameter settings.



The IPRStackSize link doesn’t appear to be working. Can you edit your post or reply with a corrected link. Thanks for your help.

Hi @Gary_Thomas ---- Sorry about that :innocent: Should be good to go, now.

Let me know how it goes!

Worked like a charm! Thanks a bunch! Doing a long needed backup as I write this. Also, the directions assume you know what your doing. For those that stumble on this thread, do the following:

On Win10 machine:

  1. locate the ‘Type here to search’ box and type regedit and press return.
  2. Navigate to the path specified in Eric’s link above and add the entry just as described. I started with 30 (decimal) dword as it was the successful setting on the thread.

Cheers from sunny Philadelphia PA.

1 Like

Awesome, glad to hear @Gary_Thomas!

Happy listening!