Update to 1.7 now Roon reports OpenGL 3.0 fatal error

Hello, Roon worked perfectly on my laptop acer travelmate 8372 before release 1.7.
I understood that now roon apply an open gl compatibility check.
As a result Roon now doesn’t work anymore, I installed latest video driver available, no result.
Do you mean I have to buy a new laptop when mine is working properly for me and Roon before?
Sorry this is very disappointing in my opinion, I hope you go back on your decision.


Hello @Guido_Serrao,

Welcome to the forum. When you say that Roon doesn’t work anymore, what exactly are you seeing? Does the App start and crash or does it not start at all? Do you see any error messages displayed? If you see any error messages, can you share a screenshot?

OpenGL 3.0 was always a requirement as @Speed_Racer pointed out, and until now it was possible to run Roon before on unsupported versions of OpenGL, but OpenGL 3.0 is now required for Roon 1.7 and above.

I’m reach out to our technical team to see if anything can be done here, but can you let me know the exact model/manufacturer of your GPU? You can find this information in Device Manager under Display Adapters.

Thanks for the reply, here the screenshot.
My gpu is intel hd graphics for core i3/i5/i7, don’t know if support open gl 3.0, but the fact is that before upgrading roon worked perfectly. So ther’s no reason to spend money to change notebook.

According to my quick Google search that laptop is approaching 10 years old. Treat yourself to a new one! :sunglasses:

That screenshot is telling you that your graphics driver is only supporting OpenGL up to version 2.1.0. Roon version 1.7 has started using features of OpenGL that are only present in OpenGL version 3.0 and above.

It happened the same to me. I have some older HP Pad that I’ve used for Roon Remote. I have many remotes for my Ruun setup, one in the kitchen two in the living room and one in the bedroom. For this purpose I often use older hardware, it is unnecessary to buy new hardware just to use for remote functionality. And now after uppgrade to 1.7 I cant use any of them. :frowning:

You could try and see if there are more recent drivers available that support OpenGL 3.0. I’ve got an old ThinkPad 10, that is using a driver dating from July 2016, but it is still able to support OpenGL 4.0.

I have already upgraded all possible drivers, but there are no drivers with Open GL 3.0 support for these HP Pads. :frowning:

welcome to the club…
I purchased a new laptop to solve the problem.

Hi @Guido_Serrao,

Thanks for sharing that screenshot. Yes, it does appear that the OpenGL version is quite out of date. There are two options to proceed here:

  1. You upgrade the hardware to matche our OpenGL requirements

  2. You use RoonServer which is similar to Roon but has no User Interface and control Roon from another PC with OpenGL 3+ or a Roon Remote (iOS/Android).
    You can download RoonServer from our downloads page and this does not require OpenGL because it has no interface, but as I mentioned Roon will need to be controlled via another device.

Thanks for your kind reply, for now I will use roon server, later on I will update hardware.

1 Like

Same problem as Guido, as an interim solution I have downloaded Roon Server, but there is a requirement in settings to Accept Remote Connection.
Unless I am missing something here, how do you do this when you cannot open the main Roon installation…due to Open GL 3.0 fatal error?

Hi @Michael_Gordon,

Does RoonServer appear on your “Select the Core” screen at all? If you try to connect to it, does anything happen?

Thanks for the reply, problem now sorted.
Followed instructions on KB for ‘moving library over to Roon Server and running Headless’, also did a fresh install of the Roon app.
Should have read this document earlier!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.