Upsampling on SOtM SMS-200

have been unable to upsample past dsd 128.

That is a function of the USB interface which is something SOTM need to look at. If the SOTM can work at the full capability of that DAC it will report that back to Roon which then should present the higher options to you.

it says the sotm is capable and set to dsd 256 and the dac is as well but roon is not giving me the option to go past dsd 128. any ideas?

Make sure the Mac can do DSD256 directly connected to your Core, if possible.
Most DAC’s max out at PCM384 and DSD128 using default USB Audio 2.0 compliance, to go beyond, drivers are needed for the USB Receiver. (Either Prebuilt into a linux os, or installed separately in Windows)

the dac i have does do dsd 256. how do i check and make sure i have the drivers you speak of? my roon and sotm are both up to date. i was kind of thinking maybe it was roon setting. maybe i should ask @support?

Hi @late_nighter23,

A few questions:

  1. What Operating System is your Core?
  2. Could you share a screenshot of your Device Setup for this zone?
  3. Could you share a screenshot of your SOtM Web UI with DSD Output type?

I used to have an SMS-200. There was another setting that was causing problems like yours.

I can’t remember what it was.
My memory is good, but it’s short. :slightly_smiling_face:

Can you screen print the other SMS-200 options from the Eunhasu app? It might help me remember.

Edit: Never mind, I remembered. There were some problems (not sure if they’re relevant in this case) unless one specified ‘Fixed Volume’ in the Eunhasu app.

If that doesn’t help there is a nice lady, May Park, at SoTM support who will work with you.

I don’t know if this is valid when you use a SMS-200 in between, but have you tried to follow MacIntosh’s instructions for DSD256 via USB
Tech Tips: Preferred Computer Settings to Play DSD & DXD over McIntosh USB Input


Screen Shot 2020-04-27 at 3.26.49 PM

this seems to apply to j river which i am not using nor am i using a pc. would this same info apply to roon / mac computer?

i changed the sotm setting from fixed volume to device as you suggested with no luck.

to be clear my goal is to upsample to 256 using the roon dsp but roon is not letting me go beyond 128

Hi Late!

What is the OS of your ROON Core as that can make a difference when trying to do native DSD.

First comment:

DSD Mode must be native to reach the full 256, in DOP mode it will always be 1 resolution lower to allow for the PCM encapsulation.

Most DACs use drivers on Windows based PCs to do native DSD. Mac OS does not do it. And Linux is a very confusing mixed bag. The DAC needs to be able to support Linux and the Linux kernel of the device being used has to be updated for that DAC or DAC’s USB interface.

I would follow slim’s advice and give SOtM or McIntosh a call to verify that those devices can indeed do native DSD 256 between them.

Screen Shot 2020-04-27 at 3.26.49 PM

Mcintosh does say it can do dsd 256

Did you try and change that setting I pointed towards in the screen cut?

@rubgy changing to native eliminates any dsp /dsd upsampling and has me maxed out (on roon) at 384khz.

Did you also see if you could set the DSD Playback in Roon under the Device Settings to Native DSD?

When the SOtM is set to Native, can you set the SOtM under Roon/Audio Device Settings to Native as well? If not, what does Roon say your options are?

i don’t see where i can set anything to native dsd in roon can you please advise where specifically i can find that specific thing? i have been looking to no avail. when the sotm is set to native i am not able to acheive dsd in roon at all. if sotm is set to native my roon options for upsampling are reduced to 384 khz max.