USB audio zone disappears but I2S audio zone remains from Wyred4sound music server

Core Machine (Operating system/System info/Roon build number)

Wyred 4 Sound MS1 “software version 2.7”/Linux/Roon 1.7 (build 667)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear Orbi RBR50 router connected by ethernet to music server (that contains Roon core)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB output from Wyred4sound Music Server (MS1) running the core going to W4S DAC-2v2SE 10th Anniversary. There is a parallel I2S output from the Wyred4Sound MS1 that is also connected to an I2S input to the DAC and that zone persists.

Description Of Issue

USB zone suddenly dropped from list of usable zones in Roon. I was able to fix this with uninstall and re-install of Roon on the MS1 and a restore of my Roon database. This has happened to me again after perhaps 4 hours of listening. The music server also has an I2S zone that continues to work fine. I have also contacted Wyred4sound with this question. It appears that the DAC can see the USB output (it shows sample rate) from the music server, but Roon does not see the USB connection at all. Please help?

This is my first post to the support area. If there is more information that you need (probably the case), please let me know. Thank you, in advance, for your help.

Thanks for reaching out, @Richard_Girton!

Are other audio devices missing during this time, or is it only the W4S DAC that you’re unable to see?

Thank you @Dylan. Yes, as you can see, there are several other outputs both directly connected to the core and connected via the network.

Hello @Richard_Girton, have you reinstalled your drivers for this device since the issue started? Also, has this always been an issue for this device?

Lastly, next time this issue occurs, could you please reply here with a timestamp so I can enable diagnostics for your account? Thanks!

Hello @nuwriy. The USB zone is still missing now. I am working with the music server vendor on updating the Linux and driver software but found previously that deleting and reinstalling Roon, and restoring the Roon database eventually allowed the USB zone to reappear. I’ll post back after server software is updated.

Is it possible to share Roon logs of its current status? Is that helpful?

Thank you.

A discussion with server manufacturer suggested software update and attempt to disconnect and reconnect USB cable. A large software update to the server did not resolve the issue. Unplugging and replugging the USB and I2S cables did not seem to make a difference. Of course server and dac were both powered down and reported up afterwards to no avail. Now both the USB and I2S zones from the server are absent. I’ll try deleting and reinstalling Roon next…

Hello @Richard_Girton, just to narrow things down, have you tried using a different USB port or cable, or using another device in this USB port to make sure there isn’t an issue?

Hi @nuwriy! Thank you for trying to help me.

I’m not sure I understand what is happening, but after updating all software on the server, there were still no zones available from the server. The USB and I2S zones are what were missing. (Screenshot below shows what it should look like.)

Because it had worked previously, I deleted Roon from the server. I then rebooted the server and reinstalled Roon. I then went into settings for Roon and unchecked the “Enable local playback in Roon server”. Making that change will change settings and restart Roon server. I then went back in and checked the setting to re-enable “Enable local playback in Roon server”. A screenshot of this setting is below. With that change the USB and I2S zones returned. After restoring my Roon database from backup, I was back in business.

Switching USB ports didn’t restore the zones. I can plug in a USB hard drive and see the drive with the server, so I don’t think it is a hardware issue. Also changing USB cables didn’t make a difference.

Does any of this extra information help? Although the problem is now fixed, I would still like to better understand why this has happened to me a few times now. The fix seems a bit extreme. If I were to speculate, I wonder about the possibility of a corrupted preference file causing Roon to “forget” about the music server’s ability to send its output “to itself” by means of the “Enable local playback in Roon server” setting?

Any additional thoughts?

Thanks, Richard

Hello @Richard_Girton, I spoke with our team about the potential resolutions to this issue and we would recommend that if this issue occurs again, the best action would be for you to do the following:

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings -> Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

On that note, if you’re able to give us reproduction steps for how you get into this state, our QA team would be happy to take a look!

1 Like

Thank you for the suggestion. I will definitely try that the next time this happens. I suspect that my uninstall and reinstall is a more “brute force” way to accomplish the same thing? Again, thanks.

Hello @Richard_Girton, yup! The part I outlined earlier is accomplishing the same thing.

Three days ago lost my USB zone again but switched to I2S and that worked for 3 days, but then the I2S zone disappeared today as well. I was just listening to an album streaming from Qobuz and reading; all of a sudden no sound. My music server has the ability to output directly to my DAC via USB or I2S. There is a preference that is required to be active to have that functionality that is labeled, “enable local playback”. If this not activated, then the music server only looks to the LAN for Roon endpoints. Roon does not recognize my DAC as an endpoint.

I was able to restore both zones without an uninstall and reinstall of Roon for a moment (but now the USB Zone is gone again) as follows (note that some of this fix is very specific to my hardware, but I suspect the solution can be extrapolated to other configurations as well):

  1. Ensure current Roon database is backed up.
  2. Shut down Roon server.
  3. Clear Roon Server cache.
  4. Uncheck “enable local playback” button.
  5. Reboot music server.
  6. Shut down Roon Server.
  7. Check “enable local playback” button.
  8. Reboot music server.

I need to do more troubleshooting to figure out why the USB zone seems to be so flaky.

In an effort to follow your instructions, @nuwriy, I was able to figure out how to expose the Roon database on the server, but I am unable to find a folder called RAATserver.

I was able to locate and briefly browse the log files and would like to share the most recent one for your review… I tried to upload as attachment, but am not allowed to upload a txt file, only images, it seems.

Thank you in advance for any advice you can render.

A search using a Mac of the Roon database for items containing “RAAT” is shown, with the path for the first listed file shown at the bottom of the image. It shows 9 files, but no folder. Are these the files that should be removed?

Although it was flaky at the start, it seems that the USB zone is back and is working well now for the last two days. I have saved some log files that might be helpful in diagnosing the problem and would like to share them if that might help to better understand why these zones seem to drop and reappear. Thanks.

Hello @Richard_Girton, I’m glad things are working better! In case the issue returns, can you post those files in a dropbox link here? Thanks!

Hi @nuwriy, well, on New Year’s Eve it happened again. I again lost the USB zone, but this time was able to capture the log file. I would like to share it with you, but don’t see the Dropbox link you reference above? Please help?

Thank you.


Hello @Richard_Girton, please use the directions found here and send us over a set of logs using a shared Dropbox link.

Hi @nuwriy. Here is the dropbox link for my log files zipped archive.

Hello @Richard_Girton, and thanks for sending those over! I have passed this information over to our QA team for review and will return with their feedback.