USB port not recognized in Vivaldi or Roon

The Netgear R7000 is functionally similar to your Apple router and doesn’t include a modem. I’m not sure which model you’re looking at, but this is the one I’m talking about:

I’m recommending this specific model for a reason. Other Netgear products are not as appropriate in this application and I’ve had numerous issues with some of them.

1 Like

Understood.

Hmmm… although I don’t have a Nucleus+ connected via USB, I typically have a linux-based Roon endpoint connected and it’s used in long playback sessions without an issue.

You’re running the right versions so I’ll have you try one more thing on the Vivaldi. Beyond that I’d say that something is goofy in how the Nucleus+ is communicating via USB.

Try resetting the USB interface on the Vivadi DAC:

  1. Go into the setup menu and select Unit Settings
  2. Scroll over to the USB class (should be in the center of the first screen).
  3. Press the menu button to change it to class 1.
  4. Once that’s done repeat the process and switch it back to class 2.

This forces a reload of the firmware onto the USB receiver.

If this doesn’t work then there’s something that @dylan can try on the RoonServer side which might solve the problem. If that’s the case then I’ll PM him with the details.

Will try and report back. Thanks again.

Unfortunately, Andrew this suggestion didn’t solve the problem. The minute the music stopped playing the USB connection went into Mute and no input both in red. The Roon application started scrolling widely from random song to random song uncontrollably. The Nucleus Plus has been terribly unstable from the beginning.I could understand why the Apple extreme is responsible for the poor network connectivity but not the screwy USB problems. Please forward on to Dylan.If you can tell me how to send a video from my iphone, I can document the wild scrolling on the Roon application.

I don’t have dCS gear anymore, but I had a ‘rapid scrolling through songs’ on a few albums after pressing Play yesterday. That was with my laptop connected with USB to my DAC.

Once I I turned off my DAC, restarted Roon, then turned the DAC on again it worked fine. Different situation, but some similar behaviour from Roon.

Thank you Gregory. That also works but this situation seems to be chronic.

I sent a note to @dylan with an idea worth trying from the Roon side. He should be back in touch with you.

For whatever it’s worth: My setup has an Airport Extreme as the firewall/router to the internet, followed by a Netgear GS116 switch. My setup is connected to the switch as are all other components. I don’t have issues with this setup.

Thanks Miguel. I too have a similar setup with a Cisco top of the line switch. I had no problems running the Core from my HP desktop. Everything started to go downhill when I switched to the Nucleus Plus as my Roon Core.
Lack of connectivity and now the USB issue, I am convinced that this is a hardware and or or software problem with the Nucleus Plus but I will be switching to he Netgear Router suggested by Andrew and will report back to the Roon community. Thanks again for your input,
Best
Marty

Which Cisco switch do you have?

Hey @Martin_Edelman,

As mentioned in the other thread, I’m going to keep these two issues separate and we will take a look at each one individually. For the Nucleus network issue, please see the other thread.

For the behavior you’re seeing when playing back to your Vivaldi via USB, I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Thanks,
Dylan

Cisco SG 200- 26

Well, that may be part of your problem with losing connectivity. Check the switch configuration and make sure that IGMP snooping and MLD snooping are disabled. In your network configuration with either of those enabled your remotes are going to have a hard time staying connected to your core.

I’d also make sure that EEE/Green Ethernet functions are disabled as well.

Thanks Andrew. However the switch is not the problem since I am running my ethernet cable directly from the Apple Extreme Router to the Nucleus Plus. However, if I choose to utilize the switch in the future these adjustments are very helpful.
Best
Marty

I’d definitely use the Airport Extreme as a firewall/wireless access point, then connected to the switch, and would connect all wired connections to the switch itself. That’s how I have it configured (with a Netgear GS116 switch) and have not had connectivity problems (with a mini running Roon core though).

While I realize that you haven’t had any issues with the Airport, I’ve found it to be the root of many similar issues of intermittent connectivity when multicast is involved (not just with Roon). The Netgear has the added benefit of being a better firewall and having better overall performance (both on Wi-Fi and through the router to the internet). From a networking standards perspective the Apple Wi-Fi products really suck.

As for the switch, yes I would highly recommend a switch plugged into the router with all wired devices connected to the switch, but there’s a key difference between your switch and the Cisco SG200-26. Your switch is unmanaged which means, among other things, it treats multicast traffic as broadcast traffic (multicast packets are always delivered to all ports). The SG200 series switches are managed and in the case of multicast they will attempt to do “smart” things with that traffic. Unfortunately, without some additional configuration they will periodically block multicast traffic to the ports that actually need to see it. Since multicast, in the way that Roon uses it, isn’t a flooding concern on a home network the best course of action is to disable the switch intelligence altogether.

The best overall course of action is to avoid using managed switches in a home media environment as they add no value while significantly increasing complexity… yet audiophiles continue to buy them.

1 Like

Andrew
I have just replaced the Cisco Switch with a 24 port TPlink unmanaged switch TL-SG1024D and also replaced my Router with a netgear Nighthawk AC 1900 model R 7000. I will report back on the connectivity and USB issues.
Thanks again.
Best,
Marty

Andrew
The connectivity issue has been solved by retiring my Apple Router and using the Netgear model you suggested. I will report back on the USB issue.
Thanks for your help.
Marty

1 Like

Great news :+1: