USBridge not working as Roon Endpoint

Hi @support and I have just started using Roon. I have gotten my chromecast endpoints working perfectly but i cannot get my newly acquired Allo USBBridge (running DietPi). My roon server is running on a 64-bit Linux machine. (Roon 1.5 339). Roon remote is on a Windows 10 32bit laptop (Roon 1.5 339). Roon Bridge on DietPi is Version 1.0 build 164.

Currently as I have not imported any local music I am just streaming Tidal tracks. I have tried a bunch of Tidal music but for each one, Roon tries to play the track, appears to start playing, and then skips to the next track. My DAC, Arcam rPAC does not indicate any audio output either (LED on it stays red).

Please help me get some sound out of my main stereo system!

PS USBridge is up and running, I can log in remotely and see web GUI.


Thanks for reaching out, @Alastair_Roberts!

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Have you tried rebooting your Core machine, networking hardware, and the Allo?

Are you able to play to this device from the same Core machine outside of Roon?


In addition to @dylan’s suggestion, if you’re running a firewall, temporarily disable this to see if this resolves your issue.

1 Like

Laptop using a 5Ghz wifi to connect to router/AP. Router connects to switch A via ethernet cable. Switch A connected to Linux PC Desktop running Roon Core.

Router connects to Switch B via ethernet cable. Switch B connects to Allo USBridge via ethernet cable.

I will reset the Roon Core machine and the Allo. Stay tuned…

No firewall running on the linux desktop currently (Roon Core). Plus I checked, and I can remote into the USBridge GUI from the core machine.

Reboot of core and USBridge changed nothing. I should clarify that the RAAT endpoint seems to be working, I added my DAC as a zone in the Roon GUI. It just cannot play anything.

My DAC has power from the Allo and is plugged into the USB 2.0 port labelled USB Host or something like that.

That something I’ll try next when I get a sec.

Where are the roon core logs? They must show something interesting here…

I tried using my wife’s iPhone to airplay to the DietPi air play endpoint. That didn’t work either :frowning:

My gut feeling here is that the Arcam DAC is not being properly configured by DietPi/USBridge, even though everything looks fine from the RAAT endpoint perspective. I don’t know anything about how to investigate this though.

A screenshot of the device settings in Roon for the endpoint would probably help in the diagnosis?


Hey @Alastair_Roberts,

Thanks for the updates here!

Have you tried connecting this device directly to the Core machine, bypassing the Allo? Is there any change when doing so?


OK let me try connecting the DAC to the Core.

Your core is a Linux machine - there may be a driver issue with Linux here. You could also try connecting it to your Windows Laptop (and you’ll probably have to install a driver from the DAC manufacturer as well).

I notice on my USBridge that my DAC is identified as a USB Audio 2.0 device - yours I see is USB Audio 1.0…

Also, I notice that my endpoint is explicitly identified as an Allo USBridge - yours is shown as an unidentified device…

Yeah its a USB 1.0 DAC. And it works fine connected directly to the Core.

OK, then what happens if you force Roon to identify the endpoint as the Allo USBridge?

Do you mean plugging the DAC back into the USBridge first and then doing what you say?

Yes indeed…

No change, Roon still skips through each track: