Using Roon with Naim Mu-So

Our vacation house setup uses a Room core on a Mac mini to stream music to 2 Naim Mu-Sos (which are Roon endpoints). The Mac mini and the Mu-Sos are on the same network, connected via Ethernet cable. When we left in August the system was working flawlessly. We returned this week for Thanksgiving vacation, and everything needed updating (Mac OS, Roon, Mu-So). I updated everything (I am now using Roon version 1.5 (build 360),), but now I cannot get Roon to play music through the Mu-Sos. Roon “sees” the Mu-Sos, and appears to be successfully streaming music to them, but no music comes out.

Here is what I have done so far to fix/understand:

  1. Hard re-booted both the Mac mini and the Mu-Sos. Did not help.
  2. Tested to see that Roon can play music. It can. It can play music out of the Mac mini.
  3. Tested to see if the Mu-Sos work and are connected to the network. They do and they are. They can play Internet radio, and I can stream music to them from my iPhone using iTunes.
  4. Reestablished the network connection for the Mu-Sos by un-connecting and then re-connecting the Ethernet cables, and re-establishing the network connection. Did not help.

Any other ideas or suggestions would be greatly appreciated. Thanks!

If the naims updated their software then they moved to airplay 2 which isn’t currently supported by roon.
Search the forum for mu-so.

Thanks. That helped me find a work around. So I guess the real fix is for Roon to complete an update than supports Airplay 2.

I think they are trying to do an airplay 1 backward fix or such like.

Hello @Peter_Zorn,

Thanks for contacting support regarding this issue. As mentioned by @ged_hickman1, we are currently working towards a fix for the Niam Mu-so and a few other Airplay2 devices but the fix is still in the testing stages at this time, and I am unable to provide a timeline for it’s release. You can read a statement about the fix here:
(Roon not recognising Naim Muso after firmware update)


Hello @Peter_Zorn/@ged_hickman1,

We have just released Roon 1.5 (Build 363) which addresses the Airplay issue with Naim Mu-so and a few other Airplay2 devices. I would highly suggest anyone currently unable to use their Naim DAC properly to update to the latest version of Roon and let us know how things are looking after performing the update.

Release notes can be found here:



Thanks Roon team!!! Just installed build 363 and both my Naim Mu-Sos now work flawlessly again. Greatly appreciate the quick update.

1 Like

updating now. thanks for the details changelog and clear communication. looking forward to full airplay2 support. do we have a date? do we know if this will address letting Roon core be the master source for multiple mu-so devices in multi room such as I can do with the native Naim app?

Oh. looks like it works right now! I can link my 3 Mu-So’s. Thanks! now the only killer feature i need is remote native access to my roon core from my apple devices. :slight_smile:

Hi, after installing 363 my Naim Muso shows up again in the lis of devices but when trying to enable it asks me to enter a password, see picture:

I never had a password for the Muso - where can I find it? Thanks a lot in advance, Christoph

Hello @didnauri,

Did you by any chance set a password for the Mu-So in the Mu-so’s WebUI? I was looking at the Mu-So User Guide and I noticed that there is a field for setting the Airplay password via the WebUI:


Can you please double check this field on your end and possibly set a new Airplay password to use for your Mu-so device?


Hi, I managed to set up a password but not through the WebUI (I failed starting the Muse own wireless mode) - my iPad offered to set up an Airplay-Speaker in the WLAN setting area and there I was able to enter a password. Thank you very much!

Great to hear that @didnauri!