Using Roon with the LMS-to-uPnP project

Hello Henry,

Can you explain the details in order to check " Bridge installs a web server on a random port from 49152 (can be configured), up to 32 ports, so your firewall must allow that."

What i can see on my windows 2019 Firewall, the below parameters are set on the Inbound rule for squeeze2upnp-win

  1. Local Address - Any
  2. Remote Address - Any
  3. Protocol - TCP
  4. Local Port - Any
  5. Remotre port - Any

I can’t. I am a ROCK user, I did some quick reading and saw that passage I pasted. It looked like it might be relevant to your situation.

Hi,

I also try to get lms-to-UPNP to work with roon server but somehow, squeezebox is not detected by roon.
UPNP renderer is a DLNA certified Denon receiver. LMS (incl. lms-to-UPNP plug-in) and the roon server run on a Synology NAS. All devices are in the same network.
LMS can play music to Denon receiver without any problem. config.xml is successfully generated (incl. roon mode). Looks all pretty well. But when trying to connect roon to the “squeezebox” it is not detected. roon does an endless search for it.
What could be wrong here? I use the latest versions of roon, LMS and plug-in (x86_64-static).

Thanks for any help
Matthias

Stupid point, but: Have you enabled „Squeezebox support“ under „Setup“ in Roon?

Hi,

Yes, I did. And I could solve the issue. Actually, LMS was still running :roll_eyes:. After stopping it, the receiver could be detected :+1:t3:.
A bit confusing, but I’m still not sure if LMS must be installed at least, since lms-to-upnp is a plugin. Sounds like the plugin could run even without LMS being installed. Does anyone know?

Now, playing music to upnp is possible. But sometimes, some sort of loud static noise is played instead of the selected track. You may change between track music and noise while moving the track position indicator. Though, the track file is absolutely okay.
I use pass-through mode and no FLAC. Files are AIFF/WAV. Anyone any idea?

Thanks

If you run LMS and Roon on different machines it’s possible to run both. Running on the same computer will result in one being blocked when both are active.
The lms-to-upnp can be run as standalone, but will require a different version of the app than the one that complies as plugin for LMS. So LMS should not be necessary.

OK but which version of LMS to UPNP in that case? It’s still not clear for me as well.

Okay. I don’t need LMS itself. I will check plugin without LMS :+1:t3:

All you need to do is set the server IP address in the GUI in LMS for the plugin to be the roon core IP and you can run both side by side as they will ignore the LMS IP and attach to Roon. Or you can run the plugin on its own.

Hi Ogs,
You said that we should use a different version than the one which complies as plugin but which one?
Thanks

To be honest I do not know. The current version is maybe a combination. Going by @CrystalGipsy’s post above the plugin can be run standalone. It should have executables for all supported OSses in the download. Info here: https://github.com/philippe44/LMS-to-uPnP.

You can download the plugin from the creators GitHub as posted by @ogs but you have to manually edit the config.xml file to get above 48/24 and if you have issues other settings. You can still run LMS and Roon and it makes it easier to setup as I said above in the LMS GUI for the plugin you can enter the IP address for the server you want them to connect to , if you put in your Roon cores IP address they will connect to it and not the locally running LMS. You then can run both side by side and have the flexibility of using its GUI for settings.

I’ve just updated my Mac Mini with OSXI.
I’ve also down loaded the squeeze2upnp from 1st November, but it does not seem to be compatible with the new Mac OS.
Does anyone know when an update to squeeze2upnp is likely?

I am using lms-to-UPNP to play roon with my old naim streamer. Everything is working very well, except roon radio and shuffle play. If I use this, music always is stopping at the end of the song.
Any help?

V.S.

I got this answer from Philippe_44:

„There are various idiosyncrasies with Roon that I don’t keep track of. I know that there are some difficulties with content-length of tracks but I think you’re more likely to have answers on Roon forum as I know a few people are using my bridge with it.“

Any help in this forum?

I’ve had a similar but slightly different issue but the resolution may be the same.

I use a Naim NDS and I was noticing that if I was playing a 24/192 track and the following track is in a different format playback would stop at the end of the 24/192 and it wouldn’t move on to the next track. I noticed this when playing a mixed format playlist from QoBuz.

I’ve discovered that if you add the following setting to the section of your Naim streamer in the config.xml file it overcomes the issue.

<stream_length>-2</stream_length>

I wonder if your issue is similar as Roon Radio will be mixing formats too?

Here’s my section for my Naim NDS

Edit - I’ve noticed that the last 10 seconds of the track then get skipped. This only occurs when sending PCM, if you enable FLAC compression in Roon the problem goes away. I’m keen to avoid FLAC as there is a slight sound quality dip on Naim streamers due to the overhead of the decompression in the streamer, they work best with native WAV/PCM. I’ve posted on the lms-to-upnp forum to see if I can get an answer.

1 Like

@Trickydickie: Thanks for your answer.I now found a different solution. I bought a upnp bridge from small green computers. With this item everything works perfectly.

1 Like

Anyone else have problems with the latest release of the LMS squeeze2upnp software?
Roon had been playing up the last few days; first I updated and rebooted my Audiostore Server. As a result I “lost” a couple rooms; all fine with the Naim app but Roon was not working. I then updated LMS (1.48 released yesterday as opposed to 1.47 that was released on 24th Jan); now all my rooms have been found but no sound comes out of the chosen system, except for my MacMini and Apple TV / Sony TV.

On the Roon screen the music bar does not move, whilst the zone window shows music is playing (see screen shot).

Add images

I’ve been running 1.49 without issue and just updated to 1.49.1 still no issue.

I just want to set a Pointer to my new Roon Extension.

Currently free of charge in the test phase…

rooUPnP: Finally a Roon Extension for UPnP Streamers - Audio Products - Roon Labs Community

2 Likes