Ver 1.5 cannot see networked devices

Hi, just updated to v. 1.5 lost all connection to networked devices and my previous setup of networked devices. Roon cannot see networked devices at all.
Running Roon on MackBook Pro,MacOS 10.13.6

A post was split to a new topic: Missing Airplay device

Thanks for reaching out to us with your report, @Kjartan_Bergsson!

May I ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Since updating have you tried power cycling your Core machine, networking hardware, and endpoints?

Do you have any non-networked devices available? Are you able to play to those succesfully?


Hi Dylan, as mentioned in my email I’m running Roon on MackBook Pro,MacOS 10.13.6. using either wifi or ethernet via Asus Gigabit router. All my music is currently on a USB disk connected to the Mackbook. I have tried rebooting everything several times. My setup is very simple and straight forward. I have been using Roon for over 2 years, streaming to a networked Rasberry unit or different Apple devices via wireless.
After upgrading to version 1.5, the only thing Roon sees are System output and Built in output. And plays ok through System output. It has lost all connection to devices on my network. Can the update have turned Roon network functionality off somehow, and can it be turned on again?? The only network related setup option I see is for Linn streaming which I don’t use.

Thanks for the update, @Kjartan_Bergsson!

Next i’d like to suggest scanning the network so we can make sure that all devices are visible. This will let us know if there is possible an issue with devices connecting to the network or if there is something else going on.

An app like FING will scan your network for devices it can see. Can you try using this or a similar app to scan your network? We will want to make sure that the Core machine and endpoints are all visible. Please let me know if they’re all showing up here!


As I have tried to say. Roon is for some reason blind regarding my network. The Rasperry is the one I usually stream to when on ethernet:

It think you should take a srious look at the latest update (ver 1.5.) I see others have reported similar problems.
Can I roll back to an earlier version of Roon?

Hey @Kjartan_Bergsson,

For various reasons, downgrading to an earlier version of Roon is not supported.

While there have been other similar reports, this type of behavior can often be caused by a number of different things. A vast majority of our users have not experienced this difficulty, so to fully understand why this behavior is occurring we need to look deeper into the specific environment where this behavior is occurring.

Can you confirm that there is no active antivirus or firewall on the Core machine? If there is, can you try disabling them and see if there is any change in behavior?

Additionally, I’d like to recommend taking a look at the settings on your router. In your router settings are you able to see if there is any IPv6 firewall active? If you disable this, do you notice any change in behavior?

If neither of the above yields any changes, I’d like to recommend a test. If you have another machine available that you can run as a Core machine, try starting a fresh database on that machine and let me know if you’re able to connect to the networked devices from there. Knowing if this is specific to this machine or not is a great data point.


Hi @dylan,

There is no firewall or antivirus on the core machine.
IPv6 firewall is disabled on my router.
Roon’s blindness towards my network is the result of me accepting update of Roon to ver 1.5 build 334 64bit.

I don’t have another machine. I have as said been using Roon for quite a long time and have been happy with Roon. This issue is linked to build 334. I have not changed anything on my side for a long time.

I don’t have access to another machine and am now fed up as our dialog is one way and only revolves around my setup, which has not changed in a long time, and not Roon build 334 which is the latest change to my environment.

I will now wait and see if the next Roon update changes anything, as I have a valid subscription to Roon. If not I’ll be forced to find another player than Roon.

Hi @Kjartan_Bergsson ----- @dylan has brought your report to my attention and I wanted to reach out to you concerning this issue you’ve reported to us.

Firstly, I understand and respect your frustration with this issue. It’s never a good experience when things have been working as expected and then seem to randomly fall on the floor. However, I do want to echo the point that Dylan has already made that while you may have seen some reports of similar behavior, we have numerous users running v.15 B334 without issue so there must be some other variable(s) having influence on your Roon setup.

I have seen this type of behavior occur in the past when there are firewalls or antivirus applications running somewhere in the setup and just to make sure we are on the same page here, you have either completely disabled this function on the MacBook Pro OR have made security exceptions for both “Roon” and “RAAT server” on the device, correct?

Furthermore, may I very kindly ask you to please confirm the following for me:

  • Are you able to successfully ping the IP addresses assigned to the device not showing up from the MacBook Pro?

  • If any of your network based endpoints can be used outside of Roon via the MacBook Pro are they functioning as expected under these conditions?


Hi Eric, I can ping the units available on WiFi (apple tv, iPads etc.) and when I reboot with ethernet connected and wifi off I can ping my Raspberry pi with dac that I use for streaming and open the interface in a browser.
I can stream to all Apple units via Airplay. Roon used to see the Airplay units as well but does not any more.
Roon sees nothing in either wifi og ethernet mode:



Hi you where right Eric. My apologies to both you and Dylan. Both Roon and RAAT where blocked in my MacBooks firewall. This is however not because of an action on my behalf, so I don’t understand why it should all of a sudden be blocked. Only thing I can think of is that current version of OSX automatically blocks new apps and/or some updates when firewall is engaged?

Regardless Im happy that I can carry on using Roon as I like it a lot. :slight_smile:

Best regards

That’s great news, @Kjartan_Bergsson!

I’m glad that was able to get everything fixed up for you.

While this doesn’t seem to be the case for all Roon users on OSX, the firewall may have removed exceptions on your machine once the update was performed. I’ll be sure to run this by the team, but moving forward this shouldn’t be an issue for you.

Happy listening!

Thanks Dylan :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.