Waiting for Remote Core...QNAP TVS-EC1080 [SOLVED: Different IP Subnets]


Lately I’ve been losing my connection with Roon. I have to login to my QNAP TVS-EC1080 and stop the Roon Server, and then start it again in order to make the connection but it will drop the connection shortly after.

I have the following:


Roon Server

Remote Roon
Running on Pixel 2 XL - Latest Version
Also tried running on iPad Mini but get the same results.

I’ve tried restarting and no luck. Even been through a couple firmware upgrades on the QNAP. I don’t know what triggered this to start happening.

Music will continue to play even when I can no longer connect to the server.

Any suggestions?


That looks like a rather odd version info for Roon Server … it should be something Build 310 in the about screen on the remote settings if you can get to that on a remote

@crieke Maybe Chris can assist here

1 Like

Roon Version 1.4 (build 310) stable (64bit)

Can you give any details about your network (like router, switches) and how all involved devices are connected?

Sure thing:

Arris TM1602 Modem to Sagemcom Router (both part of Spectrum Internet)

to Cisco SG-200-08 Switch to QNAP TVS-EC1080 (Link Aggregation)

All wired with Cat7 cables

I have Google WiFi connected to the Router and Switch as my entire place, besides the main connection, above is wireless.
I use Roon to control my Naim Uniti Nova but was getting the same issues with my previous streamer, Lumin A1.

The first thing that comes to my mind, is to check the IP addresses, as it seems all wireless devices (iPad, Pixel) are unable to connect. Please verify (if you did not do this already) if the iPad/Pixel has the same IP range than your QNAP core.

Hi @ColdBusted ---- Thank you for the report and sharing this observation you have made with your Roon remote. The feedback is appreciated and sorry to hear of the troubles.

I agree with @crieke’s suggestion in regard to verifying that the IP addresses being assigned to your devices are all within the same range. Additionally, I did some research into the mentioned switch (i.e the Cisco SG200-08) and can see that it is a smart managed switch and we have seen a few issues crop up with these devices in the past (Example: #1, #2, #3, #4). I would recommend enabling flow control on the switch, to see if this action yields a change in performance with the Pixel 2XL.

Furthermore, can also try disabling igmp snooping on the switch as well.


Thanks for the suggestions! I’m pretty sure it’s an IP address issue now.

QNAP is on but Google Wifi is all set up on the following 192.168.86.x and I’m having a hell of a time switching it over to match the QNAP.

I’m sure once I set up a custom LAN IP on Google Wifi it should work correctly.

Well that was it! Once I got everything on the same IP there are no more issues. I was able to remove the router completely from my set up and that fixed a Double NAT issue.

Thanks so much as it was driving me crazy for the last month or so.


Glad to hear, you could solve it. :fu: