Waiting for Roon Core error

I’m now getting this issue too after build 970…

A reboot of the network and core used to sort this sort of thing out in the past, but it’s a little more persistent since 970.

Core running on a NUC (hard-wired to network) streaming to various devices (BlueSound NODE over RAAT and B&W Zeppelin over AirPlay) over Google WiFi mesh network - both types of device experience the issues.

Roon Core Machine

Rock running on NUC8i5BEH

Networking Gear & Setup Details

Sky router with Google WiFi (roon core wired into an unmanaged switch connected to main Google Wifi point and all roon endpoints running off wifi)

Connected Audio Devices

BlueSound NODE (latest iteration)
Meridian 210
B&W Zeppelin x 2

Number of Tracks in Library

9810

Description of Issue

Since build 970 I have frequent “Waiting for your roon core” messages, generally these come in batches; restoring the Google WiFi network makes no appreciable difference. When the remote (in my usual case, the roon app on macOS) regains its connection it takes a little longer for it to reestablish connectivity with the BlueSound NODE.
This comes after years of stable operation in this configuration.

Connect the NUC directly to an Ethernet port on the Sky modem / router.

I think that gets a little tricky as Google WiFi creates a separate subnet so if my understanding is correct it won’t be able to see any of the remotes or audio devices.

Can the Google mesh use wired backhaul?

Three of the six WiFi points (in the loft) use a wired backhaul; the others are wireless more to provide networking for non-wireless devices than to extend the network…

Powering down the Google WiFi point nearest to the BlueSound NODE seems to have helped greatly. This may now be repurposed elsewhere.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Re-opening this after it was prematurely marked as solved…

The problem still persists and I’d really appreciate some help in diagnosis…

1 Like

Hi @Mesmo,

I’ve reopened and merged to keep all the history together.

1 Like

A post was split to a new topic: Roon cannot locate my Core on my iPad

Thanks Carl

1 Like

Over the weekend I had no end of issues with one of the Zeppelin’s in another roon - many many intermittent dropouts.

If anyone can help point me in the direction of the logs so I can try and determine if this is (as suspected) as WiFi issue it’d be good before I invest in an alternative to Google WiFi (without redecorating much of the house, wired ethernet to all the endpoints is not really possible, so I’m thinking of a mesh system with powerline backhaul).

Hi @Mesmo ,

You can use these instructions to access the Roon logs.

Do the Google router logs show any additional information regarding throughput when the issues occur? These sound like general network connectivity issues.

Have you tried powering them all down and starting back up fresh? Maybe this issue happens when switching between the access points and one of the other ones needs a reboot.

Powerline has gotten better in recent years, but it sometimes introduces other issues, so I would be cautious with them. The best option still remains a direct Ethernet run and multiple access points, while devices that support Ethernet are connected with Ethernet.