Web display won't load past splash screen on Linux Core [Resolved - Linux Multicast Firewall]

Core Machine (Operating system/System info/Roon build number)
Ubuntu 18.04.3 LTE on a Virtual Machine using FreeNas 11.2 I used the standard Linux installer.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Ethernet Netgear using a switch + router. I also have a Bitdefender Box in the mix.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Sonos and Oppo.

Description Of Issue
When I open a browser and navigate to the web display it just sits on the splash screen. I tried it on 2 computers including the virtual machine itself. I also tried different browsers and cleared caches on each and they all had the same results.

Hi @Bradley_Walter,

Can you give some details on the switch and router in use? What model are they?

Can you confirm which web browser you’re using?

Can you confirm that you’ve enabled the Display for the zone, as shown here:


Thanks for the quick response Dylan here is the info you requested

Router: NETGEAR Nighthawk X10 AD7200
Switch: NETGEAR GS308v2
Browser: Firefox 68.0.2 & Chrome 76.0.3809.132

I do not see that icon in either the app on Android or in the Windows desktop app I only see the other three

Hi @Bradley_Walter,

I wonder if the firewall is the issue here, can you confirm if the behavior is the same with bitdefender turned off? Also, that display icon will only appear once you opened the web page and navigated to the link, as per our Displays documentation.

Thanks, Noris, I’ll need to really look into that, the Box is not something I can switch on and off it’s rooted into my network it dictates IP addresses and everything else. I’ll reach out to them and see if there’s any way to disable it. But before I reached out I checked its logs and it’s not blocking anything.

I don’t know how this display system works behind the scenes but I did try the URL on the virtual Linux system and had the same issue. So I’m not sure firewalls would be an issue if I’m trying to go to a port on the same machine.

I do have lots of things running without issue, Home Assistant, Resilo, Plex and none of them have suffered from firewall issues internally. When it comes out outside access things get sticky Like accessing plex outside my network. Does this web UI function like that?

Hi, @noris

The response from Bitdefender was as expected, really nothing to deactivate on the Box itself. I just did a test and created a new core on my windows computer to test the web display function and it worked perfectly, I tried it on several browsers on several different computers and they all worked as expected.

The breakdown in my actual install seams to be the display icon never appears. So it could be a Linux thing or something to do with the virtual machine but it is not a firewall issue. I tried to look at the logs for insights but couldn’t make sense of it.

Any insights would be greatly appreciated.

Hi @Bradley_Walter,

Thanks for giving the Windows PC a test. Since this behaves as expected, I would surmise that the issue is due to the Core itself or some specific variable surrounding the Virtual Machine setup.

We typically can’t troubleshoot specific Virtual Machine settings, but I would suggest that you take a look at the multicast settings and make sure it’s configured to pass properly. Also, this thread might help:

1 Like


Thanks for pointing me to this, I’ll have to wrap my head around executing the solution but it sounds like it it’s something all Linux users would have to do. I would have to second @CRo suggestion of adding at least something even if it’s not plug and play into the install documentation. Even a link to that article would be helpful. Before I posted here I reread the install doc several times looking for something I skipped.

Thanks again for your help.

Hi Bradley_Walter,

yeah, it was a complete surprise that you need to tell Linux (well, CentOS/RHEL based distributions anyway) to explicitly allow IGMP and Broadcast in the firewall. Normally you never have anything to do with broadcast, right? Everything works fine, you enabled all the ports your various services of all your PCs and your Plex Server and what have you on your subnet and everything is fine, you just never think you want to add to your firewall rules.

1 Like

Yeah I’d have been totally lost, but that list of rules you laid out did the trick and it looks like you took the long road to get there so I’m glad you who clearly knows more then I got to the bottom of it. It really should a be a sidebar in the install instructions or at least posted as it’s own topic so it’s easier to come by. My issue wasn’t even the android remote (I hadn’t gotten that far) but the web display.

So much great information buried inside these forums

Thanks again for this.

1 Like

Hi @Bradley_Walter,

Glad to hear that the issue is resolved with those instructions! I will discuss with the product team to see if we can add any additional information to our documentation but in either case glad to hear that it helped.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.