Weird selective "can't connect to Roon search since a week"

Roon Server Machine

Server:
Roon Nucleus+
Remotes:
Roon Server 2.0, build 1359
Mac Roon app 2.0, build 1359

Networking Gear & Setup Details

Netgear Orbi 960, configured as router

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Dear all,

Since at least a week I couldn’t connect to Roon search. The rest of Roon worked well. I updated everything to what I believe (and the system indicate) are the latest versions.

This search problems affected both the Mac Roon version and the mobile version on my Iphone (both updated as well).

Now, I always tried to search for “Bill evans”. But now I thought: let’s type some thing else: it worked! If I type “Michael Jackson”, “Cher” of other things, it works. But when I persist in searching for “Bill evans”, the original search, it says it can’t connect.

So now I can search everything, except “Bill Evans”.

Any thoughts?

All the best,
Rodrigo

I don’t think I have any Bill Evans favorited or added to my catalogue, but maybe he “appears” on some albums I do have. When I did a search through Roon, it came right up with his listing. I do use Roon with Qobuz. Clicking on it took me to his page with all the relevant included.

I experienced a similar issue with a different keyword. ´Bill Evans´ works instantly with all desired results. My roon seems not to like ´Claude Debussy´, on the other hand:

Seems to be a pretty selective issue as other queries which used to cause some delay with the previous builds are pretty fast today. In general roon appears to be pretty snappy and is really fun to use since build 1358.

Hi @Rodrigo_Salgado,
Do you have anything by Bill Evans saved locally or is this all from streaming?

Dear Daniel,

Both local and streaming. And the thing is also: if I type “Bill”, I get this preliminary results below the search bar, including the “Bill Evans trio”. However, when I continue typing to the final “Bill Evans”, I get the “can’t connect to Roon search” error.

Thank for your help,

Rodrigo

Hello Rodrigo

I’ve enabled verbose logging on your machine in order to get a bit more info on what’s going on. Would you mind restarting your roon server and trying again a few searches that don’t work? This will not fix the problem, but it will give us some more insights.

Thanks Daniel,

I’ve done several searches in the last 24 hours. Only “Bill Evans” fails, while that used to be no problem.

Thanks for your help,

Rodrigo

Thanks for doing this. We’ve managed to reproduce the issue, and should be able to provide a fix soon. I’ll let you know once that happens.

1 Like

Hello @Rodrigo_Salgado, can you please retry your searches? In particular Bill Evans that was throwing errors? It should work now.

My parallel problem with ´Debussy´ or ´Claude´ has been solved. Claude Debussy is back on the search list again and search is faster than ever.

Thank you very much @ Roon team!

3 Likes

It works! Don’t know what you did, but the issue is resolved. Thanks !!

Rodrigo

3 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.