What are these endpoints “connected to your Core directly?”

I have 6 ALSA audio options that I can’t make heads or tails of. See screenshot.

Setup: Roon Core on NUC. Ethernet NUC to a switch. Incoming internet signal ethernet from modem to Google mesh to switch. The only other thing on the switch is an Apple TV, with TV:Remote installed, running Roon. Apple TV has the usual stuff, Netflix, etc. Goes into Yamaha AVR, with TV. All good.

There are other endpoints scattered about, but they all work fine and raise no fuss.

I want to run direct to the Yamaha, bypassing the Apple TV. The Yamaha and the NUC are about a foot away from each other so I can easily hardwire.

In the past I have tried to run HDMI from the NUC to an open HDMI port on the Yamaha but could never get that to work.

What are these 6 HDMI connects showing as “connected to your Core directly?”

The Yamaha has an onboard DAC, so if I can get the signal into the Yamaha, it should come out at least passably. I need to understand this before I replace the Yamaha as I am considering doing.

How many HDMI ports does your NUC actually have?

This is forcing me to use ten characters but…


Hmm, it’s been a while but I think I remember my old nuc 7i3 showing more HDMI available endpoints than the ports it had, 2 actual but 4 under Roon.
However 1 actual and 6 endpoints shown is a little excessive I admit.
I truly do not know why so much duplication of the 1 HDMI port/ endpoint you really have is being displayed.

Hypothesizing that the one port could theoretically feed six different points (though I’m not sure how that could be done without more hardware) one would think that the one outgoing NUC HDMI would pass a signal to the AVR. But it doesn’t. It’s like it needs another intermediary device to create a usable signal to feed the AVR.

You really should be able to use the HDMI port on the nuc to feed an AVR.
Many members here do this especially for multichannel music.
I think there is something else going on.
What model Yamaha is it?

Yamaha RX-A770.

And thank you for giving this some thought. I usually assume it’s user error, but I’ve tried a few different things, and managed to get the NUC running and a Raspberry PI up and chugging elsewhere in the system, so I think I have the basic knowledge.

But I’m stumped here.

A quick read of the manual and specs does not show any good reason why it should not work.
However I have not used one or any AVR for years so will let some other members comment who hopefully have actual experience.

Thank you. I went hunting there too, but a second pair of eyes always helps.

Sorry couldn’t be much more help in this case but I’m sure someone here will have the solution.

The way I use HDMI is to enable HDMI 0 and than connect it with my DAC (HDMI 1). It should work that way with your reciever - I hope

Below what I see - please note currently HDMI 0 is not enabled in my setup.


I had the same question a few years ago. This is how it was explained to me;

…Roon software lists all HDMI ports which includes Display Ports (and maybe even DVI ports?) that are either available on the motherboard video chipset, or the processor chipset in the case of Intel processor integrated video, even if all ports aren’t physically installed in the motherboard backplate, so this is somewhat common…

My streamer/core (Salkstream III) only has one HDMI connection. This is what I see in Roon. In my case, HDMI 2 (labeled Oppo 103 in the pic) turned out to be the one for the HDMI connection on the Salkstream.

1 Like

Thank you. I will give that another try. I did try that a while back and there was no sound emitted.

Did you have to try enabling all of them to see which one worked?

I tried each one by one until I found the one that worked. :+1:

1 Like

Thank you. Now I know what I’m doing tomorrow. :wink:


Hope it works! :crossed_fingers:

1 Like

I don’t use on board sound or HDMI for audio on my builds. So I tend to disable both in bios. Then I only get detectable endpoints show up. HDMI still works for video.

1 Like

If your NUC has one physical HDMI connector on the back panel, then that has always been HDMI 0 in my experience; if two physical ports, then I assume it would be HDMI 0 and 1.

Note that it is possible to disable these ports in the BIOS. They should be enabled by default, but it’s probably worth checking.

1 Like

It would seem Roon believes my Core has 5 HDMI ports and 2 Audiotrak sound cards. When in fact there are 1 of each. :sweat_smile:

My Core is running on Zorin Linux Pro on a Lenovo laptop. Not a NUC.

1 Like