What CD drive to attach to Nucleus

What to store CDS on my Nucleus. What CD drive should I buy? Is it plug and play or what do I need to do? Need make and model of the CD drive.

Thank you

Basically any USB CD drive should work. See also the Help article:

Be aware that there’s currently a bug in the CD Ripping function, and no timeline on a fix as yet.

2 Likes

Thank you I will wait to to purchase a Cd Drive when the bug gets fixed

Don’t wait. Just do it on your PC using a software like dbPoweramp. I don’t use the RoonOS ripping feature as it doesn’t add the meta-data to the files during the rip. If you want your music for use elsewhere you have to then do an export.

I find it much better to rip on the PC and then copy TO the Nucleus. Either way you are still going to be doing 2 steps. A rip and a copy (or export).

2 Likes

Got you. So rip using the software and save to a device. Do you just insert a usb drive In to the nucleus and it automatically transfers or how do you tell the Nucleus to receive the files?

Great info and thank you.

You have to copy over the network to get files into the Nucleus. Assuming you have a storage drive in the Nucleus.

If not, then I’d put everything onto an external USB hard drive and just plug that into the Nucleus.

I have 2tb in Nucleus.

So procedurally I pop cd in drive save to a file

Is there a way to save to the nucleus when the cd is in my cd drive attached to my windows laptop?

Well, you can add a drive share to your Windows Computer as a drive letter, I have one setup as Z: and rip to that drive. However, the rip process is so slow that Roon will start trying to analyze the file as it is ripping and can cause split albums. Better to wait til it has been ripped and then copy it over.

But, you can use the share you setup to quickly copy things from your PC to the Nucleus! :smiley:

Can I see the nucleus from my Windows laptop?

If I plug a removable drive in to laptop and rip cd to the drive can I drag or copy file over to nucleus or something else?

Yes. Type \\ROCK\ into File Explorer (upper case important). That should allow you to see the Nucleus (it does my NUC). Then navigate to Data, then Storage - you should see your drive in there (I think - mine is an external drive that shows up there).

I rip several discs to a folder on my Wondows laptop using dbPoweramp, then periodically transfer the folder contents over to the ROCK machine.

Note to self - must get round to those 900 CDs not yet ripped (darned eBay job lots!)

1 Like

I attempted to use my Apple Super Drive CD with my Nucleus to add some of my CD disc’s to my SSD Samsung drive in my Nucleus. It worked intermittently but stopped working on a number of occasions and ultimately stopped working completely refusing to release a CD. I tried rebooting the Nucleus among other things but I finally gave up. For a number of reasons I don’t want to go the Mac route of inputing and transferring the data. I saw your post that this may be part of a larger issue known to Roon Labs and if so could you tell me if this has been fixed or not. In short, just want to know if the problem is Roon Labs software or me and my equipment. Any light you can shed would be appreciated. Thanks, Steve

This issue of CD Drives locking up on the Nucleus has not yet been fixed. It requires Roon OS 2.0 to be released, and this is still in development (and has been for a long time now).

A workaround for when the issue strikes is to disconnect the CD Drive, reboot the Nucleus and reconnect the drive. This may work for an Apple Super Drive, but I’m not sure…

1 Like

Thanks for your quick reply. The fix is to tedious for the CD’s I have. Very unfortunate. I would not have bought the SSD if I had known. I would have spent the money on an external drive.

Many of us use the CD Drive on our PCs/Macs and use a third-party software package to rip CD to our computers. Then transfer the ripped files across to the Nucleus…

1 Like