What Would Cause the 'Loading Album' Screen to Remain On?

Sorry, but because I don’t know why this happens, I don’t know where to post my question.

Very often when I’m navigating from one screen to another, I get the black “Loading Album” screen that doesn’t go away on its own. I’m forced to close my Roon app for 15 seconds or so and then start it up again. I don’t know if this problem is caused by my core device (a MacBook Air with 8 MB of RAM) or my tablet (a late model Apple iPad) or my streamer (a Lumin D2).

I should also mention that I make it a point to not ever have any other apps open on my iPad either.

Any guidance would be helpful and appreciated.

Please take a look at the thread linked below. Do the circumstances described there match your observations?

1 Like

Yes, that thread pretty well sums it up.

I’ll have to scan the thread to see if there’s a solution for me.

Not until a fixed version of Roon get’s released.

1 Like

Thanks BlackJack, at least I know now that the problem isn’t with my equipment. :+1:

Hello @S_J_A,

Thanks for confirming that your symptoms match the one’s reported in the thread. As @BlackJack has noted, we have an active ticket regarding this behavior and I would suggest keeping a close eye on that thread for when we address this issue. I appreciate your patience here while the dev team addresses this. Thanks!

– Noris

1 Like

Thanks Noris, I’ll be sure to keep an eye on the thread you mentioned.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.