White screen with multiple monitors

i am seeing this regularly on a threadripper system with 3 monitors and a 5700xt, so it is not an nvidia specific issue. the multimonitor thing IS very interesting tho.

only an uninstall with clearing the database and reinstalling fixed things. i will leave the roon app on the monitor it initially started up on vs moving it to a different one for a while to see if that helps, but this seems like a rather easy thing for a developer to reproduce, assuming it is a multimonitor thing with moving the main window around to different monitors from where it started.

its a horribly frustrating issue

1 Like

Thank you for sharing that you’ve run into this. There’s nothing worse than starting to think you’re crazy and the only one. It is horribly frustrating when I’m trying to work and can’t move my Roon.

I’m on an AMD 3900X. Not quite a Threadripper but similar enough.
I am also using the same workaround … just keeping Roon on a single monitor and not moving it.
I also ran into the only solution you did to fix it, although disconnecting ALL of your monitors (via control or physically), then launching the app, and then reconnecting the monitors has worked for me too.

for the record, i am running a 3970x CPU on a Asus ROG Zenith II Extreme motherboard. GPU is Asus ROG as well

its not you! i dont recall this happening on my last intel build with the same 3 monitors tho.

well, things broke after a reboot. sigh. even if the devs find the issue, its going to take months to see it pushed out. major PITA

i am not about to disconnect monitors =/

what is even more frustrating is that you have to uninstall the app AND delete the settings for things to work again. Even deleting just the settings and leaving the app in place doesnt fix this

Hi @Eric_Zimmerman,

The team is currently looking into this, but this isn’t something we are seeing widespread reports of, and it’s not something that the team has been able to reproduce through testing in our QA labs.

How often does this occur? After resettings the database do things work fine for a while, even if you move between monitors?

Is the machine that you’re using here your Core machine or just a remote device?

it is a remote device. Core device is a linux VM

it occurs pretty much every time i reboot and then have to restart. the tricky part is i have 3 monitors. the installer is on the main one, and clicking “start roon” in the installer brings it up on the main window. the shortcut tho is on a secondary window, so restarting it forces it to start on the secondary screen, and the issue exhibits itself.

if there is a verbose logging feature i am happy to turn it on and send you whatever you need. i am a software dev myself so i get the issue with it being reproducible.

if i uninstall COMPLETELY, including the database and settings, then reinstall, things work perfect. once the issue happens, nothing fixes it. it says not responding until its task killed and reinstalled from scratch.

i tried NOT reinstalling and just nuking the database and it did not fix it. i had to remove the whole app and restart, so i dont know if there are registry settings involved that may be part of it,

please let me know if you have a way to turn on trace messages or you want me to test a special build, etc. happy to do so

Hi @Eric_Zimmerman — Thanks for the details here.

Moving forward, I’m hoping you can do the following:

  • Reinstall Roon so that it is in a working state
  • Reproduce the issue
  • Use the directions found here and send us over a set of logs using a shared Dropbox link
  • Save Event View logs (directions below) and send those over as well

Getting Event Viewer logs:

  1. Press Win + R and type eventvwr.msc
  2. Press OK – this should open Event Viewer window
  3. From the left sidebar go to Windows Logs > Application
  4. Right click on the Application subsection and pick Filter Current Log... from the context menu
  5. On the Filter tab for the Logged section pick a parameter Last 30 days and press OK
  6. Right click on the Application subsection again and pick Save filtered log file as.. from the context menu
  7. Enter the log file name, for e.g. Roon_USERNAME , and press Save
  8. Share the logs via a Dropbox link along with the timestamp from step 2

Thanks!

sweet. i am out of town this week but will do this remotely if possible one evening.

for event log stuff, you may be interested in this, as you can target the application log very easily to CSV and save people who are less familiar with that some hassle

its my program (i am a forensics nerd), so if there are specific event IDs you want, it can target those too and write out to csv, etc. you can do maps and all kinds of things to make your life easier.

i am curious, how are you viewing the event logs now on your side? the built in windows tool?

so an interesting discovery.

when i RDP into the box, the app starts and stops just fine, i assume because RDP is presenting a single monitor so it works. if i cannot reproduce via RDP, i will do this on the weekend or early next week when i am physically back in front of the machine

i sent you logs via DM as well

Hi @Eric_Zimmerman — Thanks for the update, and for sending the logs over.

Definitely interesting that things work okay when using RDP — I’ll get these logs over to the team and this weekend when you can reproduce can you send them over as well?

Thanks!

yes i will repull logs when i get home so they can be compared.

Note: You don’t have to physically disconnect your monitors. If you disconnect the monitors via your control panel, then relaunch Roon on the primary monitor. Then close Roon. Then reactivate your monitors. Roon should launch correctly.

THIS IS A BAND-AID … not a fix.

I can also confirm I had to blitz the setting as well as the app in order to get ROON to launch (without disconnecting monitors).

OK i can confirm moving the window, closing, and reopening makes it hang.

the workaround works too. disconnecting the monitors makes the app start on main window and its fine.

i have collected several sets of logs, with it working, and then another set where it was working, i made it break, force killed it, disabled monitors, and got it working again. will send those via dropbox now

Thanks for sending those over, @Eric_Zimmerman — I’ll get those to the team and will follow up soon!

Just to throw it out there … I think we’re both on Zen2 micro-architecture. If the team isn’t testing on a Zen2 platform, that could be why they can’t reproduce. I know there’s been some issues with thread handling on the higher core count parts like @Eric_Zimmerman has, but I’m only on the 12 core.

i updated to the latest and it still exhibits the same behavior.

a certain window