Why did Roon spontaneously revert itself from Roon 2.0 to 1.8? [Fixed: Update Server Error, Update To v2.0 Using Migration FAQ]


There are 2 issues:

  • The automatic downgrade of Rock from 2->1.8 and impossible to upgrade it back to 2.0 (unless I do a clean installation)

  • Since I have reinstalled everything, the connection issue.

That’s why I made a separate subject.

@xxx, sorry for not being accurate. What I tried to say is that it’s not every RoonOS install affected. We are investigating this and have not been able to reproduce it locally.

Apologies for the trouble.


Also, the procedures from updating a ROCK from Legacy V1.8 to V2.0 don’t work.

Sorry to jump in again. Are the logs from the machines any help at all? I’ve seen one user post a log which complained about the branches folder and connection to the room server URL. However the pair has since been moved or deleted, so I am unable to link it directly to you.

I had this problem (ROCK downgraded itself to 1.8)
I fixed it by installing the legacy 1.8 remote, connecting to the core, then going to the settings/about screen - thats what prompted it to update again to 2.0.

I’m super annoyed by my connection issue.
In fact, I have 2 Rock on my network

  • One Rock which is my server
  • Another Rocker with is my Rock endpoint.

I can connect to the endpoint, no issue:

But not to Rock Server. Please help but currently I need to use windows PC to play songs :frowning:

Geoff, this entry should be in my other thread that you have linked to this one - which in my opinion is a mistake -

Again, I’m using Roon Remote on Android.

That didn’t work for me.

I finally tossed in the towel and reinstalled ROCK from square one.

And do you experience the issue I’m having ? Can’t connect from Roon Remote :frowning:

No, running ROCK V2.0 and Roon V2.0 Remote under WIN11.

If you’re having problems connecting to ROCK V2.0 from a Windows Roon Remote running V2.0, try restarting the Remote. That’s what I had to do.

I have an Intel NUC8i5BEH Core i5 that I bought in September 2019 running Version 1.8 (build 1126). I have carefully followed the instructions located on the “Roon 1.8 <-> 2.0 Migration FAQ” from the Knowledge Base marked as “RoonOS Core 2.0 (Nucleus / ROCK)” from the "How do I move to Roon 2.0 from Roon 1.8? " section and the Roon Core still remains on version 1.8.

I have repeated the process several times and restarted the Roon Server or rebooting the Intel NUC several times too and after all that it still remains on version 1.8.

Screenshots do not say anything new as you can see.


Can you fix this issue asap please?

Yep, the procedure to get you out of your fix doesn’t work.

If you have an iOS device, then you can download ‘Roon Legacy’ Remote from the App store. That will control your Legacy ROCK until Roon gets its act together…

Oh my god, it’s so broken.

Once again, I have used the USB Stick to reinstall Rock
Roon remote Android saw the 1.7 version and asked for Upgrade.

And now again;

Nothing works.
Do you want people to resign ?
Fix this or I will ask for a refund.

It’s broken since last Friday :frowning:

Thanks a lot xxx. I installed Roon Remote Legacy 1.8 from the App Store in my IOS devices as you suggested and it is working again.

But please RoonLabs, fix this issue. The way to update to Roon Core 2.0 on Barebones like the Intel NUCs is not working.

Just to confirm I am having exactly the same issue as @XAVIER_POUYOLLON described:

  • It was working perfectly on Roon 2.0
  • Roon requested an update
  • I’m now back on Roon 1.8 (ROCK running on my NUC)
  • Now there appears to be no way to upgrade back to Roon 2.0

The legacy iPhone app does not give the option to upgrade to Roon 2.0.

Roon 2.0 is excellent, but this is super frustrating and I want to use ARC again.

1 Like

Same here, updated at first and reverted soon after. Also on a NUC btw.

We’re investigating the root cause of this issue and will report back as we know more. We have made a change to the update server which should prevent this from happening to more users.

@kdsl, when you have a moment can you please attempt the 1.8 Legacy → 2.0 migration process on your ROCK? Please let us know if it attempts to move back to 1.8 after 2.0 is installed.

I just attempted the 1.8 Legacy → 2.0 migration process on ROCK (Intel NUC8i5BEH Core i5). Here it is the steps I have done:

  1. I removed from “Data/branches” folder the old version of the downloaded “roon” file, named “roon_2-0” when downloaded.

  2. Before trying to download again the “roon_2-0” file from the server, named it “roon” and copied on “Data/branches” folder so this folder remained empty, I went to the Roon Core Web UI to stop the Roon Server software when I have noticed that “Version 2.0 (build 1128) production” was already running so I did not proceed stopping the Roon Server software and followed as described.

  3. I removed the old version of the Roon App from my MacBook Pro, downloaded again the Roon App from RoonLabs web site and installed.

  4. Started the Roon App on my MacBook Pro, connected to the Roon Core and it is working like a charm! Roon Core running with Version 2.0 (build 1128) and my Mac (remote device) with Version 2.0 (build 1128).

Thanks a lot! Finally this issue have been resolved in my case. What about you guys?

1 Like

Hello All,

Thank you for the reports here and we apologize for the inconvenience.

We’ve identified an issue with our update server erroneously serving 1.8 Legacy builds when it was not supposed to, and have since corrected this behavior.

For those who have already been downgraded to Legacy 1.8 and wish to re-install Roon 2.0 on their Cores, please follow the 2.0 migration guide on our knowledge base, linked below.

1.8 Legacy is compatible with 2.0, so your Roon database should remain intact. If you encounter any further issues after following the guide, please start a new support topic and let us know, thank you!