Why doesn't crossfade work? [Ticket In]

More often than not, when I am paying attention, crossfade doesn’t seem to work. Often the current track will cut off 5 seconds before the second track, there will be a little gap, and the next track will cut in. The progress bar on the slider freezes at that five second mark until the next track cuts in.

Even when I hear the current track through to the end, the next track doesn’t fade in. Doesn’t have anything to do with silent spots at the beginning or end of tracks.

Anyone else seeing this?

Hello @James_I,

Using the instructions provided in this link, could you provide some more details about the setup you are using? Some helpful information to include would be if you are using an external DAC and if you see this behavior with every output on your device.

-John

I am experiencing this as well. Exactly as @James_I describes. I even turned the crossfade up to 10 seconds so the effect is easier to hear. All that seems to happen is that there is a “brickwall” cutoff 10 seconds from the end of the preceding track and then the next one just starts. There doesn’t seem to be “seguing” in the sense of beat matching between tracks nor do I hear anything like one track fading out and the other fading in which is actually more what I expected as the feature is called crossfade. I tried this with lots of different combinations of tracks, Including tracks with long fade outs and those with none. The effect is actually more jarring with tracks that naturally have long fade outs.

I tried this in two scenarios.

  1. In my main system I use HQPlayer. So I thought maybe it had something to do with that. In the device set up there are actually no volume options for HQPlayer in roon. That is, there is no option to choose between device control, DSP control and fixed volume. @support, is it the case that crossfade will only work if DSP volume control is enabled? Does that mean that in effect cross fade does not work with HQPlayer? Or maybe there is another setting I am not aware of?

  2. I also tried crossfade output through the soundcard on my laptop (Conexant HD). In this case in the device settings there are options to set volume control to device, DSP or fixed. But it didn’t matter which option I chose. Crossfade doesn’t seem to segue or crossfade. There is just a brick-wall cut-off which counter-intuitively is much more noticeable the longer the crossfade is set to.

Hello @tripleCrotchet,

To change the crossfade settings for a given playback zone, right click on the zone icon along the bottom playback bar and select “Zone Settings” in the pop-up menu. It should look like this

-John

Hi @John,

I mustn’t have explained very well. Both myself and the OP have already done that. We are not asking how to switch crossfade on. We are asking why it doesn’t work when we switch it on.

I notice from your screenshot you are using HQPlayer. I am as well. My experience is crossfade doesn’t actually crossfade. What it does is truncate. That is not the same thing. To my ears on my system, using HQPlayer, all roon seems to be doing is chopping off 1 to 10 seconds from the end of the preceding track and then immediately starting the next track.

At a minimum I would be expecting to hear one track fading out as the other is fading in. What I hear instead is one track abruptly stopping and the next one abruptly starting. That is not crossfade. Something more sophisticated would be to “segue” which benefits a lot of pop and dance music by matching the BPM of outgoing and incoming tracks.

I can only assume you are hearing something else.

  1. What settings exactly are you using? I can replicate them to see if it helps. I don’t believe there is anything odd about my setup. It is just roon->HQPlayer->USB DAC.

  2. But I don’t believe the issue is the result of HQPLayer as I have an identical crossfade experience whether I use HQPlayer or not.

Hello @tripleCrotchet,

Just to confirm, you are seeing this behavior on every crossfade transition? Even when the next track is of the same format and sample rate? Can you also relay to me what you have selected in Settings>Library for the “Background Audio Analysis Speed” and “On-Demand Audio Analysis Speed” options?

-John

I’m out of town but will run some tests when I return, and report back. My recollection is it is every transition.

Hi John,

On my system it is every transition. I randomly queued up a bunch of MP3/320, FLAC 44.4, 96 and 192 and a few DSD as well just to double check. All transitions are extremely abrupt. I cannot hear any crossfading at all.

I have background audio analysis set to “fast (2 cores)” and on demand audio analysis set to “fast”. But I have not noticed any change in behaviour whether I have a backlog queued up for analysis or not. I actually played around with crossfade maybe 18 months ago when first subscribed to roon but switched it off pretty quick, along with radio, as essentially un-listenable. I have two roon’s at home. The main system is on an i3, fanless, self-build but I also have a travel roon set up on an i7 laptop. The behavior is the same, on both systems, with or without HQPlayer.

Counter-intuitively the effect is much more noticeable the longer the cross-fade is set to. At 10 seconds, for example, roon becomes particularly un-listenable as any fade outs that have been recorded on the vast majority of tracks are essentially just wiped and and the track abruptly terminates very jarringly mid phrase. It doesn’t matter what value I set crossfade to, I simply cannot hear any cross-fading at all.

I started experimenting with cross fade again because of the changes to radio in the new release. Neither works for me, so both are switched off now.

I share this experience - I presumed I was doing something wrong, misunderstood crossfade or that it didn’t work with Tidal content, but I don’t think it has ever worked as I expected it to. The only advantage it held was eliminating clicks between tracks on an RPi + Volumio setup.

Hello @tripleCrotchet,

To narrow down the scope of this issue, I discussed with the tech team how we could isolate the various components of the playback system to nail down the root cause of this behavior you’re seeing. They asked that you try the following steps

  1. Select a simple playback zone, such as system output, for playback
  2. Start playback on an Album from Tidal
  3. Do not seek during the track, allow it to reach the end of the track naturally
  4. If crossfade does not behave as intended, notate the time of day and what computer you were running the core on and report back to the thread with the information so the tech team can request diagnostic logs from the core

If you do not subscribe to Tidal, you can attempt the steps with a local album that you know is all of the same format and sample rate. The reason they would like for you to try Tidal is to isolate the local analysis process from the crossfade engine.

-John

Hi John,

I don’t use TIDAL so sorry I cannot help you there. But I don’t believe that audio analysis is interfering. I cannot see that there is any backlog queued for audio analysis on my system. Mostly the analysis when adding an album is very quick on my system, maybe a bit longer with a box set.

It hadn’t occurred to me to use crossfade to play an album or that anyone would want to do that. I am trying to using crossfade on radio or with the queue or playlists which I would have thought was a more typical use case.

When I use crossfade to play an album I hear an overlap between tracks I didn’t hear before. I hear it with crossfade set to 5 seconds and it is more noticeable (and more successful to my ears) when set to 10 seconds. I still do not hear the tracks fading out and in. What I hear is the first and second tracks playing concurrently for a few seconds. They are literally “overlapping” but they sound as if they are both playing at their normal levels and the first one sounds as if it is fading out only because it was recorded that way anyway.

Personally this is not to my taste. I think it works with some styles of pop and club / dance music but not with jazz, classical and easy listening / american songbook. I would prefer more seamless transitions or at least the option to chose between different crossfade styles depending on the type of music. Researching this on the internet I notice that there are many styles of crossfade and many implementations by different consumer and professional players and editors and automated radio station players. For example, Adobe Premiere Pro offers two types of crossfade.

However, when I play radio with crossfade on I cannot hear this “overlap”. It is a completely different experience. Most transitions are extremely abrupt and this worsens the longer the crossfade is set to. So set at 10 seconds radio is virtually unlistenable on my system whereas with certain styles of pop and dance music I thought that was the most successful setting when listening to an album.

I will set radio running overnight and you can access the logs if that helps.

this is happening to me ,crossfade in is not working at all!!

I concur crossfade could have nicer transition from one song to the other. I also experience abrupt cuts same as the people who started this thread. Maybe in the next update will be improved/enhanced?

Regards,
Norwin

All ---- Thank you for the feedback and more importantly thank you for your patience here. My sincerest apologies for the very delayed response on our end.

Continuing forward, if you are noticing issues while using the crossfade feature in Roon may I very kindly ask you for the following:

  1. For the tracks that are fading in and out are they the same sample rate + bit depth?

  2. Are you noticing an issue every time crossfading is enabled in Roon?

  3. Has analysis been completed on your library?

-Eric

I’m so glad to see this thread rekindled. I have been struggling with the crossfade quality for close to a year and I very much want to see this sorted.

My setup is simple and consistent: Tidal (all qualities AAC/CD/MQA). System Output.

I’ve adjusted the crossfade length for experimentation (4 to 10 seconds) with the same results. note: my experience is the same as the previous posts (abrupt ending of track, followed by silence, followed by next track).

I’m available to follow up on this thread, as needed, with whatever information you may need.

Thanks for your help, Eric!

Agreed, I still notice that crossfade seems to work about half the time.

All ---- Thank you for the continued feedback and more importantly thank you for your patience here. Both are appreciated!

Moving forward, if you are still experiencing issue with crossfade may I very kindly ask you to please provide the answers to the questions I posted above.

Many thanks!
-Eric

Hi Eric-

Just had a bad crossfade. Track stopped a few seconds early, then silence, then new track started. First track was 24/96 FLAC, second was 16/44 FLAC.

It does seem to correlate with changes in sample rate or bit depth.

Hi @James_I — Thank you for getting in touch and apologies for the tardiness on my end.

If the tracks are of the same sample rate/bit depth do yo notice the same behavior? The reason I ask is because as you can see from the link posted above (i.e “crossfade feature”) Roon will crossfade content when the content is the same sample rate/bit depth:

-Eric

Thanks Eric I was unaware of this limitation. I actually do think that I have seen crossfade fail even when the tracks are the same format.

However, I have a lot of hi res files and if crossfade doesn’t work when tracks are different sample rates or bit depth, I probably don’t want to use it - it makes for an inconsistent experience. I will turn it off. I was just hoping it would be fixed so it would work consistently. I guess that is not in the cards.

THAT SAID, there ought to be a way to make it work across different bit depths or sample rates, especially when one is upsampling…and given Roon’s stated perfectionism, I am kind of surprised that a half-done feature was even rolled out.

EDIT: half-done is not fair. Roon is a brilliant piece of software that really needs refinement in a number of areas, and that includes crossfade, which should be kind of high priority because it is something that you hear and notice with every track. Diamond in the rough, for sure.

2 Likes