Why is my max sample rate limited to 172 when my DAC can do 384

Roon 1.7 on imac
core sending output to ropieeexl on on rasptouch
My signal path shows DSD -> 352.8 (I’ve disabled native DSD playback due to ticking sounds I haven’t tracked down yet).
But then it gets re-encoded from 352.8 to 176.4.
Going to settings the max available selectable in roon is 192.
I’m sure I’m missing something but why can’t roon send 352.8khz out to the DAC?
Below are the DAC specs as well.

1 Like

Might be its limit when driven by a Linux box, probably need windows and the special USB drivers they gave written to get full specs.

well, the issue is probably with the Ropiee bridge unit since THAT is what is reporting capabilities back to Roon, not the Kitsune. How is it connected, USB,Coax, ?

i2s connection between the rasptouch and the holo spring.
Thanks for any ideas…

Buy an extra Micro SDcard and try VitOS by Silent Angel. Mind you it can only be a Roon Bridge. My DAC was detected native BDA-3 (usually requires drivers (Asio) in Mac or Windows).
You are running Ropieee XL which has extra streaming features so that might be limiting you…if you only use Roon Bridge try above or just Ropieee without XL.

Stay safe
Back to the music

Hey Jerry, I can’t seem to find this OS. Would you mind posting a link?

I found it but it only seems to be for raspberry pi 4. I’m at pi 3.

1 Like

I put ropieee on a different card, booted, configured. Seems to be same problems
(ticking on dsd playback and signal rate in roon limited to 176.)

I’m trying dietpi but it’s config looks complicated…

Just poking around, but did you check that sample rate conversion is turned off in Your zone’s DSP settings?

thanks for the idea but all DSP settings are off.

1 Like

Think they might want to consider using less names, especially not one that uses a plural for Vito and then the word Pi

That is correct link @Jose_Vita only for Pi 4b after using it I was quite happy to have purchased the 4. The 4 runs hot so consider a case with a fan that can be plugged into PIO bus if you install on 3.3v pins you won’t hear fan. I have read the Flirc Raspberry Pi 4 Case is good also as it acts like a giant heat sink if a fan worries you.

@Peter_Galvin1 have you checked with @spockfish to see if he has any idea’s?
Believe he has integrated a method in Ropieee so logs can be uploaded and provide him a code and might look to see what problem is…

Native DSD is known for causing pops and ticks when switching to and from it on some DACS. RME implemented fix (previous dac) also trying to bring to Bryston’s attention see if they can look at. Sure everyone is crazy busy getting back to work.

Now Peter looking at your device setup have you tried DOP or Native (if you have option) under DSD playback strategy? Native usually requires your DAC is known to to Linux or that a Win PC or Mac has Drivers usually Asio based. Otherwise you are limited like this. I have tried 4 devices from 3 manufactures and all have been detected with correct capabilities in Roon, Allo, RME, Bryston.
Lets see what Harry can do to help. Me tagging him should bring attention to your issue.

Thanks Jerry.
I tried DoP. I don’t see native…
Screen Shot 2020-07-03 at 3.28.05 PM

Hmm, maybe I’ll try building a Pi 4 system. But I do like the i2s output on the rasptouch so I’m sure it’d be complicated to build a similar one based on the 4 myself…

Hi, It shows as Disabled, but try changing the sample rate conversion filter and notice the changes. I found out yesterday, not sure if it is supposed to work like that.

Should have googled your device first.
RASPTOUCH I-SABRE ES9038Q2M Streamer with Touchscreen 32bit 384kHz DSD128.
I have Diet Pi on wifes Katana and here is screenshot on what I have read others select with that hardware. See if you have the option in red on Ropieee thought there was.
You can add touchscreens to any Pi device. Nice looking little rig almost bought one, went with Allo Katana instead.

If native was an option it would appear like this screenshot. This is from my DAC, VitOS connected.
There is no guarantee that your device would work with VitOS either Harry is in different time zones he is pretty good about support good luck.

Odd one. Only thing I can see is that maybe setting Volume Control (Device Setup) to Fixed Volume might help.
I use RopieeeXL and I have not come across this one. Is the Holo Audio a ladder dac? Perhaps it is a USB driver issue?

I changed it from device control to fixed and still have the same limitation.
@spockfish any other thoughts?

Can you send feedback?