Why is Roon ignoring my song genre tags?


(Greg Stratton) #37

This is very odd.

Do you have more than one device to control your music? If so, do they all have the same genre settings as in your screenshot?

Grasping at straws here.

Maybe see if it happens again and report back.

Others may have some suggestions as well.

Cheers, Greg


#38

The only devices I have with Roon control are my iPad mini 2 (latest iOS) which I use 99.9% of the time, and a desktop computer (PC Windows 10) which is rarely used. At the time the issue occurred I was using the iPad and the desktop was powered off.

To be sure I checked the Roon control settings on the desktop and verified they are the same as on the iPad.

Btw, I’m the only one in the household (only two of us) who uses Roon.

I’m just guessing, but it looks like since the Roon genre tags can be checked and unchecked that they may be a factor in the behavior I’m seeing (perhaps erroneously…a bug?).


#39

Is this a bug?

Anyone? :frowning:


(Greg Stratton) #40

Hi James,

I’ve tried, and failed, to reproduce this issue.

Could you try again and track what steps you take when it happens? ie. what genre you focus on, whether you select Play or Radio, what genre played that shouldn’t, etc.

Also, we can flag @support and see if anyone else has run into this issue.

Cheers, Greg


#41

Yes, I’ll try it again when I get a chance and let you know what happens. Unfortunately I don’t get to listen as much as I would like…sigh.

Last time I touched the 3 bars at the upper left corner of the screen, under Browse I selected Genres, then selected the Pop/Rock genre, then selected Play Genre, then selected Play Now. I noticed that it played at least one track, and I think more, from an album that only has an Opera genre tag in the file. But as you saw in my screenshots, Roon had other genre tags associated with it when you look in Album Editor.

Am I correct that since In settings I have it set only to display my file tag genres (not Roon’s) that it should only play tracks from albums that have the selected genre file tag? In other words, if I select to play the Pop/Rock genre, it should only play tracks from albums that have the Pop/Rock genre tag in the file (again, not from Roon’s tags)? Do I understand this correctly? Btw, I do understand that currently Roon does not use tags at track level, just album level.

Thank you again for your time and help.


(Greg Stratton) #42

Hi James,

Ah ha! I think you found a bug!

The information you provided allowed me to reproduce the issue. From what I understand, if you select the Genre Browser, select your genre and click Play Genre then Play Now, it should only play albums that have that genre in your tags. Instead it plays albums that contain that genre under Roon Genres.

I will summarize the issue so @support can investigate.

  1. In Settings, use Roon Genres set to No
  2. In Settings, Show Genres from File Tags set to Yes. So Roon Genres are not being used at all
  3. Navigate to Genre Browser. Select a genre. Click Play Genre and then Play Now.
  4. Roon will play albums that have that genre in Roon Genres, even though you don’t use Roon genres.

Also, if you go into Album Browser and Focus on a Genre and click Play Now, it works as expected.

Hope that’s correct and makes sense.

Cheers, Greg


#43

Your summary looks correct.

Do I understand you correctly that if I instead go into Album Browser and Focus on a Genre and click Play Now it will work as it should? I’ve never tried that method of playing by genre.

I’'m happy to hear you were able to reproduce this issue. Hopefully it’s an easy fix. :slight_smile:


(Greg Stratton) #44

Hi James,

Yes, I use Focus all the time. It’s a lot more flexible, allowing you to focus in on a lot more than just one genre.

For example, you can select a genre or multiple genres, select a date range (ie 1970-1980) and file format (ie hires). You get the idea.

Also, by clicking on the + of a selected genre and making it a - you can exclude something too.

If you find that there’s a Focus you use often, then save it as a Bookmark. Once you have your focus results showing, click the Bookmark icon in the top right of the screen next to the search and click Add Bookmark and give it a name. Every time you select it, it will bring up the screen with refreshed results.

Cheers, Greg


(Mike) #45

I believe so :tada:

We’re going to confirm this and make sure it’s resolved for our next release. Thanks for the report @James_Kirkman!


#46

Thanks for the great tips, Greg. :slight_smile:


#47

Thanks Mike. I appreciate the support. :slight_smile:


#48

Any progress on identifying the bug and fixing it?


(Eric Stewart) #49

Hi @James_Kirkman ----- I wanted to touch base with you real quick to confirm that this issue is resolved for our next release, but we do not have a firm release date yet.

Thanks!
-Eric


#50

Good to hear it’s been fixed.

Thank you for the update. :slight_smile:


#51

Did the recent build 165 release fix this? I didn’t see it mentioned in the release notes.

I don’t have access to my system at the moment to test it (recovering from surgery).

Thanks. :slight_smile:


(Greg Stratton) #52

Hi James,

Apparently not yet. Just tested and the issue is still there.

It may be in the version 1.3 release. Don’t know when that will be.

Cheers, Greg


#53

:frowning:


#54

Was this fixed in 1.3?

I can’t test it right now because I’m having another problem since updating this morning.


(Greg Stratton) #55

Hi James,

I believe it was fixed. Give it a try when you can and let us know if you’re still having issues.

Cheers, Greg


#56

Thanks Greg. Hopefully it won’t take too long to fix my other issue. Right now Roon cant see my music collection. I have another thread going about this.